summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDalon Westergreen <dwesterg@gmail.com>2019-09-18 15:03:49 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-20 18:39:32 -0700
commitd67906c96a1cec7e2780b03e4b941615d37721ee (patch)
tree5e0c75108443528ba187e02723c276952b2db427
parent87fe6e18e5c23ab8031ed9f19d3a4688fb069699 (diff)
downloadmeta-altera-d67906c96a1cec7e2780b03e4b941615d37721ee.tar.gz
Add support for u-boot-socfpga 2019.04
2019.04 is now the officially supported u-boot for all socfpga platforms. Signed-off-by: Dalon Westergreen <dwesterg@gmail.com>
-rw-r--r--conf/machine/arria10.conf2
-rw-r--r--conf/machine/arria5.conf2
-rw-r--r--conf/machine/cyclone5.conf2
-rw-r--r--conf/machine/include/socfpga_armv8a.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga-common.inc7
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb7
6 files changed, 13 insertions, 9 deletions
diff --git a/conf/machine/arria10.conf b/conf/machine/arria10.conf
index 249edcc..3fd23c1 100644
--- a/conf/machine/arria10.conf
+++ b/conf/machine/arria10.conf
@@ -4,8 +4,6 @@
4 4
5require conf/machine/include/socfpga.inc 5require conf/machine/include/socfpga.inc
6 6
7PREFERRED_VERSION_u-boot-socfpga ?= "v2019.07%"
8
9SPL_BINARY = "u-boot-with-spl.sfp" 7SPL_BINARY = "u-boot-with-spl.sfp"
10UBOOT_BINARY = "u-boot-dtb.img" 8UBOOT_BINARY = "u-boot-dtb.img"
11 9
diff --git a/conf/machine/arria5.conf b/conf/machine/arria5.conf
index 01cc58b..0110fb1 100644
--- a/conf/machine/arria5.conf
+++ b/conf/machine/arria5.conf
@@ -4,8 +4,6 @@
4 4
5require conf/machine/include/socfpga.inc 5require conf/machine/include/socfpga.inc
6 6
7PREFERRED_VERSION_u-boot-socfpga ?= "v2019.01%"
8
9UBOOT_CONFIG ??= "arria5-socdk" 7UBOOT_CONFIG ??= "arria5-socdk"
10 8
11UBOOT_CONFIG[arria5-socdk] = "socfpga_arria5_defconfig" 9UBOOT_CONFIG[arria5-socdk] = "socfpga_arria5_defconfig"
diff --git a/conf/machine/cyclone5.conf b/conf/machine/cyclone5.conf
index c66af25..a9c45ef 100644
--- a/conf/machine/cyclone5.conf
+++ b/conf/machine/cyclone5.conf
@@ -4,8 +4,6 @@
4 4
5require conf/machine/include/socfpga.inc 5require conf/machine/include/socfpga.inc
6 6
7PREFERRED_VERSION_u-boot-socfpga ?= "v2019.01%"
8
9UBOOT_CONFIG ??= "cyclone5-socdk" 7UBOOT_CONFIG ??= "cyclone5-socdk"
10 8
11UBOOT_CONFIG[cyclone5-socdk] = "socfpga_cyclone5_defconfig" 9UBOOT_CONFIG[cyclone5-socdk] = "socfpga_cyclone5_defconfig"
diff --git a/conf/machine/include/socfpga_armv8a.inc b/conf/machine/include/socfpga_armv8a.inc
index e6307a7..150e3f2 100644
--- a/conf/machine/include/socfpga_armv8a.inc
+++ b/conf/machine/include/socfpga_armv8a.inc
@@ -8,7 +8,7 @@ MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
8PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-socfpga" 8PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-socfpga"
9PREFERRED_PROVIDER_u-boot ?= "u-boot-socfpga" 9PREFERRED_PROVIDER_u-boot ?= "u-boot-socfpga"
10 10
11SPL_BINARY = "spl/u-boot-spl.hex" 11SPL_BINARY = "spl/u-boot-spl-dtb.hex"
12UBOOT_SUFFIX = "img" 12UBOOT_SUFFIX = "img"
13UBOOT_BINARY = "u-boot.img" 13UBOOT_BINARY = "u-boot.img"
14UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}" 14UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
diff --git a/recipes-bsp/u-boot/u-boot-socfpga-common.inc b/recipes-bsp/u-boot/u-boot-socfpga-common.inc
index 06f0992..2038545 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga-common.inc
+++ b/recipes-bsp/u-boot/u-boot-socfpga-common.inc
@@ -1,9 +1,12 @@
1HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome" 1HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
2SECTION = "bootloaders" 2SECTION = "bootloaders"
3DEPENDS += "flex-native bison-native"
3 4
4PV_append = "+git${SRCPV}" 5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
7PE = "1"
5 8
6SRC_URI = "git://git.denx.de/u-boot.git;branch=master" 9PV_append = "+git${SRCPV}"
7 10
8S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
9 12
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb
new file mode 100644
index 0000000..f9e1afc
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb
@@ -0,0 +1,7 @@
1require u-boot-socfpga-common.inc
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3
4SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2019.04"
5SRCREV = "bc38a09daa09e73b075006d8006caa84bb2fe0fe"
6
7DEPENDS += "dtc-native bc-native u-boot-mkimage-native"