summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com>2020-08-06 12:12:24 +0800
committerKhem Raj <raj.khem@gmail.com>2020-08-06 21:59:17 -0700
commitd11f5df392fbdc2ef5ebb4cc0da04e56bf1b50d9 (patch)
tree7af316d6dcc8f7456fa99ce2738d66536dd06959
parent846f22156ae8694c789582ce7c5536a6b77e8e52 (diff)
downloadmeta-altera-d11f5df392fbdc2ef5ebb4cc0da04e56bf1b50d9.tar.gz
u-boot: move common variables into u-boot-socfpga-common.inc
This should provide more flexibility in controlling the u-boot build for SoCFPGA products. We would like to adopt the similar approach as the linux-altera.inc to gain control on some variables when building u-boot recipe. The versioned recipes will then be much simpler to maintain. Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga-common.inc15
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb6
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb6
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb6
4 files changed, 20 insertions, 13 deletions
diff --git a/recipes-bsp/u-boot/u-boot-socfpga-common.inc b/recipes-bsp/u-boot/u-boot-socfpga-common.inc
index def29fa..80b4752 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga-common.inc
+++ b/recipes-bsp/u-boot/u-boot-socfpga-common.inc
@@ -1,17 +1,30 @@
1HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome" 1HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
2SECTION = "bootloaders" 2SECTION = "bootloaders"
3DEPENDS += "flex-native bison-native" 3DEPENDS += "flex-native bison-native dtc-native bc-native u-boot-mkimage-native"
4 4
5LICENSE = "GPLv2+" 5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" 6LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
7PE = "1" 7PE = "1"
8 8
9require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
10
11UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git"
12UBOOT_PROT ?= "https"
13
14UBOOT_VERSION_PREFIX ?= "socfpga_"
15UBOOT_VERSION ?= "v2019.10"
16UBOOT_BRANCH ?= "${UBOOT_VERSION_PREFIX}${UBOOT_VERSION}"
17
18SRCREV ?= "${AUTOREV}"
9PV_append = "+git${SRCPV}" 19PV_append = "+git${SRCPV}"
10 20
11S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22B = "${WORKDIR}/build"
12 23
13RPROVIDES_${PN} += "u-boot" 24RPROVIDES_${PN} += "u-boot"
14 25
26SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}"
27
15UBOOT_CONFIG[agilex-socdk] = "socfpga_agilex_defconfig" 28UBOOT_CONFIG[agilex-socdk] = "socfpga_agilex_defconfig"
16UBOOT_CONFIG[agilex-socdk-qspi] = "socfpga_agilex_qspi_defconfig" 29UBOOT_CONFIG[agilex-socdk-qspi] = "socfpga_agilex_qspi_defconfig"
17UBOOT_CONFIG[stratix10-socdk] = "socfpga_stratix10_defconfig" 30UBOOT_CONFIG[stratix10-socdk] = "socfpga_stratix10_defconfig"
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb
index 790eca1..01f3fa4 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb
@@ -1,7 +1,5 @@
1require u-boot-socfpga-common.inc 1require u-boot-socfpga-common.inc
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3 2
4SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2019.04" 3UBOOT_VERSION = "v2019.04"
5SRCREV = "6296fdb7da9e205bc34416f38631715fb6d74e71"
6 4
7DEPENDS += "dtc-native bc-native u-boot-mkimage-native" 5SRCREV = "6296fdb7da9e205bc34416f38631715fb6d74e71"
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb
index a42659a..7b8af58 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb
@@ -1,7 +1,5 @@
1require u-boot-socfpga-common.inc 1require u-boot-socfpga-common.inc
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3 2
4SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2019.10" 3UBOOT_VERSION = "v2019.10"
5SRCREV = "34638cc921269665e43340a50552302bd358f793"
6 4
7DEPENDS += "dtc-native bc-native u-boot-mkimage-native" 5SRCREV = "34638cc921269665e43340a50552302bd358f793"
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb
index 5e3d99b..fac30e4 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb
@@ -1,7 +1,5 @@
1require u-boot-socfpga-common.inc 1require u-boot-socfpga-common.inc
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3 2
4SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2020.04" 3UBOOT_VERSION = "v2020.04"
5SRCREV = "2cbc36afbb31bee6e245291c51c283dbde0e3b89"
6 4
7DEPENDS += "dtc-native bc-native u-boot-mkimage-native" 5SRCREV = "2cbc36afbb31bee6e245291c51c283dbde0e3b89"