summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com>2020-09-04 15:57:33 +0000
committerKhem Raj <raj.khem@gmail.com>2020-09-08 23:30:37 -0700
commitc6747a8981a50968c9a00cfed4a33585b83e6055 (patch)
tree53b713447d2dc77c2b662a700662e31c7c0dfde0
parent87415b166e76b70f2151cbf212ee912c4444b980 (diff)
downloadmeta-altera-c6747a8981a50968c9a00cfed4a33585b83e6055.tar.gz
add recipe for arm-trusted-firmware
Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com>
-rw-r--r--recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc45
-rw-r--r--recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb3
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc
new file mode 100644
index 0000000..43d412d
--- /dev/null
+++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc
@@ -0,0 +1,45 @@
1DESCRIPTION = "ARM Trusted Firmware"
2
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://docs/license.rst;md5=189505435dbcdcc8caa63c46fe93fa89"
5
6PROVIDES += "arm-trusted-firmware"
7
8DEPENDS += "u-boot-tools"
9
10inherit deploy
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14PROT ?= "https"
15BRANCH ?= "socfpga_v2.3"
16SRC_URI ?= "git://github.com/altera-opensource/arm-trusted-firmware.git;protocol=${PROT};branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
19
20COMPATIBLE_MACHINE = "(agilex|stratix10)"
21ATFPLAT = "${MACHINE}"
22
23# Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application
24EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" PLAT="${ATFPLAT}" DEPRECATED=1 HANDLE_EA_EL3_FIRST=1'
25CFLAGS[unexport] = "1"
26LDFLAGS[unexport] = "1"
27AS[unexport] = "1"
28LD[unexport] = "1"
29PARALLEL_MAKE = ""
30
31ALLOW_EMPTY_${PN} = "1"
32
33do_configure[noexec] = "1"
34
35do_compile() {
36 oe_runmake -C ${S} bl31
37}
38
39do_deploy() {
40 install -d ${DEPLOYDIR}
41 install -m 0644 ${S}/build/${ATFPLAT}/release/bl31.bin ${DEPLOYDIR}/bl31.bin-${MACHINE}-${PV}-${PR}
42 ln -sf bl31.bin-${MACHINE}-${PV}-${PR} ${DEPLOYDIR}/bl31.bin
43}
44
45addtask deploy after do_compile
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
new file mode 100644
index 0000000..509c8a4
--- /dev/null
+++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
@@ -0,0 +1,3 @@
1require arm-trusted-firmware.inc
2
3SRCREV = "a124a308dc3125480ca9c746afb48007d9a7ffce"