summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-08-10 20:24:09 +0200
committerKhem Raj <raj.khem@gmail.com>2017-08-10 12:24:10 -0700
commit37ca0f7ab398e2e5bc61bd163b0bc16df535160f (patch)
treec19367072efd45a26869d58ba8fe472eddf1e1c5
parent12d7066b3c79461538a2996d4ee15d9e67705061 (diff)
downloadmeta-altera-37ca0f7ab398e2e5bc61bd163b0bc16df535160f.tar.gz
Fix build with YP pyro
Mainly fix the u-boot build by: - changing u-boot-mkenvimage to use $(CC) instead of cc - adding bc-native to u-boot-socfpga due to RS-sysroot in YP Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-bsp/u-boot/files/0001-Fix-native-build-by-using-env-variables.patch31
-rw-r--r--recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb2
3 files changed, 34 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/files/0001-Fix-native-build-by-using-env-variables.patch b/recipes-bsp/u-boot/files/0001-Fix-native-build-by-using-env-variables.patch
new file mode 100644
index 0000000..5443bce
--- /dev/null
+++ b/recipes-bsp/u-boot/files/0001-Fix-native-build-by-using-env-variables.patch
@@ -0,0 +1,31 @@
1From 5aa1e2d99a26f1cab1774fa1e94b53de42897d1c Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <jsmoeller@linuxfoundation.org>
3Date: Thu, 10 Aug 2017 19:36:21 +0200
4Subject: [PATCH] Fix native build by using env variables
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
10---
11 Makefile | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/Makefile b/Makefile
15index 8ca1db5..fef1059 100644
16--- a/Makefile
17+++ b/Makefile
18@@ -254,8 +254,8 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
19 else if [ -x /bin/bash ]; then echo /bin/bash; \
20 else echo sh; fi ; fi)
21
22-HOSTCC = cc
23-HOSTCXX = c++
24+HOSTCC = $(CC)
25+HOSTCXX = $(CXX)
26 HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
27 $(if $(CONFIG_TOOLS_DEBUG),-g)
28 HOSTCXXFLAGS = -O2
29--
302.1.4
31
diff --git a/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb b/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
index e90e5f1..19ea6c6 100644
--- a/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
+++ b/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
@@ -8,7 +8,8 @@ LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
8 8
9PV_append = "+git${SRCPV}" 9PV_append = "+git${SRCPV}"
10 10
11SRC_URI = "git://git.denx.de/u-boot.git;branch=master" 11SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
12SRC_URI += "file://0001-Fix-native-build-by-using-env-variables.patch"
12 13
13S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
14 15
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb
index be33fa2..9d47e72 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb
@@ -16,5 +16,5 @@ SRC_URI_append = "\
16 file://cyclone5-socdk.env \ 16 file://cyclone5-socdk.env \
17 " 17 "
18 18
19DEPENDS += "dtc-native" 19DEPENDS += "dtc-native bc-native"
20DEPENDS += "u-boot-mkimage-native" 20DEPENDS += "u-boot-mkimage-native"