summaryrefslogtreecommitdiffstats
path: root/recipes-jailhouse/jailhouse/files/0003-workaround-if-changed-problem-in-tools-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-jailhouse/jailhouse/files/0003-workaround-if-changed-problem-in-tools-makefile.patch')
-rw-r--r--recipes-jailhouse/jailhouse/files/0003-workaround-if-changed-problem-in-tools-makefile.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-jailhouse/jailhouse/files/0003-workaround-if-changed-problem-in-tools-makefile.patch b/recipes-jailhouse/jailhouse/files/0003-workaround-if-changed-problem-in-tools-makefile.patch
new file mode 100644
index 0000000..7d02b55
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/files/0003-workaround-if-changed-problem-in-tools-makefile.patch
@@ -0,0 +1,18 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile
4+++ git/tools/Makefile
5@@ -55,10 +55,11 @@ endef
6 targets += jailhouse.o
7
8 $(obj)/jailhouse: $(obj)/jailhouse.o
9- $(call if_changed,ld)
10+ $(LD) $(LDFLAGS) -o $@ $^
11
12 $(obj)/jailhouse-config-collect: $(src)/jailhouse-config-create $(src)/jailhouse-config-collect.tmpl
13- $(call if_changed,gen_collect)
14+ $< -g $@; \
15+ chmod +x $@
16
17 install-bin: $(BINARIES) $(DESTDIR)$(sbindir)
18 $(INSTALL_PROGRAM) $^