summaryrefslogtreecommitdiffstats
path: root/recipes-jailhouse/freertos-cell/freertos-cell_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-jailhouse/freertos-cell/freertos-cell_1.0.bb')
-rw-r--r--recipes-jailhouse/freertos-cell/freertos-cell_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-jailhouse/freertos-cell/freertos-cell_1.0.bb b/recipes-jailhouse/freertos-cell/freertos-cell_1.0.bb
new file mode 100644
index 0000000..a61dd80
--- /dev/null
+++ b/recipes-jailhouse/freertos-cell/freertos-cell_1.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "FreeRTOS for Jailhouse"
2HOMEPAGE = "https://github.com/siemens/freertos-cell"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://freertos/License/license.txt;md5=ff3ee34806c13760712131849e183a35\
6 file://LICENSE;md5=494a529748a63071fbdf44f61db2391c"
7
8DEPENDS = "virtual/kernel make-native"
9
10SRC_URI = "git://github.com/siemens/freertos-cell.git;protocol=https;branch=master; \
11 file://Fix-Makefile.patch \
12 file://Remove-check-of-interrupt-mask.patch \
13 file://Bananapi-config-fix-for-Jailhouse-0.6.patch"
14
15SRCREV = "6ad80637be066d196d81c1640bc1bd5b66e0ec45"
16
17S ="${WORKDIR}/git"
18
19inherit jailhouse-cell
20
21INMATE = "${S}/freertos-demo.bin"
22CELLCONFIG = "${S}/jailhouse-configs/bananapi-freertos-demo.c"
23CELLCONFIG_TARGET = "freertos-cell.c"
24
25
26do_compile() {
27 LDFLAGS="" oe_runmake
28}