summaryrefslogtreecommitdiffstats
path: root/recipes-jailhouse/freertos-cell/freertos-cell/Fix-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-jailhouse/freertos-cell/freertos-cell/Fix-Makefile.patch')
-rw-r--r--recipes-jailhouse/freertos-cell/freertos-cell/Fix-Makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-jailhouse/freertos-cell/freertos-cell/Fix-Makefile.patch b/recipes-jailhouse/freertos-cell/freertos-cell/Fix-Makefile.patch
new file mode 100644
index 0000000..c680b03
--- /dev/null
+++ b/recipes-jailhouse/freertos-cell/freertos-cell/Fix-Makefile.patch
@@ -0,0 +1,22 @@
1diff --git a/Makefile b/Makefile
2index d49c25f..f9d295a 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -4,12 +4,12 @@ src = $(CURDIR)
6
7 CROSS_COMPILE ?= arm-linux-gnueabihf-
8
9-CC = $(CROSS_COMPILE)gcc
10-LD = $(CROSS_COMPILE)ld
11-AR = $(CROSS_COMPILE)ar
12-OBJCOPY = $(CROSS_COMPILE)objcopy
13+#CC = $(CROSS_COMPILE)gcc
14+#LD = $(CROSS_COMPILE)ld
15+#AR = $(CROSS_COMPILE)ar
16+#OBJCOPY = $(CROSS_COMPILE)objcopy
17
18-CFLAGS += -mcpu=cortex-a7 -mtune=cortex-a7 -mfpu=vfpv4-d16 -mfloat-abi=hard -O2
19+CFLAGS += -mcpu=cortex-a7 -mtune=cortex-a7 -mfpu=vfpv4-d16 -mfloat-abi=hard -O0
20 CFLAGS += -DCONFIG_MACH_SUN7I=1
21 CFLAGS += -Wall -MMD -pipe
22 CFLAGS += -I $(src) -I $(src)/freertos/Source/include -I $(src)/freertos-runtime -I $(src)/freertos/Source/portable/GCC/ARM_A7jailhouse