summaryrefslogtreecommitdiffstats
path: root/recipes-jailhouse/jailhouse/jailhouse-0.8
diff options
context:
space:
mode:
authorOla Redell <ola.redell@retotech.se>2017-12-29 22:38:57 +0100
committerOla Redell <ola.redell@retotech.se>2017-12-29 22:38:57 +0100
commitae7608e59c336d97d550ba4c08a927b58d3703e7 (patch)
tree1051015216f875a255db498a6b6f94ef7b8c8999 /recipes-jailhouse/jailhouse/jailhouse-0.8
parenta4a0e54936cbd80439fe9d524fbb4653664d8959 (diff)
parente15d02bbaa82aeb346e6e1cc14569677f202f6ba (diff)
downloadmeta-jailhouse-ae7608e59c336d97d550ba4c08a927b58d3703e7.tar.gz
Merged jailhouse-0.8 into master
Diffstat (limited to 'recipes-jailhouse/jailhouse/jailhouse-0.8')
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.8/0004-no-kbuild-of-tools.patch13
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.8/0005-tools-makefile.patch36
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.8/0004-no-kbuild-of-tools.patch b/recipes-jailhouse/jailhouse/jailhouse-0.8/0004-no-kbuild-of-tools.patch
new file mode 100644
index 0000000..30d3b6d
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/jailhouse-0.8/0004-no-kbuild-of-tools.patch
@@ -0,0 +1,13 @@
1Index: git/Kbuild
2===================================================================
3--- git.orig/Kbuild
4+++ git/Kbuild
5@@ -53,7 +53,7 @@ $(obj)/driver $(obj)/hypervisor: $(GEN_V
6
7 endif
8
9-subdir-y := driver hypervisor configs inmates tools
10+subdir-y := driver hypervisor configs inmates
11
12 subdir-ccflags-y := -Werror
13
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.8/0005-tools-makefile.patch b/recipes-jailhouse/jailhouse/jailhouse-0.8/0005-tools-makefile.patch
new file mode 100644
index 0000000..ea041a9
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/jailhouse-0.8/0005-tools-makefile.patch
@@ -0,0 +1,36 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile
4+++ git/tools/Makefile
5@@ -19,7 +19,7 @@ LINUXINCLUDE := -I$(src)/../driver
6 KBUILD_CFLAGS := -g -O3 -DLIBEXECDIR=\"$(libexecdir)\" \
7 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes -Werror \
8 -DJAILHOUSE_VERSION=\"$(shell cat $(src)/../VERSION)\" $(EXTRA_CFLAGS)
9-LDFLAGS :=
10+
11 GCOV_PROFILE := n
12
13 BINARIES := jailhouse
14@@ -57,7 +57,7 @@ endef
15 targets += jailhouse.o
16
17 $(obj)/jailhouse: $(obj)/jailhouse.o
18- $(call if_changed,ld)
19+ $(LD) $(LDFLAGS) -o $@ $^
20
21 CFLAGS_jailhouse-gcov-extract.o := -I$(src)/../hypervisor/include \
22 -I$(src)/../hypervisor/arch/$(SRCARCH)/include
23@@ -68,10 +68,11 @@ targets += jailhouse-gcov-extract.o
24 always += jailhouse-gcov-extract
25
26 $(obj)/jailhouse-gcov-extract: $(obj)/jailhouse-gcov-extract.o
27- $(call if_changed,ld)
28+ $(LD) $(LDFLAGS) -o $@ $^
29
30 $(obj)/jailhouse-config-collect: $(src)/jailhouse-config-create $(src)/jailhouse-config-collect.tmpl
31- $(call if_changed,gen_collect)
32+ $< -g $@; \
33+ chmod +x $@
34
35 install-bin: $(BINARIES) $(DESTDIR)$(sbindir)
36 $(INSTALL_PROGRAM) $^