summaryrefslogtreecommitdiffstats
path: root/recipes-jailhouse/jailhouse/jailhouse-0.6
diff options
context:
space:
mode:
authorOla Redell <ola.redell@retotech.se>2017-12-29 22:38:57 +0100
committerOla Redell <ola.redell@retotech.se>2017-12-29 22:38:57 +0100
commitae7608e59c336d97d550ba4c08a927b58d3703e7 (patch)
tree1051015216f875a255db498a6b6f94ef7b8c8999 /recipes-jailhouse/jailhouse/jailhouse-0.6
parenta4a0e54936cbd80439fe9d524fbb4653664d8959 (diff)
parente15d02bbaa82aeb346e6e1cc14569677f202f6ba (diff)
downloadmeta-jailhouse-ae7608e59c336d97d550ba4c08a927b58d3703e7.tar.gz
Merged jailhouse-0.8 into master
Diffstat (limited to 'recipes-jailhouse/jailhouse/jailhouse-0.6')
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.6/0002-no-ldflags-in-tools.patch13
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch18
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.6/0004-no-kbuild-of-tools.patch13
3 files changed, 0 insertions, 44 deletions
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.6/0002-no-ldflags-in-tools.patch b/recipes-jailhouse/jailhouse/jailhouse-0.6/0002-no-ldflags-in-tools.patch
deleted file mode 100644
index e94f69d..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse-0.6/0002-no-ldflags-in-tools.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1diff --git a/tools/Makefile b/tools/Makefile
2index 4d91e7a..ecc5503 100644
3--- a/tools/Makefile
4+++ b/tools/Makefile
5@@ -19,7 +19,7 @@ LINUXINCLUDE := -I$(src)/../driver
6 KBUILD_CFLAGS := -g -O3 -DLIBEXECDIR=\"$(libexecdir)\" \
7 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes -Werror \
8 -DJAILHOUSE_VERSION=\"$(shell cat $(src)/../VERSION)\" $(EXTRA_CFLAGS)
9-LDFLAGS :=
10+#LDFLAGS := $(EXTRA_LDLAGS)
11
12 BINARIES := jailhouse
13 HELPERS := \
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch b/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch
deleted file mode 100644
index 7d02b55..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch
+++ /dev/null
@@ -1,18 +0,0 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile
4+++ git/tools/Makefile
5@@ -55,10 +55,11 @@ endef
6 targets += jailhouse.o
7
8 $(obj)/jailhouse: $(obj)/jailhouse.o
9- $(call if_changed,ld)
10+ $(LD) $(LDFLAGS) -o $@ $^
11
12 $(obj)/jailhouse-config-collect: $(src)/jailhouse-config-create $(src)/jailhouse-config-collect.tmpl
13- $(call if_changed,gen_collect)
14+ $< -g $@; \
15+ chmod +x $@
16
17 install-bin: $(BINARIES) $(DESTDIR)$(sbindir)
18 $(INSTALL_PROGRAM) $^
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.6/0004-no-kbuild-of-tools.patch b/recipes-jailhouse/jailhouse/jailhouse-0.6/0004-no-kbuild-of-tools.patch
deleted file mode 100644
index 4e0f337..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse-0.6/0004-no-kbuild-of-tools.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: git/Kbuild
2===================================================================
3--- git.orig/Kbuild
4+++ git/Kbuild
5@@ -11,7 +11,7 @@
6 # the COPYING file in the top-level directory.
7 #
8
9-subdir-y := driver hypervisor configs inmates tools
10+subdir-y := driver hypervisor configs inmates
11
12 subdir-ccflags-y := -Werror
13