summaryrefslogtreecommitdiffstats
path: root/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch
diff options
context:
space:
mode:
authorOla Redell <ola.redell@retotech.se>2017-11-15 21:54:39 +0100
committerOla Redell <ola.redell@retotech.se>2017-11-15 21:54:39 +0100
commit3af813eaa50cc3bf5192c0218cf7e779f9f5af01 (patch)
treedfb2fa235941f723cca0c9b1347fe04597d4bfb8 /recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch
parentf2cccf9409c91a33c4394ca4cfafe1cc00f9ce21 (diff)
downloadmeta-jailhouse-3af813eaa50cc3bf5192c0218cf7e779f9f5af01.tar.gz
Default Jailhouse configuration, add new jailhouse versions
Added variable JH_CONFIG that is used to point to current jailhouse hypervisor configuration. Added recipes for jailhouse version 0.7 and a _git recipe that tracks HEAD on master.
Diffstat (limited to 'recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch')
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch b/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch
new file mode 100644
index 0000000..7d02b55
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch
@@ -0,0 +1,18 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile
4+++ git/tools/Makefile
5@@ -55,10 +55,11 @@ endef
6 targets += jailhouse.o
7
8 $(obj)/jailhouse: $(obj)/jailhouse.o
9- $(call if_changed,ld)
10+ $(LD) $(LDFLAGS) -o $@ $^
11
12 $(obj)/jailhouse-config-collect: $(src)/jailhouse-config-create $(src)/jailhouse-config-collect.tmpl
13- $(call if_changed,gen_collect)
14+ $< -g $@; \
15+ chmod +x $@
16
17 install-bin: $(BINARIES) $(DESTDIR)$(sbindir)
18 $(INSTALL_PROGRAM) $^