summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-11-25 06:42:43 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:36:56 (GMT)
commit552169e89aea5706100a67f1f1e68a85600e1105 (patch)
treeba6246d958abd1c3d2ece313000c384f13436d9b /meta/recipes-gnome/gtk+
parent8f23c1413ad12e60e98f9887cafa4315db7b62a2 (diff)
downloadpoky-552169e89aea5706100a67f1f1e68a85600e1105.tar.gz
gdk-pixbuf: Add 2.22.1 as new recipe
Updating gtk+ to 2.23.2 requires gdk-pixbuf, which is originaly a module in gtk+. Borrow hardcoded_libtool.patch from original gtk+, and add configure_fix.patch to fix build failure in cross-compile environment. As gdk-pixbuf is a stand-alone package now, gdk-pixbuf-csource-native can be safely removed. So extend gdk-pixbuf with native support, and make related packages depend on it. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-gnome/gtk+')
-rw-r--r--meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb37
-rw-r--r--meta/recipes-gnome/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch221
2 files changed, 0 insertions, 258 deletions
diff --git a/meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb b/meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb
deleted file mode 100644
index 0c8506a..0000000
--- a/meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1require gtk+_${PV}.bb
2inherit native
3DEPENDS = "jpeg-native libpng-native gettext-native glib-2.0-native libx11-native"
4S = "${WORKDIR}/gtk+-${PV}"
5FILESPATH = "${FILE_DIRNAME}/gdk-pixbuf-csource:${FILE_DIRNAME}/gtk+-${PV}:${FILE_DIRNAME}/files"
6SRC_URI += "file://reduce-dependencies.patch;patch=1"
7PR = "r13"
8
9#clear recommends for uclibc builds
10RRECOMMENDS_${PN} = " "
11RRECOMMENDS_${PN}_linux = " "
12RRECOMMENDS_${PN}_linux-gnueabi = " "
13
14EXTRA_OECONF = "\
15 --with-gdktarget=x11 \
16 --without-libtiff \
17 --with-libjpeg \
18 --with-libpng \
19 --x-includes=${STAGING_INCDIR} \
20 --x-libraries=${STAGING_LIBDIR} \
21"
22
23PACKAGES_DYNAMIC = ""
24
25do_compile() {
26 cd gdk-pixbuf && oe_runmake
27}
28
29do_install() {
30 cd gdk-pixbuf
31 oe_runmake 'DESTDIR=${D}' install
32 install -d ${D}${sysconfdir}/gtk-2.0
33 GDK_PIXBUF_MODULEDIR=${D}${libdir}/gtk-2.0/2.10.0/loaders ${D}${bindir}/gdk-pixbuf-query-loaders > ${D}${sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
34 sed -i -e 's#${D}##g' ${D}${sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
35 find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
36}
37
diff --git a/meta/recipes-gnome/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch b/meta/recipes-gnome/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch
deleted file mode 100644
index 6b030e8..0000000
--- a/meta/recipes-gnome/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch
+++ /dev/null
@@ -1,221 +0,0 @@
1#
2# strip unnecessary stuff out of configure, we just want
3# to build gdk-pixbuf-csource.
4# -- Michael 'Mickey' Lauer <mlauer@vanille-media.de>
5#
6---
7# configure.in | 116 ++---------------------------------------------------------
8# 1 file changed, 5 insertions(+), 111 deletions(-)
9#
10--- gtk+-2.12.7.orig/configure.in
11+++ gtk+-2.12.7/configure.in
12@@ -30,13 +30,10 @@ m4_define([gtk_api_version], [2.0])
13 #GTK_BINARY_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$LT_CURRENT
14 m4_define([gtk_binary_version], [2.10.0])
15
16 # required versions of other packages
17 m4_define([glib_required_version], [2.13.5])
18-m4_define([pango_required_version], [1.17.3])
19-m4_define([atk_required_version], [1.9.0])
20-m4_define([cairo_required_version], [1.2.0])
21
22
23 AC_INIT([gtk+], [gtk_version],
24 [http://bugzilla.gnome.org/enter_bug.cgi?product=gtk%2B],
25 [gtk+])
26@@ -347,14 +344,11 @@ ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
27 ## Later on we actually use the cflags/libs from separate pkg-config
28 ## calls. Oh, also the later pkg-config calls don't include
29 ## the version requirements since those make the module lists
30 ## annoying to construct
31 PKG_CHECK_MODULES(BASE_DEPENDENCIES,
32- [glib-2.0 >= glib_required_version dnl
33- atk >= atk_required_version dnl
34- pango >= pango_required_version dnl
35- cairo >= cairo_required_version])
36+ [glib-2.0 >= glib_required_version])
37
38 if test "$os_win32" != yes; then
39 # libtool option to control which symbols are exported
40 # right now, symbols starting with _ are not exported
41 LIBTOOL_EXPORT_OPTIONS='-export-symbols-regex "^[[^_]].*"'
42@@ -1059,27 +1053,19 @@ GDK_PIXBUF_DEP_CFLAGS="`$PKG_CONFIG --cf
43
44 GDK_PIXBUF_XLIB_PACKAGES=
45 GDK_PIXBUF_XLIB_EXTRA_CFLAGS=
46 GDK_PIXBUF_XLIB_EXTRA_LIBS=
47
48-X_PACKAGES=fontconfig
49+X_PACKAGES=
50 GDK_EXTRA_LIBS="$GDK_WLIBS"
51 GDK_EXTRA_CFLAGS=
52
53 # GTK+ uses some X calls, so needs to link against X directly
54 GTK_DEP_PACKAGES_FOR_X=
55 GTK_DEP_LIBS_FOR_X=
56
57 if test "x$gdktarget" = "xx11"; then
58- #
59- # We use fontconfig very peripherally when decoding the default
60- # settings.
61- #
62- if $PKG_CONFIG --exists fontconfig; then : ; else
63- AC_MSG_ERROR([
64-*** fontconfig (http://www.fontconfig.org) is required by the X11 backend.])
65- fi
66
67 #
68 # Check for basic X packages; we use pkg-config if available
69 #
70 if $PKG_CONFIG --exists x11 xext xrender; then
71@@ -1122,20 +1108,10 @@ if test "x$gdktarget" = "xx11"; then
72 CPPFLAGS="$CPPFLAGS $X_CFLAGS"
73
74 gtk_save_LIBS=$LIBS
75 LIBS="$x_libs_for_checks $LIBS"
76
77- # Sanity check for the X11 and Xext libraries. While everything we need from
78- # Xext is optional, the chances a system has *none* of these things is so
79- # small that we just unconditionally require it.
80- AC_CHECK_FUNC(XOpenDisplay, :,
81- AC_MSG_ERROR([*** libX11 not found. Check 'config.log' for more details.]))
82- AC_CHECK_FUNC(XextFindDisplay, :,
83- AC_MSG_ERROR([*** libXext not found. Check 'config.log' for more details.]))
84- AC_CHECK_FUNC(XRenderQueryExtension, :,
85- AC_MSG_ERROR([*** libXrender not found. Check 'config.log' for more details.]))
86-
87 # Check for xReply
88
89 AC_MSG_CHECKING([if <X11/extensions/XIproto.h> is needed for xReply])
90 AC_TRY_COMPILE([#include <X11/Xlibint.h>],
91 [xReply *rep;],
92@@ -1416,104 +1392,33 @@ if test "x$gdktarget" = "xdirectfb"; the
93 AM_CONDITIONAL(USE_DIRECTFB, true)
94 else
95 AM_CONDITIONAL(USE_DIRECTFB, false)
96 fi
97
98-
99-# Check for Pango flags
100-
101-if test "x$gdktarget" = "xwin32"; then
102- PANGO_PACKAGES="pangowin32 pangocairo"
103-else
104- PANGO_PACKAGES="pango pangocairo"
105-fi
106-
107-AC_MSG_CHECKING(Pango flags)
108-if $PKG_CONFIG --exists $PANGO_PACKAGES ; then
109- PANGO_CFLAGS=`$PKG_CONFIG --cflags $PANGO_PACKAGES`
110- PANGO_LIBS=`$PKG_CONFIG --libs $PANGO_PACKAGES`
111-
112- AC_MSG_RESULT($PANGO_CFLAGS $PANGO_LIBS)
113-else
114- AC_MSG_ERROR([
115-*** Pango not found. Pango built with Cairo support is required
116-*** to build GTK+. See http://www.pango.org for Pango information.
117-])
118-fi
119-
120-CFLAGS="$CFLAGS $PANGO_CFLAGS"
121-
122-if $PKG_CONFIG --uninstalled $PANGO_PACKAGES; then
123- :
124-else
125- gtk_save_LIBS="$LIBS"
126- LIBS="$PANGO_LIBS $LIBS"
127- AC_TRY_LINK_FUNC(pango_context_new, :, AC_MSG_ERROR([
128-*** Can't link to Pango. Pango is required to build
129-*** GTK+. For more information see http://www.pango.org]))
130- LIBS="$gtk_save_LIBS"
131-fi
132-
133-CFLAGS="$saved_cflags"
134-LDFLAGS="$saved_ldflags"
135-
136-GDK_PACKAGES="$PANGO_PACKAGES"
137-if test "x$gdktarget" = "xx11"; then
138- GDK_PACKAGES="$GDK_PACKAGES $X_PACKAGES"
139-fi
140 GDK_DEP_LIBS="$GDK_EXTRA_LIBS `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $GDK_PACKAGES` $GDK_PIXBUF_EXTRA_LIBS"
141 GDK_DEP_CFLAGS="`$PKG_CONFIG --cflags gthread-2.0 $GDK_PIXBUF_PACKAGES $GDK_PACKAGES` $GDK_PIXBUF_EXTRA_CFLAGS $GDK_EXTRA_CFLAGS"
142
143 #
144 # If we aren't writing explicit dependencies, then don't put the extra libraries we need
145 # into the pkg-config files
146 #
147 if test $enable_explicit_deps != yes ; then
148- GDK_PACKAGES="$PANGO_PACKAGES"
149+ GDK_PACKAGES=
150 GDK_EXTRA_LIBS=
151 fi
152
153 AC_SUBST(GDK_PACKAGES)
154 AC_SUBST(GDK_EXTRA_LIBS)
155 AC_SUBST(GDK_EXTRA_CFLAGS)
156 AC_SUBST(GDK_DEP_LIBS)
157 AC_SUBST(GDK_DEP_CFLAGS)
158
159
160-########################################
161-# Check for Accessibility Toolkit flags
162-########################################
163-
164-ATK_PACKAGES=atk
165-AC_MSG_CHECKING(ATK flags)
166-if $PKG_CONFIG --exists $ATK_PACKAGES ; then
167- ATK_CFLAGS=`$PKG_CONFIG --cflags $ATK_PACKAGES`
168- ATK_LIBS=`$PKG_CONFIG --libs $ATK_PACKAGES`
169-
170- AC_MSG_RESULT($ATK_CFLAGS $ATK_LIBS)
171-else
172- AC_MSG_ERROR([
173-*** Accessibility Toolkit not found. Accessibility Toolkit is required
174-*** to build GTK+.
175-])
176-fi
177-
178-if $PKG_CONFIG --uninstalled $ATK_PACKAGES; then
179- :
180-else
181- gtk_save_LIBS="$LIBS"
182- LIBS="$ATK_LIBS $LIBS"
183- AC_TRY_LINK_FUNC(atk_object_get_type, : , AC_MSG_ERROR([
184- *** Cannot link to Accessibility Toolkit. Accessibility Toolkit is required
185- *** to build GTK+]))
186- LIBS="$gtk_save_LIBS"
187-fi
188-
189-GTK_PACKAGES="atk cairo"
190+GTK_PACKAGES=
191 GTK_EXTRA_LIBS=
192 GTK_EXTRA_CFLAGS=
193-GTK_DEP_LIBS="$GDK_EXTRA_LIBS $GTK_DEP_LIBS_FOR_X `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $PANGO_PACKAGES $GTK_PACKAGES_FOR_X $GTK_PACKAGES` $GTK_EXTRA_LIBS $GDK_PIXBUF_EXTRA_LIBS"
194+GTK_DEP_LIBS="$GDK_EXTRA_LIBS $GTK_DEP_LIBS_FOR_X `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $GTK_PACKAGES_FOR_X $GTK_PACKAGES` $GTK_EXTRA_LIBS $GDK_PIXBUF_EXTRA_LIBS"
195 GTK_DEP_CFLAGS="`$PKG_CONFIG --cflags gthread-2.0 $GDK_PIXBUF_PACKAGES $GDK_PACKAGES $GTK_PACKAGES` $GDK_PIXBUF_EXTRA_CFLAGS $GDK_EXTRA_CFLAGS $GTK_EXTRA_CFLAGS"
196
197 if test x"$os_win32" = xyes; then
198 GTK_EXTRA_CFLAGS="$msnative_struct"
199 fi
200@@ -1567,21 +1472,10 @@ LIBS="$CUPS_LIBS"
201 AC_CHECK_FUNCS(httpGetAuthString)
202 LIBS="$gtk_save_libs"
203
204 gtk_save_cppflags="$CPPFLAGS"
205 CPPFLAGS="$CPPFLAGS $GTK_DEP_CFLAGS"
206-
207-AC_CHECK_HEADER(cairo-pdf.h,,AC_MSG_ERROR([
208-*** Can't find cairo-pdf.h. You must build Cairo with the pdf
209-*** backend enabled.]))
210-
211-if test "$os_win32" != "yes"; then
212- AC_CHECK_HEADER(cairo-ps.h,,AC_MSG_ERROR([
213-*** Can't find cairo-ps.h. You must build Cairo with the
214-*** postscript backend enabled.]))
215-fi
216-
217 CPPFLAGS="$gtk_save_cppflags"
218
219
220 AC_ARG_ENABLE(test-print-backend,
221 [AC_HELP_STRING([--enable-test-print-backend],