diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-10-25 15:23:08 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-10-25 15:23:08 +0000 |
commit | 6de1eeaa11c2cc82aede83aaf00c13692e5f40f6 (patch) | |
tree | 35dfe10950c283bb662415157492d5aca28a41e2 /meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb | |
parent | 8cd7a0e4f49e3ccce07de59a5d8d14080d0dc366 (diff) | |
download | poky-6de1eeaa11c2cc82aede83aaf00c13692e5f40f6.tar.gz |
pcmcia-cs: drop as we use pcmciautils for all PCMCIA machines
Pcmcia-cs is needed for kernels older then 2.6.13-rc1 and all Poky targets
use newer versions.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2976 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb')
-rw-r--r-- | meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb | 105 |
1 files changed, 0 insertions, 105 deletions
diff --git a/meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb b/meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb deleted file mode 100644 index 018f33550f..0000000000 --- a/meta/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb +++ /dev/null | |||
@@ -1,105 +0,0 @@ | |||
1 | DESCRIPTION = "Utilities and system configuration files for the Linux PCMCIA card services" | ||
2 | SECTION = "base" | ||
3 | PRIORITY = "required" | ||
4 | LICENSE = "GPL" | ||
5 | DEPENDS = "virtual/kernel" | ||
6 | RDEPENDS = "hostap-conf orinoco-conf" | ||
7 | PR = "r28" | ||
8 | |||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \ | ||
10 | file://busybox.patch;patch=1 \ | ||
11 | file://network.patch;patch=1 \ | ||
12 | file://pcic-extra.patch;patch=1 \ | ||
13 | file://automount.patch;patch=1 \ | ||
14 | file://ratoc-cfu1u.patch;patch=1 \ | ||
15 | file://no-hostap-cards.patch;patch=1 \ | ||
16 | file://gcc4_fixes.patch;patch=1 \ | ||
17 | file://pcmcia \ | ||
18 | file://ide.opts \ | ||
19 | file://wireless.opts \ | ||
20 | file://network.conf \ | ||
21 | file://wnv.conf" | ||
22 | |||
23 | SRC_URI_append_spitz = " file://nocleanup.patch;patch=1" | ||
24 | SRC_URI_append_sh3 = " file://superh-noO3.patch;patch=1" | ||
25 | |||
26 | S = "${WORKDIR}/pcmcia-cs-${PV}" | ||
27 | |||
28 | INITSCRIPT_NAME = "pcmcia" | ||
29 | INITSCRIPT_PARAMS = "defaults" | ||
30 | |||
31 | inherit update-rc.d module-base | ||
32 | |||
33 | export KERNEL_SOURCE = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}" | ||
34 | |||
35 | sbindir = "/sbin" | ||
36 | |||
37 | do_configure() { | ||
38 | touch .prereq.ok | ||
39 | touch config.out | ||
40 | cat >config.mk <<EOF | ||
41 | UCC=${CC} | ||
42 | UFLAGS=${CFLAGS} -I${S}/include | ||
43 | HAS_WORDEXP=y | ||
44 | SYSV_INIT=y | ||
45 | RC_DIR=/etc | ||
46 | CONFIG_PNP_BIOS=n | ||
47 | ARCH=${ARCH} | ||
48 | CONFIG_CARDBUS=n | ||
49 | CONFIG_PCMCIA=y | ||
50 | CONFIG_INET=y | ||
51 | CONFIG_SCSI=y | ||
52 | DO_IDE=y | ||
53 | EOF | ||
54 | cat >include/pcmcia/autoconf.h <<EOF | ||
55 | #define HAS_WORDEXP 1 | ||
56 | EOF | ||
57 | } | ||
58 | |||
59 | do_compile() { | ||
60 | oe_runmake all HAS_XPM= FLIBS="" XMANDIR="" | ||
61 | } | ||
62 | |||
63 | INSTALL_ETC = "ftl ide ieee1394 memory network parport scsi serial wireless" | ||
64 | INSTALL_ETC_DATA = "config config.opts ftl.opts ieee1394.opts memory.opts network.opts parport.opts scsi.opts serial.opts shared" | ||
65 | INSTALL_ETC_DATA_arm = "config ftl.opts ieee1394.opts memory.opts network.opts parport.opts scsi.opts serial.opts shared" | ||
66 | |||
67 | do_install() { | ||
68 | install -d ${D}${sbindir} | ||
69 | for f in cardmgr/cardctl cardmgr/cardmgr cardmgr/ide_info cardmgr/ifport cardmgr/ifuser cardmgr/pcinitrd flash/ftl_check flash/ftl_format | ||
70 | do | ||
71 | install -m 0755 $f ${D}${sbindir}/ | ||
72 | done | ||
73 | install -d ${D}${sysconfdir}/init.d \ | ||
74 | ${D}${sysconfdir}/pcmcia \ | ||
75 | ${D}${sysconfdir}/pcmcia/cis | ||
76 | |||
77 | install -m 0644 ${WORKDIR}/network.conf ${D}${sysconfdir}/pcmcia/ | ||
78 | install -m 0644 ${WORKDIR}/wnv.conf ${D}${sysconfdir}/pcmcia/ | ||
79 | |||
80 | for i in ${INSTALL_ETC}; do | ||
81 | install -m 0755 etc/${i} ${D}${sysconfdir}/pcmcia/ | ||
82 | done | ||
83 | for i in ${INSTALL_ETC_DATA}; do | ||
84 | install -m 0644 etc/${i} ${D}${sysconfdir}/pcmcia/ | ||
85 | done | ||
86 | |||
87 | # ensure that config.opts always exists, albeit empty | ||
88 | echo >> ${D}${sysconfdir}/pcmcia/config.opts | ||
89 | |||
90 | install -m 0644 ${WORKDIR}/ide.opts ${D}${sysconfdir}/pcmcia/ | ||
91 | install -m 0644 ${WORKDIR}/wireless.opts ${D}${sysconfdir}/pcmcia/ | ||
92 | for i in etc/cis/*; do | ||
93 | install -m 0644 $i ${D}${sysconfdir}/pcmcia/cis/ | ||
94 | done | ||
95 | install -m 0755 etc/rc.pcmcia ${D}${sysconfdir}/init.d/pcmcia | ||
96 | install -d ${D}${sysconfdir}/sysconfig | ||
97 | install -m 0755 ${WORKDIR}/pcmcia ${D}${sysconfdir}/sysconfig/pcmcia | ||
98 | } | ||
99 | |||
100 | PACKAGES =+ "${PN}-ftl ${PN}-pcinitrd" | ||
101 | |||
102 | FILES_${PN} = "${sbindir} ${sysconfdir}" | ||
103 | FILES_${PN}-ftl = "/sbin/ftl_format /sbin/ftl_check /etc/pcmcia/ftl*" | ||
104 | FILES_${PN}-pcinitrd = "/sbin/pcinitrd" | ||
105 | |||