summaryrefslogtreecommitdiffstats
path: root/README.LSB
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-08-25 17:21:15 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-29 13:05:12 (GMT)
commitbac4bc9aa6a1f2fcf2ce9644925615185cc8e847 (patch)
tree9ef8ba7038907331db8f6d1f57f2915b3b6cf410 /README.LSB
parent1af3e4bea666e944a610025ca8979098b59b1174 (diff)
downloadpoky-bac4bc9aa6a1f2fcf2ce9644925615185cc8e847.tar.gz
Remove LSB support
LSB as a standard isn't current and isn't well suited to embedded anyway. Its putting artifical constraints on the system and with modern layer technology, would now be better off as its own layer. As such its time to split it out. The only part with some (marginal) usage is lsb_release, which is split from the lsb package into an own lsb-release package. (From OE-Core rev: fb064356af615d67d85b65942103bf943d84d290) Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'README.LSB')
-rw-r--r--README.LSB29
1 files changed, 0 insertions, 29 deletions
diff --git a/README.LSB b/README.LSB
deleted file mode 100644
index fecbe54..0000000
--- a/README.LSB
+++ /dev/null
@@ -1,29 +0,0 @@
1OE-Core aims to be able to provide basic LSB compatible images. There
2are some challenges for OE as LSB isn't always 100% relevant to its
3target embedded and IoT audiences.
4
5One challenge is that the LSB spec is no longer being actively
6developed [https://github.com/LinuxStandardBase/lsb] and has
7components which are end of life or significantly dated. OE
8therefore provides compatibility with the following caveats:
9
10* Qt4 is provided by the separate meta-qt4 layer. Its noted that Qt4
11 is end of life and this isn't something the core project regularly
12 tests any longer. Users are recommended to group together to support
13 maintenance of that layer. [http://git.yoctoproject.org/cgit/cgit.cgi/meta-qt4/]
14
15* GTK+ 2 is provided by meta-oe. It is noted that GTK+ 2 is end of life
16 and use of GTK+ 2 isn't recommended.
17
18* mailx has been dropped since its no longer being developed upstream
19 and there are better, more modern replacements such as s-nail
20 (http://sdaoden.eu/code.html) or mailutils (http://mailutils.org/).
21
22* A few perl modules that were required by LSB 4.x aren't provided:
23 libclass-isa, libenv, libdumpvalue, libfile-checktree,
24 libi18n-collate, libpod-plainer.
25
26* libpng 1.2 isn't provided; oe-core includes the latest release of libpng
27 instead.
28
29* pax (POSIX standard archive) tool is not provided.