diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2017-02-08 12:53:26 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-02-09 09:14:26 -0500 |
commit | d475adc71ba14740e1fe9c19493df7275d0737c4 (patch) | |
tree | e0f613c4e1805834ecdb197ddb2d166cca43aa51 | |
parent | ee0b5e316af429d4352abcad4a4110deae99e4f6 (diff) | |
download | meta-virtualization-d475adc71ba14740e1fe9c19493df7275d0737c4.tar.gz |
go-native: rename to go-initial-native
With the new per recipe sysroots we were having build issues since the
bootstrap version of go (go-native 1.4) was being found and not the
go-cross (1.6) we are expecting. This results in errors such as the
following when building packages such as containerd:
_cgo_.o: decoding dwarf section info at offset 0x4: unsupported version 0
This is caused by the dependency tree built up to prepare the per
recipe sysroot. Since recipes like containerd DEPEND on go-cross and
go-cross DEPENDS on go-native both are installed but unlike the old
global sysroot the dependency parsing order results in go-native being
last, overwriting go-cross. You can see this by running a devshell for
containerd and running 'go version'.
By adding '-initial' in the name we exploit functionality in
sstate.bbclass that is already in place to handle gcc-initial and
similar. This results in only explicit DEPENDS on go-native being
enforced, so in the case of containerd we only get a dependency on
go-cross and we therefor get go 1.6 as expected.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-devtools/go-cross/go-cross.inc | 4 | ||||
-rw-r--r-- | recipes-devtools/go-cross/go-initial-native_1.4.bb (renamed from recipes-devtools/go-cross/go-native_1.4.bb) | 0 |
2 files changed, 3 insertions, 1 deletions
diff --git a/recipes-devtools/go-cross/go-cross.inc b/recipes-devtools/go-cross/go-cross.inc index 7f74903a..857fbd54 100644 --- a/recipes-devtools/go-cross/go-cross.inc +++ b/recipes-devtools/go-cross/go-cross.inc | |||
@@ -1,7 +1,9 @@ | |||
1 | inherit cross | 1 | inherit cross |
2 | 2 | ||
3 | # libgcc is required for the target specific libraries to build properly | 3 | # libgcc is required for the target specific libraries to build properly |
4 | DEPENDS += "go-native libgcc virtual/${TARGET_PREFIX}gcc" | 4 | DEPENDS += "go-initial-native libgcc virtual/${TARGET_PREFIX}gcc" |
5 | |||
6 | do_compile[depends] += "go-initial-native:do_populate_sysroot" | ||
5 | 7 | ||
6 | # Prevent runstrip from running because you get errors when the host arch != target arch | 8 | # Prevent runstrip from running because you get errors when the host arch != target arch |
7 | #INHIBIT_PACKAGE_STRIP = "1" | 9 | #INHIBIT_PACKAGE_STRIP = "1" |
diff --git a/recipes-devtools/go-cross/go-native_1.4.bb b/recipes-devtools/go-cross/go-initial-native_1.4.bb index cf186e78..cf186e78 100644 --- a/recipes-devtools/go-cross/go-native_1.4.bb +++ b/recipes-devtools/go-cross/go-initial-native_1.4.bb | |||