diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2020-04-14 15:41:48 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2020-04-15 14:58:16 -0400 |
commit | 4ca0557476009b7eda8706b5d2772d70278291de (patch) | |
tree | 8a8743336da74f64c2e0e01f974da512edff86b5 /recipes-security | |
parent | 65086a9972bf345a72c5c1f40dfb3209e1059ccf (diff) | |
download | meta-selinux-4ca0557476009b7eda8706b5d2772d70278291de.tar.gz |
libsemanage: upgrade to 3.0 (20191204)
* Refresh libsemanage-allow-to-disable-audit-support.patch
* Fix typos in patches.
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'recipes-security')
-rw-r--r-- | recipes-security/selinux/libsemanage.inc | 2 | ||||
-rw-r--r-- | recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch | 14 | ||||
-rw-r--r-- | recipes-security/selinux/libsemanage/libsemanage-define-FD_CLOEXEC-as-necessary.patch | 2 | ||||
-rw-r--r-- | recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch | 2 | ||||
-rw-r--r-- | recipes-security/selinux/libsemanage_3.0.bb (renamed from recipes-security/selinux/libsemanage_2.9.bb) | 6 |
5 files changed, 13 insertions, 13 deletions
diff --git a/recipes-security/selinux/libsemanage.inc b/recipes-security/selinux/libsemanage.inc index 81a3eda..0139511 100644 --- a/recipes-security/selinux/libsemanage.inc +++ b/recipes-security/selinux/libsemanage.inc | |||
@@ -6,7 +6,7 @@ on binary policies such as customizing policy boolean settings." | |||
6 | SECTION = "base" | 6 | SECTION = "base" |
7 | LICENSE = "LGPLv2.1+" | 7 | LICENSE = "LGPLv2.1+" |
8 | 8 | ||
9 | inherit lib_package python3-dir | 9 | inherit lib_package python3native |
10 | 10 | ||
11 | DEPENDS += "libsepol libselinux bzip2 python3 bison-native flex-native swig-native" | 11 | DEPENDS += "libsepol libselinux bzip2 python3 bison-native flex-native swig-native" |
12 | DEPENDS_append_class-target = " audit" | 12 | DEPENDS_append_class-target = " audit" |
diff --git a/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch b/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch index 6ea9c29..c588b61 100644 --- a/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch +++ b/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 50f8f9f090425d23ecab2bedc949bc65bc4d58dc Mon Sep 17 00:00:00 2001 | 1 | From 1633f72579e3b79d055759256b71e4169627889b Mon Sep 17 00:00:00 2001 |
2 | From: Wenzong Fan <wenzong.fan@windriver.com> | 2 | From: Wenzong Fan <wenzong.fan@windriver.com> |
3 | Date: Mon, 20 Jan 2014 03:53:48 -0500 | 3 | Date: Mon, 20 Jan 2014 03:53:48 -0500 |
4 | Subject: [PATCH] libsemanage: allow to disable audit support | 4 | Subject: [PATCH] libsemanage: allow to disable audit support |
@@ -13,7 +13,7 @@ Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> | |||
13 | 3 files changed, 31 insertions(+), 2 deletions(-) | 13 | 3 files changed, 31 insertions(+), 2 deletions(-) |
14 | 14 | ||
15 | diff --git a/src/Makefile b/src/Makefile | 15 | diff --git a/src/Makefile b/src/Makefile |
16 | index 8240c3a..1485d23 100644 | 16 | index 3bd1e20..483e818 100644 |
17 | --- a/src/Makefile | 17 | --- a/src/Makefile |
18 | +++ b/src/Makefile | 18 | +++ b/src/Makefile |
19 | @@ -26,6 +26,14 @@ ifeq ($(DEBUG),1) | 19 | @@ -26,6 +26,14 @@ ifeq ($(DEBUG),1) |
@@ -41,7 +41,7 @@ index 8240c3a..1485d23 100644 | |||
41 | 41 | ||
42 | $(LIBPC): $(LIBPC).in ../VERSION | 42 | $(LIBPC): $(LIBPC).in ../VERSION |
43 | diff --git a/src/seusers_local.c b/src/seusers_local.c | 43 | diff --git a/src/seusers_local.c b/src/seusers_local.c |
44 | index a79e2d3..ce76dee 100644 | 44 | index 3e2761c..8bc6b83 100644 |
45 | --- a/src/seusers_local.c | 45 | --- a/src/seusers_local.c |
46 | +++ b/src/seusers_local.c | 46 | +++ b/src/seusers_local.c |
47 | @@ -8,7 +8,11 @@ typedef struct semanage_seuser record_t; | 47 | @@ -8,7 +8,11 @@ typedef struct semanage_seuser record_t; |
@@ -98,10 +98,10 @@ index a79e2d3..ce76dee 100644 | |||
98 | semanage_seuser_free(seuser); | 98 | semanage_seuser_free(seuser); |
99 | return rc; | 99 | return rc; |
100 | diff --git a/tests/Makefile b/tests/Makefile | 100 | diff --git a/tests/Makefile b/tests/Makefile |
101 | index 324766a..5732ec7 100644 | 101 | index 69f49a3..f914492 100644 |
102 | --- a/tests/Makefile | 102 | --- a/tests/Makefile |
103 | +++ b/tests/Makefile | 103 | +++ b/tests/Makefile |
104 | @@ -3,10 +3,18 @@ SOURCES = $(sort $(wildcard *.c)) | 104 | @@ -4,10 +4,18 @@ CILS = $(sort $(wildcard *.cil)) |
105 | 105 | ||
106 | ########################################################################### | 106 | ########################################################################### |
107 | 107 | ||
@@ -119,8 +119,8 @@ index 324766a..5732ec7 100644 | |||
119 | -override LDLIBS += -lcunit -lbz2 -laudit -lselinux -lsepol | 119 | -override LDLIBS += -lcunit -lbz2 -laudit -lselinux -lsepol |
120 | +override LDLIBS += -lcunit -lbz2 $(LIBAUDIT) -lselinux -lsepol | 120 | +override LDLIBS += -lcunit -lbz2 $(LIBAUDIT) -lselinux -lsepol |
121 | 121 | ||
122 | OBJECTS = $(SOURCES:.c=.o) | 122 | OBJECTS = $(SOURCES:.c=.o) |
123 | 123 | POLICIES = $(CILS:.cil=.policy) | |
124 | -- | 124 | -- |
125 | 2.7.4 | 125 | 2.7.4 |
126 | 126 | ||
diff --git a/recipes-security/selinux/libsemanage/libsemanage-define-FD_CLOEXEC-as-necessary.patch b/recipes-security/selinux/libsemanage/libsemanage-define-FD_CLOEXEC-as-necessary.patch index 0c77c7a..45bcbe6 100644 --- a/recipes-security/selinux/libsemanage/libsemanage-define-FD_CLOEXEC-as-necessary.patch +++ b/recipes-security/selinux/libsemanage/libsemanage-define-FD_CLOEXEC-as-necessary.patch | |||
@@ -7,7 +7,7 @@ In truly old systems, even FD_CLOEXEC may not be defined. Produce a | |||
7 | warning and duplicate the #define for FD_CLOEXEC found in | 7 | warning and duplicate the #define for FD_CLOEXEC found in |
8 | asm-generic/fcntl.h on more modern platforms. | 8 | asm-generic/fcntl.h on more modern platforms. |
9 | 9 | ||
10 | Uptream-Status: Inappropriate | 10 | Upstream-Status: Inappropriate |
11 | 11 | ||
12 | Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com> | 12 | Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com> |
13 | --- | 13 | --- |
diff --git a/recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch b/recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch index de71e27..c9b052c 100644 --- a/recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch +++ b/recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch | |||
@@ -3,7 +3,7 @@ From: Randy MacLeod <Randy.MacLeod@windriver.com> | |||
3 | Date: Tue, 30 Apr 2013 23:15:57 -0400 | 3 | Date: Tue, 30 Apr 2013 23:15:57 -0400 |
4 | Subject: [PATCH] libselinux: drop flag: -Wno-unused-but-set-variable | 4 | Subject: [PATCH] libselinux: drop flag: -Wno-unused-but-set-variable |
5 | 5 | ||
6 | Upstream-Status: Inappropriate (older compilers only). | 6 | Upstream-Status: Inappropriate [older compilers only] |
7 | 7 | ||
8 | Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> | 8 | Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> |
9 | --- | 9 | --- |
diff --git a/recipes-security/selinux/libsemanage_2.9.bb b/recipes-security/selinux/libsemanage_3.0.bb index 83320a1..450675b 100644 --- a/recipes-security/selinux/libsemanage_2.9.bb +++ b/recipes-security/selinux/libsemanage_3.0.bb | |||
@@ -1,10 +1,10 @@ | |||
1 | require selinux_20190315.inc | 1 | require selinux_20191204.inc |
2 | require ${BPN}.inc | 2 | require ${BPN}.inc |
3 | 3 | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
5 | 5 | ||
6 | SRC_URI[md5sum] = "25f086ff66175a0ca0e7b34dbe8586b7" | 6 | SRC_URI[md5sum] = "17a2fc780af0a36f2cf27ab7c4e85946" |
7 | SRC_URI[sha256sum] = "2576349d344492e73b468059767268dec1dabd8c35f3c7222c3ec2448737bc1c" | 7 | SRC_URI[sha256sum] = "a497b0720d54eac427f1f3f618eed417e50ed8f4e47ed0f7a1d391bd416e84cf" |
8 | 8 | ||
9 | SRC_URI += "\ | 9 | SRC_URI += "\ |
10 | file://libsemanage-Fix-execve-segfaults-on-Ubuntu.patch \ | 10 | file://libsemanage-Fix-execve-segfaults-on-Ubuntu.patch \ |