diff options
author | Xin Ouyang <Xin.Ouyang@windriver.com> | 2012-02-20 10:29:10 +0800 |
---|---|---|
committer | Xin Ouyang <Xin.Ouyang@windriver.com> | 2012-02-20 10:29:10 +0800 |
commit | 00137225282b4338f56d91313637bea0d8956742 (patch) | |
tree | f09e265ca3e88c6de8829caf927443d20c2a8206 /recipes-security/selinux/libselinux_git.bb | |
parent | 679cdbe1c9d46476ce5ffe46d3b83fd0b165c520 (diff) | |
download | meta-selinux-00137225282b4338f56d91313637bea0d8956742.tar.gz |
Rename all git bb recipes.
Diffstat (limited to 'recipes-security/selinux/libselinux_git.bb')
-rw-r--r-- | recipes-security/selinux/libselinux_git.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-security/selinux/libselinux_git.bb b/recipes-security/selinux/libselinux_git.bb new file mode 100644 index 0000000..8de51e0 --- /dev/null +++ b/recipes-security/selinux/libselinux_git.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | SUMMARY = "SELinux library and simple utilities" | ||
2 | DESCRIPTION = "libselinux provides an API for SELinux applications to get and set \ | ||
3 | process and file security contexts and to obtain security policy \ | ||
4 | decisions. Required for any applications that use the SELinux API." | ||
5 | SECTION = "base" | ||
6 | PR = "r1" | ||
7 | LICENSE = "NSA-Public_Domain" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=84b4d2c6ef954a2d4081e775a270d0d0" | ||
9 | |||
10 | include selinux_git.inc | ||
11 | inherit lib_package | ||
12 | |||
13 | SRCREV = "339f8079d7b9dd1e0b0138e2d096dc7c60b2092e" | ||
14 | S = "${WORKDIR}/git/libselinux" | ||
15 | DEPENDS += "libsepol python python-native swig-native" | ||
16 | |||
17 | PACKAGES += "${PN}-python" | ||
18 | FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/selinux/*" | ||
19 | FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/site-packages/selinux/.debug/*" | ||
20 | |||
21 | python __anonymous () { | ||
22 | import re | ||
23 | target = d.getVar('TARGET_ARCH', True) | ||
24 | extra_oemake = d.getVar('EXTRA_OEMAKE', True) | ||
25 | p = re.compile('i.86') | ||
26 | target = p.sub('i386',target) | ||
27 | d.setVar("EXTRA_OEMAKE", extra_oemake + " ARCH='" + target + "'") | ||
28 | } | ||
29 | |||
30 | do_compile_append() { | ||
31 | oe_runmake pywrap -j1 \ | ||
32 | INCLUDEDIR='${STAGING_INCDIR}' \ | ||
33 | LIBDIR='${STAGING_LIBDIR}' \ | ||
34 | PYLIBVER='python${PYTHON_BASEVERSION}' \ | ||
35 | PYINC='-I${STAGING_INCDIR}/$(PYLIBVER)' \ | ||
36 | PYLIB='-L${STAGING_LIBDIR}/$(PYLIBVER) -l$(PYLIBVER)' \ | ||
37 | PYTHONLIBDIR='${PYLIB}' | ||
38 | } | ||
39 | |||
40 | do_install_append() { | ||
41 | oe_runmake install-pywrap swigify \ | ||
42 | DESTDIR=${D} \ | ||
43 | PYLIBVER='python${PYTHON_BASEVERSION}' \ | ||
44 | PYLIBDIR='${D}/${libdir}/$(PYLIBVER)' | ||
45 | } | ||
46 | |||
47 | BBCLASSEXTEND = "native" | ||