diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2021-09-13 09:48:08 +0800 |
---|---|---|
committer | Joe MacDonald <joe@deserted.net> | 2021-09-29 22:29:59 -0400 |
commit | 4d2bb085d29c4d6f2ccb62fec53da23ff541183e (patch) | |
tree | 0130e8e6a8e9659fc65b0e81c242c523568e6bce | |
parent | fbe470fa2e9022c716896ddf0b77e80119c59588 (diff) | |
download | meta-selinux-4d2bb085d29c4d6f2ccb62fec53da23ff541183e.tar.gz |
coreutils/findutils/tar: remove pkgconfig from bbappend
When enable meta-gplv2 layer [1], there comes below error:
ERROR: coreutils-6.9-r5 do_configure: QA Issue: coreutils: configure was passed unrecognised options: --without-selinux [unknown-configure-option]
ERROR: coreutils-6.9-r5 do_configure: Fatal QA errors found, failing task.
It's because the old version of coreutils under meta-gplv2 layer
doesn't support the above configure option, so move the related
pkgconfig setting to the coreutils recipe under oe-core [2] which
supports the configure option to fix the gap.
And the findutils and tar also have the problem.
[1] http://git.yoctoproject.org/cgit/cgit.cgi/meta-gplv2/
[2] https://git.openembedded.org/openembedded-core/
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r-- | recipes-core/coreutils/coreutils_%.bbappend | 1 | ||||
-rw-r--r-- | recipes-extended/findutils/findutils_%.bbappend | 1 | ||||
-rw-r--r-- | recipes-extended/tar/tar_selinux.inc | 2 |
3 files changed, 0 insertions, 4 deletions
diff --git a/recipes-core/coreutils/coreutils_%.bbappend b/recipes-core/coreutils/coreutils_%.bbappend index 138c23a..74e22b3 100644 --- a/recipes-core/coreutils/coreutils_%.bbappend +++ b/recipes-core/coreutils/coreutils_%.bbappend | |||
@@ -1,2 +1 @@ | |||
1 | inherit ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'enable-selinux', '', d)} | inherit ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'enable-selinux', '', d)} | |
2 | PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux" | ||
diff --git a/recipes-extended/findutils/findutils_%.bbappend b/recipes-extended/findutils/findutils_%.bbappend index 138c23a..74e22b3 100644 --- a/recipes-extended/findutils/findutils_%.bbappend +++ b/recipes-extended/findutils/findutils_%.bbappend | |||
@@ -1,2 +1 @@ | |||
1 | inherit ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'enable-selinux', '', d)} | inherit ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'enable-selinux', '', d)} | |
2 | PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux" | ||
diff --git a/recipes-extended/tar/tar_selinux.inc b/recipes-extended/tar/tar_selinux.inc index 0f64298..8c11cac 100644 --- a/recipes-extended/tar/tar_selinux.inc +++ b/recipes-extended/tar/tar_selinux.inc | |||
@@ -1,3 +1 @@ | |||
1 | inherit enable-selinux | inherit enable-selinux | |
2 | |||
3 | PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux" | ||