summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/rpi-gpio_0.5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/rpi-gpio_0.5.4.bb')
-rw-r--r--recipes-devtools/python/rpi-gpio_0.5.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/rpi-gpio_0.5.4.bb b/recipes-devtools/python/rpi-gpio_0.5.4.bb
new file mode 100644
index 0000000..7307399
--- /dev/null
+++ b/recipes-devtools/python/rpi-gpio_0.5.4.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
2HOMEPAGE = "http://code.google.com/p/raspberry-gpio-python/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=35af90ff2a10e8bdc967653b9dfcb22a"
6
7SRCNAME = "RPi.GPIO"
8
9SRC_URI = "\
10 http://pypi.python.org/packages/source/R/RPi.GPIO/${SRCNAME}-${PV}.tar.gz \
11 "
12S = "${WORKDIR}/${SRCNAME}-${PV}"
13
14inherit distutils
15
16COMPATIBLE_MACHINE = "raspberrypi"
17
18SRC_URI[md5sum] = "add6554ed8331d515fccb5e052c7d1ff"
19SRC_URI[sha256sum] = "5fae8e59a9a1cdb68208d40239d7ad788d22aa9d58c54c482fa5d89ccc4c0f37"