diff options
Diffstat (limited to 'recipes-devtools/pi-blaster/files/enable-autotools-support.patch')
-rw-r--r-- | recipes-devtools/pi-blaster/files/enable-autotools-support.patch | 77 |
1 files changed, 0 insertions, 77 deletions
diff --git a/recipes-devtools/pi-blaster/files/enable-autotools-support.patch b/recipes-devtools/pi-blaster/files/enable-autotools-support.patch deleted file mode 100644 index f0d4958..0000000 --- a/recipes-devtools/pi-blaster/files/enable-autotools-support.patch +++ /dev/null | |||
@@ -1,77 +0,0 @@ | |||
1 | Add autotools configuration files to simplify cross-compilation | ||
2 | |||
3 | Upstream-Status: Submitted [https://github.com/sarfata/pi-blaster/pull/25] | ||
4 | |||
5 | Signed-off-by: Alex Lennon <ajlennon@dynamicdevices.co.uk> | ||
6 | |||
7 | diff -Nur git.org/Makefile git.new/Makefile | ||
8 | --- git.org/Makefile 2014-06-11 15:42:26.490930706 +0100 | ||
9 | +++ git.new/Makefile 1970-01-01 01:00:00.000000000 +0100 | ||
10 | @@ -1,23 +0,0 @@ | ||
11 | -.PHONY: all | ||
12 | -all: pi-blaster | ||
13 | - | ||
14 | -REVISION=$(shell egrep -q '000f$$' /proc/cpuinfo && echo 2 || echo 1) | ||
15 | - | ||
16 | -pi-blaster: pi-blaster.c | ||
17 | - gcc -Wall -g -O2 -o $@ $< -DREVISION=$(REVISION) | ||
18 | - | ||
19 | -clean: | ||
20 | - rm -f pi-blaster | ||
21 | - | ||
22 | -install: pi-blaster | ||
23 | - cp -f pi-blaster.boot.sh /etc/init.d/pi-blaster | ||
24 | - chmod +x /etc/init.d/pi-blaster | ||
25 | - cp -f pi-blaster /usr/sbin/pi-blaster | ||
26 | - update-rc.d pi-blaster defaults | ||
27 | - /etc/init.d/pi-blaster start | ||
28 | - | ||
29 | -uninstall: | ||
30 | - -/etc/init.d/pi-blaster stop | ||
31 | - rm /usr/sbin/pi-blaster | ||
32 | - rm /etc/init.d/pi-blaster | ||
33 | - update-rc.d pi-blaster remove | ||
34 | diff -Nur git.org/Makefile.am git.new/Makefile.am | ||
35 | --- git.org/Makefile.am 1970-01-01 01:00:00.000000000 +0100 | ||
36 | +++ git.new/Makefile.am 2014-06-11 15:40:16.562930372 +0100 | ||
37 | @@ -0,0 +1,9 @@ | ||
38 | +AUTOMAKE_OPTIONS = foreign | ||
39 | + | ||
40 | +CFLAGS = -Wall -pedantic | ||
41 | + | ||
42 | +sbin_PROGRAMS = pi-blaster | ||
43 | +pi_blaster_SOURCES = pi-blaster.c | ||
44 | + | ||
45 | +init_ddir = $(sysconfdir)/init.d | ||
46 | +init_d_SCRIPTS = pi-blaster.boot.sh | ||
47 | diff -Nur git.org/autogen.sh git.new/autogen.sh | ||
48 | --- git.org/autogen.sh 1970-01-01 01:00:00.000000000 +0100 | ||
49 | +++ git.new/autogen.sh 2014-06-11 15:35:57.798929684 +0100 | ||
50 | @@ -0,0 +1,9 @@ | ||
51 | +#!/bin/sh | ||
52 | + | ||
53 | +echo "Generating configure files... may take a while." | ||
54 | + | ||
55 | +autoreconf --install --force && \ | ||
56 | + echo "Preparing was successful if there was no error messages above." && \ | ||
57 | + echo "Now type:" && \ | ||
58 | + echo " ./configure && make" && \ | ||
59 | + echo "Run './configure --help' for more information" | ||
60 | diff -Nur git.org/configure.ac git.new/configure.ac | ||
61 | --- git.org/configure.ac 1970-01-01 01:00:00.000000000 +0100 | ||
62 | +++ git.new/configure.ac 2014-06-11 15:35:53.154929717 +0100 | ||
63 | @@ -0,0 +1,14 @@ | ||
64 | +# -*- Autoconf -*- | ||
65 | +# Process this file with autoconf to produce a configure script. | ||
66 | + | ||
67 | +AC_PREREQ([2.69]) | ||
68 | +AC_INIT(pi-blaster, 0.1.0) | ||
69 | +AC_CONFIG_SRCDIR([pi-blaster.c]) | ||
70 | +AC_CONFIG_HEADERS([config.h]) | ||
71 | +AM_INIT_AUTOMAKE | ||
72 | + | ||
73 | +# Checks for programs. | ||
74 | +AC_PROG_CC | ||
75 | + | ||
76 | +AC_CONFIG_FILES([Makefile]) | ||
77 | +AC_OUTPUT | ||