diff options
-rw-r--r-- | recipes-core/images/rpi-basic-image.bb | 4 | ||||
-rw-r--r-- | recipes-core/images/rpi-hwup-image.bb | 4 | ||||
-rw-r--r-- | recipes-core/images/rpi-test-image.bb | 4 |
3 files changed, 10 insertions, 2 deletions
diff --git a/recipes-core/images/rpi-basic-image.bb b/recipes-core/images/rpi-basic-image.bb index 623a5a7..33dca7d 100644 --- a/recipes-core/images/rpi-basic-image.bb +++ b/recipes-core/images/rpi-basic-image.bb | |||
@@ -4,3 +4,7 @@ include rpi-hwup-image.bb | |||
4 | SPLASH = "psplash-raspberrypi" | 4 | SPLASH = "psplash-raspberrypi" |
5 | 5 | ||
6 | IMAGE_FEATURES += "ssh-server-dropbear splash" | 6 | IMAGE_FEATURES += "ssh-server-dropbear splash" |
7 | |||
8 | do_image_prepend() { | ||
9 | bb.warn("The image 'rpi-basic-image' is deprecated, please use 'core-image-base' instead") | ||
10 | } | ||
diff --git a/recipes-core/images/rpi-hwup-image.bb b/recipes-core/images/rpi-hwup-image.bb index 486ea59..d2371ad 100644 --- a/recipes-core/images/rpi-hwup-image.bb +++ b/recipes-core/images/rpi-hwup-image.bb | |||
@@ -5,3 +5,7 @@ include recipes-core/images/core-image-minimal.bb | |||
5 | IMAGE_INSTALL += " \ | 5 | IMAGE_INSTALL += " \ |
6 | kernel-modules \ | 6 | kernel-modules \ |
7 | " | 7 | " |
8 | |||
9 | do_image_prepend() { | ||
10 | bb.warn("The image 'rpi-hwup-image' is deprecated, please use 'core-image-minimal' instead") | ||
11 | } | ||
diff --git a/recipes-core/images/rpi-test-image.bb b/recipes-core/images/rpi-test-image.bb index c8dc436..c2f5f73 100644 --- a/recipes-core/images/rpi-test-image.bb +++ b/recipes-core/images/rpi-test-image.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | # Base this image on rpi-basic-image | 1 | # Base this image on core-image-base |
2 | include rpi-basic-image.bb | 2 | include recipes-core/images/core-image-base.bb |
3 | 3 | ||
4 | COMPATIBLE_MACHINE = "^rpi$" | 4 | COMPATIBLE_MACHINE = "^rpi$" |
5 | 5 | ||