summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/userland/userland/0016-define-PROJECT_APIVER.patch33
-rw-r--r--recipes-graphics/userland/userland_git.bb3
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-graphics/userland/userland/0016-define-PROJECT_APIVER.patch b/recipes-graphics/userland/userland/0016-define-PROJECT_APIVER.patch
new file mode 100644
index 0000000..63a35eb
--- /dev/null
+++ b/recipes-graphics/userland/userland/0016-define-PROJECT_APIVER.patch
@@ -0,0 +1,33 @@
1From 56072d7282e7daf65f58fa897f1f76268ae88121 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Feb 2016 11:06:26 -0800
4Subject: [PATCH 16/16] define PROJECT_APIVER
5
6this helps in compiling components which use packageconfig to poke for
7library versions and requiring minimum supported version
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 CMakeLists.txt | 6 ++++++
12 1 file changed, 6 insertions(+)
13
14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index b240ef6..aa5e14f 100644
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -2,6 +2,12 @@ cmake_minimum_required(VERSION 2.8)
19
20 project(vmcs_host_apps)
21
22+SET(PROJECT_VER_MAJOR 1)
23+SET(PROJECT_VER_MINOR 0)
24+SET(PROJECT_VER_PATCH 0)
25+SET(PROJECT_VER "${PROJECT_VER_MAJOR}.${PROJECT_VER_MINOR}.${PROJECT_VER_PATCH}")
26+SET(PROJECT_APIVER "${PROJECT_VER}")
27+
28 set(BUILD_MMAL TRUE)
29 set(BUILD_MMAL_APPS TRUE)
30 set(vmcs_root ${PROJECT_SOURCE_DIR})
31--
322.7.0
33
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index d78a7c9..5ea48e1 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -10,6 +10,8 @@ PR = "r5"
10PROVIDES = "virtual/libgles2 \ 10PROVIDES = "virtual/libgles2 \
11 virtual/egl" 11 virtual/egl"
12 12
13RPROVIDES_${PN} += "libgles2 libgl"
14
13COMPATIBLE_MACHINE = "raspberrypi" 15COMPATIBLE_MACHINE = "raspberrypi"
14 16
15SRCBRANCH = "master" 17SRCBRANCH = "master"
@@ -33,6 +35,7 @@ SRC_URI = "\
33 file://0013-zero-out-wl-buffers-in-egl_surface_free.patch \ 35 file://0013-zero-out-wl-buffers-in-egl_surface_free.patch \
34 file://0014-initialize-front-back-wayland-buffers.patch \ 36 file://0014-initialize-front-back-wayland-buffers.patch \
35 file://0015-Remove-RPC_FLUSH.patch \ 37 file://0015-Remove-RPC_FLUSH.patch \
38 file://0016-define-PROJECT_APIVER.patch \
36" 39"
37S = "${WORKDIR}/git" 40S = "${WORKDIR}/git"
38 41