diff options
-rw-r--r-- | recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch | 12 | ||||
-rw-r--r-- | recipes-graphics/userland/userland_git.bb | 2 |
2 files changed, 7 insertions, 7 deletions
diff --git a/recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch b/recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch index 324fa91..c054572 100644 --- a/recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch +++ b/recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 5f9e011a6c15b3a05b3be412d7ba5c1077ececf1 Mon Sep 17 00:00:00 2001 | 1 | From 61a9d792ed774af43e592aa8fdb2a18488696d0f Mon Sep 17 00:00:00 2001 |
2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> | 2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> |
3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 | 3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 |
4 | Subject: [PATCH 02/13] wayland: Add support for the Wayland winsys | 4 | Subject: [PATCH 02/13] wayland: Add support for the Wayland winsys |
@@ -102,7 +102,7 @@ index 358d2b4..4da4448 100644 | |||
102 | + | 102 | + |
103 | +$ BUILD_WAYLAND=1 ./buildme. | 103 | +$ BUILD_WAYLAND=1 ./buildme. |
104 | diff --git a/buildme b/buildme | 104 | diff --git a/buildme b/buildme |
105 | index 1061745..d0e6e54 100755 | 105 | index b8fd440..a780bb6 100755 |
106 | --- a/buildme | 106 | --- a/buildme |
107 | +++ b/buildme | 107 | +++ b/buildme |
108 | @@ -8,6 +8,10 @@ fi | 108 | @@ -8,6 +8,10 @@ fi |
@@ -117,7 +117,7 @@ index 1061745..d0e6e54 100755 | |||
117 | # Native compile on the Raspberry Pi | 117 | # Native compile on the Raspberry Pi |
118 | mkdir -p build/raspberry/$BUILDSUBDIR | 118 | mkdir -p build/raspberry/$BUILDSUBDIR |
119 | @@ -32,9 +36,13 @@ elif [ "$1" = "--native" ]; then | 119 | @@ -32,9 +36,13 @@ elif [ "$1" = "--native" ]; then |
120 | make -j 6 $* | 120 | make -j `nproc` $* |
121 | else | 121 | else |
122 | # Cross compile on a more capable machine | 122 | # Cross compile on a more capable machine |
123 | + if [ -n "$BUILD_WAYLAND" ]; then | 123 | + if [ -n "$BUILD_WAYLAND" ]; then |
@@ -128,7 +128,7 @@ index 1061745..d0e6e54 100755 | |||
128 | pushd build/arm-linux/$BUILDSUBDIR | 128 | pushd build/arm-linux/$BUILDSUBDIR |
129 | - cmake -DCMAKE_TOOLCHAIN_FILE=../../../makefiles/cmake/toolchains/arm-linux-gnueabihf.cmake -DCMAKE_BUILD_TYPE=$BUILDTYPE ../../.. | 129 | - cmake -DCMAKE_TOOLCHAIN_FILE=../../../makefiles/cmake/toolchains/arm-linux-gnueabihf.cmake -DCMAKE_BUILD_TYPE=$BUILDTYPE ../../.. |
130 | + cmake -DCMAKE_TOOLCHAIN_FILE=../../../makefiles/cmake/toolchains/arm-linux-gnueabihf.cmake -DCMAKE_BUILD_TYPE=$BUILDTYPE $WAYLAND_VARS ../../.. | 130 | + cmake -DCMAKE_TOOLCHAIN_FILE=../../../makefiles/cmake/toolchains/arm-linux-gnueabihf.cmake -DCMAKE_BUILD_TYPE=$BUILDTYPE $WAYLAND_VARS ../../.. |
131 | make -j 6 | 131 | make -j `nproc` |
132 | 132 | ||
133 | if [ "$1" != "" ]; then | 133 | if [ "$1" != "" ]; then |
134 | diff --git a/host_applications/linux/apps/raspicam/CMakeLists.txt b/host_applications/linux/apps/raspicam/CMakeLists.txt | 134 | diff --git a/host_applications/linux/apps/raspicam/CMakeLists.txt b/host_applications/linux/apps/raspicam/CMakeLists.txt |
@@ -1604,7 +1604,7 @@ index 37fdae1..fe3619a 100755 | |||
1604 | } | 1604 | } |
1605 | #endif | 1605 | #endif |
1606 | diff --git a/interface/vmcs_host/vc_vchi_dispmanx.c b/interface/vmcs_host/vc_vchi_dispmanx.c | 1606 | diff --git a/interface/vmcs_host/vc_vchi_dispmanx.c b/interface/vmcs_host/vc_vchi_dispmanx.c |
1607 | index 133e86d..45f4cff 100755 | 1607 | index 7a6cdcd..eab146e 100755 |
1608 | --- a/interface/vmcs_host/vc_vchi_dispmanx.c | 1608 | --- a/interface/vmcs_host/vc_vchi_dispmanx.c |
1609 | +++ b/interface/vmcs_host/vc_vchi_dispmanx.c | 1609 | +++ b/interface/vmcs_host/vc_vchi_dispmanx.c |
1610 | @@ -1319,3 +1319,45 @@ static void *dispmanx_notify_func( void *arg ) { | 1610 | @@ -1319,3 +1319,45 @@ static void *dispmanx_notify_func( void *arg ) { |
@@ -1885,5 +1885,5 @@ index 0000000..ad90d30 | |||
1885 | + set(${_sources} ${${_sources}} PARENT_SCOPE) | 1885 | + set(${_sources} ${${_sources}} PARENT_SCOPE) |
1886 | +endfunction() | 1886 | +endfunction() |
1887 | -- | 1887 | -- |
1888 | 2.12.0 | 1888 | 2.12.2 |
1889 | 1889 | ||
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb index afbe5ac..9526fae 100644 --- a/recipes-graphics/userland/userland_git.bb +++ b/recipes-graphics/userland/userland_git.bb | |||
@@ -16,7 +16,7 @@ COMPATIBLE_MACHINE = "raspberrypi" | |||
16 | 16 | ||
17 | SRCBRANCH = "master" | 17 | SRCBRANCH = "master" |
18 | SRCFORK = "raspberrypi" | 18 | SRCFORK = "raspberrypi" |
19 | SRCREV = "cdb5da59f939eb4078e90ed0e3c231c498ba9957" | 19 | SRCREV = "f0642e3b58d8a140a3f7621630c15fbfa794b19d" |
20 | 20 | ||
21 | SRC_URI = "\ | 21 | SRC_URI = "\ |
22 | git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ | 22 | git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ |