summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@noraisin.net>2013-01-26 00:33:23 +1100
committerAndrei Gherzan <andrei@gherzan.ro>2013-01-27 15:28:25 +0200
commite7fdddc4e134ff8aa2afd6996dd8c932f5fcfc86 (patch)
treed0383de2226bca7e0bb5583a8f8b323e52dd7216 /recipes-kernel
parentb3de8baa2f8c30bc1dd91ab843269dc3b6fce6fe (diff)
downloadmeta-raspberrypi-e7fdddc4e134ff8aa2afd6996dd8c932f5fcfc86.tar.gz
linux: Add a Linux 3.6 kernel recipe
* Add a recipe to build the linux kernel from the rpi-3.6.y branch at https://github.com/raspberrypi/linux * Since this has a higher version, it will be the preferred linux kernel by default. Signed-off-by: Jan Schmidt <thaytan@noraisin.net> Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-raspberrypi_3.6.11.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi_3.6.11.bb b/recipes-kernel/linux/linux-raspberrypi_3.6.11.bb
new file mode 100644
index 0000000..caee7f2
--- /dev/null
+++ b/recipes-kernel/linux/linux-raspberrypi_3.6.11.bb
@@ -0,0 +1,34 @@
1require linux.inc
2
3DESCRIPTION = "Linux kernel for the RaspberryPi board"
4COMPATIBLE_MACHINE = "raspberrypi"
5
6PR = "r6"
7PV_append = "+git${SRCREV}"
8
9SRCREV = "31a951046155b27361127d9cf85a1f58719fe9b3"
10SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=rpi-3.6.y \
11 "
12S = "${WORKDIR}/git"
13
14# NOTE: For now we pull in the default config from the RPi kernel GIT tree.
15KERNEL_DEFCONFIG = "bcmrpi_defconfig"
16
17# CMDLINE for raspberrypi
18CMDLINE_raspberrypi = "dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait"
19
20UDEV_GE_141 ?= "1"
21
22do_configure_prepend() {
23 install -m 0644 ${S}/arch/${ARCH}/configs/${KERNEL_DEFCONFIG} ${WORKDIR}/defconfig || die "No default configuration for ${MACHINE} / ${KERNEL_DEFCONFIG} available."
24}
25
26do_install_prepend() {
27 install -d ${D}/lib/firmware
28}
29
30do_deploy_append() {
31 # Deploy cmdline.txt
32 install -d ${DEPLOYDIR}/bcm2835-bootfiles
33 echo "${CMDLINE}" > ${DEPLOYDIR}/bcm2835-bootfiles/cmdline.txt
34}