diff options
author | Petter Mabäcker <petter@technux.se> | 2015-05-08 23:49:05 +0200 |
---|---|---|
committer | Andrei Gherzan <andrei@gherzan.ro> | 2015-05-18 00:48:49 +0200 |
commit | 6ef9d94a2c2588dcefe442577ef6ae5bbe722dec (patch) | |
tree | 62b84a87ae50fe0331ee4150f51afe6946c376b6 /recipes-kernel | |
parent | bcae58ba84cb3125a6104d0627cd088a33fed09c (diff) | |
download | meta-raspberrypi-6ef9d94a2c2588dcefe442577ef6ae5bbe722dec.tar.gz |
linux-raspberrypi: Update 3.12 branch to latest
Update linux-raspberrypi_3.12 to latest revision.
Remove sl030raspberrypii2ckernel.patch since it will not apply anymore
and its content seems to be obsolite after
'558d0bf Fix grabbing lock from atomic context in i2c driver' was
merged to 3.12.
[Support #60]
Signed-off-by: Petter Mabäcker <petter@technux.se>
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-raspberrypi/sl030raspberrypii2ckernel.patch | 32 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-raspberrypi_3.12.bb | 3 |
2 files changed, 1 insertions, 34 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi/sl030raspberrypii2ckernel.patch b/recipes-kernel/linux/linux-raspberrypi/sl030raspberrypii2ckernel.patch deleted file mode 100644 index 8534ecb..0000000 --- a/recipes-kernel/linux/linux-raspberrypi/sl030raspberrypii2ckernel.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | Fix i2c timing errors. | ||
2 | |||
3 | When Transmitting: Make SDA valid quarter of a cycle after the falling edge of SCL. | ||
4 | When Receiving: Sample SDA Quarter of a cycle after the rising edge of SCL. | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | RP 2013/04/21 | ||
9 | |||
10 | Index: git/drivers/i2c/busses/i2c-bcm2708.c | ||
11 | =================================================================== | ||
12 | --- git.orig/drivers/i2c/busses/i2c-bcm2708.c 2013-01-06 17:15:00.754954587 +0000 | ||
13 | +++ git/drivers/i2c/busses/i2c-bcm2708.c 2013-01-06 17:50:09.794905741 +0000 | ||
14 | @@ -150,6 +150,7 @@ | ||
15 | unsigned long bus_hz; | ||
16 | u32 cdiv; | ||
17 | u32 c = BSC_C_I2CEN | BSC_C_INTD | BSC_C_ST | BSC_C_CLEAR_1; | ||
18 | + u32 cdel; | ||
19 | |||
20 | bus_hz = clk_get_rate(bi->clk); | ||
21 | cdiv = bus_hz / baudrate; | ||
22 | @@ -163,6 +164,10 @@ | ||
23 | bcm2708_wr(bi, BSC_A, bi->msg->addr); | ||
24 | bcm2708_wr(bi, BSC_DLEN, bi->msg->len); | ||
25 | bcm2708_wr(bi, BSC_C, c); | ||
26 | + | ||
27 | + cdel = (cdiv / 4) & 0xffff; | ||
28 | + cdel = cdel << 16 | cdel; | ||
29 | + bcm2708_wr(bi, BSC_DEL, cdel); | ||
30 | } | ||
31 | |||
32 | static irqreturn_t bcm2708_i2c_interrupt(int irq, void *dev_id) | ||
diff --git a/recipes-kernel/linux/linux-raspberrypi_3.12.bb b/recipes-kernel/linux/linux-raspberrypi_3.12.bb index 2952778..71fba49 100644 --- a/recipes-kernel/linux/linux-raspberrypi_3.12.bb +++ b/recipes-kernel/linux/linux-raspberrypi_3.12.bb | |||
@@ -1,8 +1,7 @@ | |||
1 | LINUX_VERSION ?= "3.12.36" | 1 | LINUX_VERSION ?= "3.12.36" |
2 | 2 | ||
3 | SRCREV = "90fa5df724d147564149c7b79cb1ffc571a345ec" | 3 | SRCREV = "ee9b8c7d46f2b1787b1e64604acafc70f70191cf" |
4 | SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=rpi-3.12.y \ | 4 | SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=rpi-3.12.y \ |
5 | file://sl030raspberrypii2ckernel.patch \ | ||
6 | " | 5 | " |
7 | 6 | ||
8 | require linux-raspberrypi.inc | 7 | require linux-raspberrypi.inc |