summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Doehring <toolmmy@gmail.com>2016-04-16 15:31:25 +0200
committerAndrei Gherzan <andrei@gherzan.ro>2016-04-20 22:57:56 +0200
commitbfc46bdd55d3d37efdb3734124c5c38975aa1323 (patch)
tree87522d88a16c2d6475a8bee558045edec9ad9421 /recipes-graphics
parent3645b27848edd0d873925f5fa2a7686f3ff9eeb9 (diff)
downloadmeta-raspberrypi-bfc46bdd55d3d37efdb3734124c5c38975aa1323.tar.gz
userland: Fix passing of wayland-native to cmake while configuring
While having 'wayland' set DISTRO_FEATURES 'wayland-native' is handled as a cmake parameter which breaks the do_configure: $ cat /data/builds/rpi3-sandbox/tmp/work/raspberrypi2-poky-linux-gnueab i/userland/git-r5/temp/run.do_configure cmake \ ${OECMAKE_SITEFILE} \ [...] -DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' wayland-native \ -Wno-dev $ CMake Error: The source directory "/data/builds/rpi3-sandbox/tmp/work/raspberrypi2-poky-linux-gnueabi/userland/git-r5/build/wayland-native" does not exist. | Specify --help for usage, or press the help button on the CMake GUI. Assuming that wayland-native should only be defined as a DEPENDS package this patch moves it to the correct PACKAGECONFIG position. Signed-off-by: Tom Doehring <toolmmy@gmail.com> Signed-off-by: toolmmy <toolmmy@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/userland/userland_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index ef06b12..0e7057e 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -45,7 +45,7 @@ EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-a
45 45
46PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}" 46PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
47 47
48PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,wayland-native,wayland" 48PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,,wayland-native wayland"
49 49
50CFLAGS_append = " -fPIC" 50CFLAGS_append = " -fPIC"
51 51