summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-06 00:25:15 -0700
committerAndrei Gherzan <andrei@gherzan.ro>2016-11-08 12:26:24 +0100
commita5f95f423322e8b4fe48eed00de5cad8dd8a9460 (patch)
treea74b4138569a135e52109ff9430801ba3b15fea8 /recipes-graphics
parent716b6a9cd7f24a8bacd539bb40519d185e3f963a (diff)
downloadmeta-raspberrypi-a5f95f423322e8b4fe48eed00de5cad8dd8a9460.tar.gz
userland: Bump to latest and add ASNEEDED = ""
ASNEEDED does not work with userland libraries as noted in see https://lists.yoctoproject.org/pipermail/yocto/2014-June/019933.html Helps with running kodi using gles2 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch14
-rw-r--r--recipes-graphics/userland/userland_git.bb4
2 files changed, 10 insertions, 8 deletions
diff --git a/recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch b/recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch
index 49a7872..98f18c8 100644
--- a/recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch
+++ b/recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch
@@ -1,4 +1,4 @@
1From 7f52662a4d1965988ee5ada28ce3525c38ebf164 Mon Sep 17 00:00:00 2001 1From 6ee44bd040bf8e8abf9c5a7be7f6ea4b82d5671a Mon Sep 17 00:00:00 2001
2From: Tomeu Vizoso <tomeu.vizoso@collabora.com> 2From: Tomeu Vizoso <tomeu.vizoso@collabora.com>
3Date: Tue, 1 Oct 2013 13:19:20 +0200 3Date: Tue, 1 Oct 2013 13:19:20 +0200
4Subject: [PATCH 03/13] wayland: Add Wayland example 4Subject: [PATCH 03/13] wayland: Add Wayland example
@@ -844,23 +844,23 @@ index 0000000..1a7bfc4
844+} 844+}
845+ 845+
846diff --git a/host_applications/linux/apps/hello_pi/rebuild.sh b/host_applications/linux/apps/hello_pi/rebuild.sh 846diff --git a/host_applications/linux/apps/hello_pi/rebuild.sh b/host_applications/linux/apps/hello_pi/rebuild.sh
847index fa4539e..37120ac 100755 847index 8225dd5..0be6ce7 100755
848--- a/host_applications/linux/apps/hello_pi/rebuild.sh 848--- a/host_applications/linux/apps/hello_pi/rebuild.sh
849+++ b/host_applications/linux/apps/hello_pi/rebuild.sh 849+++ b/host_applications/linux/apps/hello_pi/rebuild.sh
850@@ -13,6 +13,7 @@ make -C hello_jpeg clean 850@@ -14,6 +14,7 @@ make -C hello_videocube clean
851 make -C hello_videocube clean
852 make -C hello_teapot clean 851 make -C hello_teapot clean
853 make -C hello_fft clean 852 make -C hello_fft clean
853 make -C hello_mmal_encode clean
854+make -C hello_wayland clean 854+make -C hello_wayland clean
855 855
856 make -C libs/ilclient 856 make -C libs/ilclient
857 make -C libs/vgfont 857 make -C libs/vgfont
858@@ -29,4 +30,4 @@ make -C hello_jpeg 858@@ -31,4 +32,4 @@ make -C hello_videocube
859 make -C hello_videocube
860 make -C hello_teapot 859 make -C hello_teapot
861 make -C hello_fft 860 make -C hello_fft
861 make -C hello_mmal_encode
862- 862-
863+make -C hello_wayland 863+make -C hello_wayland
864-- 864--
8652.10.0 8652.10.2
866 866
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 7558851..84d6854 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -16,7 +16,7 @@ COMPATIBLE_MACHINE = "raspberrypi"
16 16
17SRCBRANCH = "master" 17SRCBRANCH = "master"
18SRCFORK = "raspberrypi" 18SRCFORK = "raspberrypi"
19SRCREV = "2852d9ff5a9038021f1c22d95e8a9e3aad09893f" 19SRCREV = "100f8bb3e74e29d04fb99857183cc34aaa712e3f"
20 20
21SRC_URI = "\ 21SRC_URI = "\
22 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ 22 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
@@ -38,6 +38,8 @@ S = "${WORKDIR}/git"
38 38
39inherit cmake pkgconfig 39inherit cmake pkgconfig
40 40
41ASNEEDED = ""
42
41EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \ 43EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \
42 -DVMCS_INSTALL_PREFIX=${exec_prefix} \ 44 -DVMCS_INSTALL_PREFIX=${exec_prefix} \
43" 45"