diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-02-03 20:33:34 -0800 |
---|---|---|
committer | Andrei Gherzan <andrei@gherzan.ro> | 2016-03-10 14:53:28 +0100 |
commit | 34cb8379294df3eedd449e24241fcb638dcd7264 (patch) | |
tree | c5543961b6987432751f54cd8a202b4c60a6871f /recipes-graphics | |
parent | 507ab2682b3a232fa7ffa52b8b2ef29f07845a26 (diff) | |
download | meta-raspberrypi-34cb8379294df3eedd449e24241fcb638dcd7264.tar.gz |
userland: Define PROJECT_APIVER and rprovide libgles2 libgl
These are needed for pkgconfig to have correct version number which is
checked by many configure systems e.g. cogl to decide on support for
wayland-egl
rprovides are expected by cogl as well to define runtime deps on
libgles2 and libgl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/userland/userland/0016-define-PROJECT_APIVER.patch | 33 | ||||
-rw-r--r-- | recipes-graphics/userland/userland_git.bb | 3 |
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-graphics/userland/userland/0016-define-PROJECT_APIVER.patch b/recipes-graphics/userland/userland/0016-define-PROJECT_APIVER.patch new file mode 100644 index 0000000..63a35eb --- /dev/null +++ b/recipes-graphics/userland/userland/0016-define-PROJECT_APIVER.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 56072d7282e7daf65f58fa897f1f76268ae88121 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 6 Feb 2016 11:06:26 -0800 | ||
4 | Subject: [PATCH 16/16] define PROJECT_APIVER | ||
5 | |||
6 | this helps in compiling components which use packageconfig to poke for | ||
7 | library versions and requiring minimum supported version | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | CMakeLists.txt | 6 ++++++ | ||
12 | 1 file changed, 6 insertions(+) | ||
13 | |||
14 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
15 | index b240ef6..aa5e14f 100644 | ||
16 | --- a/CMakeLists.txt | ||
17 | +++ b/CMakeLists.txt | ||
18 | @@ -2,6 +2,12 @@ cmake_minimum_required(VERSION 2.8) | ||
19 | |||
20 | project(vmcs_host_apps) | ||
21 | |||
22 | +SET(PROJECT_VER_MAJOR 1) | ||
23 | +SET(PROJECT_VER_MINOR 0) | ||
24 | +SET(PROJECT_VER_PATCH 0) | ||
25 | +SET(PROJECT_VER "${PROJECT_VER_MAJOR}.${PROJECT_VER_MINOR}.${PROJECT_VER_PATCH}") | ||
26 | +SET(PROJECT_APIVER "${PROJECT_VER}") | ||
27 | + | ||
28 | set(BUILD_MMAL TRUE) | ||
29 | set(BUILD_MMAL_APPS TRUE) | ||
30 | set(vmcs_root ${PROJECT_SOURCE_DIR}) | ||
31 | -- | ||
32 | 2.7.0 | ||
33 | |||
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb index d78a7c9..5ea48e1 100644 --- a/recipes-graphics/userland/userland_git.bb +++ b/recipes-graphics/userland/userland_git.bb | |||
@@ -10,6 +10,8 @@ PR = "r5" | |||
10 | PROVIDES = "virtual/libgles2 \ | 10 | PROVIDES = "virtual/libgles2 \ |
11 | virtual/egl" | 11 | virtual/egl" |
12 | 12 | ||
13 | RPROVIDES_${PN} += "libgles2 libgl" | ||
14 | |||
13 | COMPATIBLE_MACHINE = "raspberrypi" | 15 | COMPATIBLE_MACHINE = "raspberrypi" |
14 | 16 | ||
15 | SRCBRANCH = "master" | 17 | SRCBRANCH = "master" |
@@ -33,6 +35,7 @@ SRC_URI = "\ | |||
33 | file://0013-zero-out-wl-buffers-in-egl_surface_free.patch \ | 35 | file://0013-zero-out-wl-buffers-in-egl_surface_free.patch \ |
34 | file://0014-initialize-front-back-wayland-buffers.patch \ | 36 | file://0014-initialize-front-back-wayland-buffers.patch \ |
35 | file://0015-Remove-RPC_FLUSH.patch \ | 37 | file://0015-Remove-RPC_FLUSH.patch \ |
38 | file://0016-define-PROJECT_APIVER.patch \ | ||
36 | " | 39 | " |
37 | S = "${WORKDIR}/git" | 40 | S = "${WORKDIR}/git" |
38 | 41 | ||