diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-02-22 16:34:15 -0800 |
---|---|---|
committer | Andrei Gherzan <andrei@gherzan.ro> | 2019-02-24 11:07:36 +0000 |
commit | 60dbfd25443754690f834afe30e7a6dca46a40da (patch) | |
tree | 02afa16733ac801f295fff82d6043baf54fd6036 /recipes-graphics/userland | |
parent | a6c81aa527ce92e20452d5f23c17542bb81b4811 (diff) | |
download | meta-raspberrypi-60dbfd25443754690f834afe30e7a6dca46a40da.tar.gz |
userland: Upgrade to latest as of 20190114
Forward port the patches
package vcfiled init scripts
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/userland')
19 files changed, 44 insertions, 42 deletions
diff --git a/recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch b/recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch index d6b2abb..cea215d 100644 --- a/recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch +++ b/recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 08d56c1174e27573ae8df2a7b9e6632afd0bfe86 Mon Sep 17 00:00:00 2001 | 1 | From 829dff626d423ad34c8e710cd10d5fc9a4ea80b3 Mon Sep 17 00:00:00 2001 |
2 | From: Dom Cobley <dc4@broadcom.com> | 2 | From: Dom Cobley <dc4@broadcom.com> |
3 | Date: Tue, 9 Jul 2013 09:26:26 -0400 | 3 | Date: Tue, 9 Jul 2013 09:26:26 -0400 |
4 | Subject: [PATCH 01/18] Allow applications to set next resource handle | 4 | Subject: [PATCH 01/18] Allow applications to set next resource handle |
@@ -204,5 +204,5 @@ index 8a5734c..51b3580 100644 | |||
204 | 204 | ||
205 | FN(void, eglIntGetColorData_impl, (EGL_SURFACE_ID_T s, KHRN_IMAGE_FORMAT_T format, uint32_t width, uint32_t height, int32_t stride, uint32_t y_offset, void *data)) | 205 | FN(void, eglIntGetColorData_impl, (EGL_SURFACE_ID_T s, KHRN_IMAGE_FORMAT_T format, uint32_t width, uint32_t height, int32_t stride, uint32_t y_offset, void *data)) |
206 | -- | 206 | -- |
207 | 2.19.1 | 207 | 2.20.1 |
208 | 208 | ||
diff --git a/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch b/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch index c41cde7..5501000 100644 --- a/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch +++ b/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From da60a2a34a48e2b324fceae608964814488cc8fb Mon Sep 17 00:00:00 2001 | 1 | From 469840d211beb22085e57934bda3caabb71a4695 Mon Sep 17 00:00:00 2001 |
2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> | 2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> |
3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 | 3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 |
4 | Subject: [PATCH 02/18] wayland: Add support for the Wayland winsys | 4 | Subject: [PATCH 02/18] wayland: Add support for the Wayland winsys |
@@ -91,13 +91,13 @@ index cfc8ae5..673a5ad 100644 | |||
91 | 91 | ||
92 | # Global include paths | 92 | # Global include paths |
93 | diff --git a/README.md b/README.md | 93 | diff --git a/README.md b/README.md |
94 | index 94b93b8..50b90b1 100644 | 94 | index de5754d..2097036 100644 |
95 | --- a/README.md | 95 | --- a/README.md |
96 | +++ b/README.md | 96 | +++ b/README.md |
97 | @@ -6,3 +6,7 @@ Use buildme to build. It requires cmake to be installed and an arm cross compile | 97 | @@ -6,3 +6,7 @@ Use buildme to build. It requires cmake to be installed and an arm cross compile |
98 | https://github.com/raspberrypi/tools/tree/master/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian | 98 | https://github.com/raspberrypi/tools/tree/master/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian |
99 | 99 | ||
100 | Note that this repository does not contain the source for the edid_parser and vcdbg binaries due to licensing restrictions. | 100 | Note that this repository does not contain the source for the edidparser and vcdbg binaries due to licensing restrictions. |
101 | + | 101 | + |
102 | +To build support for the Wayland winsys in EGL, execute the buildme script like this: | 102 | +To build support for the Wayland winsys in EGL, execute the buildme script like this: |
103 | + | 103 | + |
@@ -133,10 +133,10 @@ index b8fd440..a780bb6 100755 | |||
133 | 133 | ||
134 | if [ "$1" != "" ]; then | 134 | if [ "$1" != "" ]; then |
135 | diff --git a/host_applications/linux/apps/raspicam/CMakeLists.txt b/host_applications/linux/apps/raspicam/CMakeLists.txt | 135 | diff --git a/host_applications/linux/apps/raspicam/CMakeLists.txt b/host_applications/linux/apps/raspicam/CMakeLists.txt |
136 | index 42636e8..d47ad55 100644 | 136 | index f7db21e..73997b7 100644 |
137 | --- a/host_applications/linux/apps/raspicam/CMakeLists.txt | 137 | --- a/host_applications/linux/apps/raspicam/CMakeLists.txt |
138 | +++ b/host_applications/linux/apps/raspicam/CMakeLists.txt | 138 | +++ b/host_applications/linux/apps/raspicam/CMakeLists.txt |
139 | @@ -33,7 +33,7 @@ add_executable(raspividyuv ${COMMON_SOURCES} RaspiVidYUV.c) | 139 | @@ -54,7 +54,7 @@ add_executable(raspividyuv ${COMMON_SOURCES} RaspiVidYUV.c) |
140 | 140 | ||
141 | set (MMAL_LIBS mmal_core mmal_util mmal_vc_client) | 141 | set (MMAL_LIBS mmal_core mmal_util mmal_vc_client) |
142 | 142 | ||
@@ -1894,5 +1894,5 @@ index 0000000..ad90d30 | |||
1894 | + set(${_sources} ${${_sources}} PARENT_SCOPE) | 1894 | + set(${_sources} ${${_sources}} PARENT_SCOPE) |
1895 | +endfunction() | 1895 | +endfunction() |
1896 | -- | 1896 | -- |
1897 | 2.19.1 | 1897 | 2.20.1 |
1898 | 1898 | ||
diff --git a/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch b/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch index d83a9e5..74b97b8 100644 --- a/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch +++ b/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 976cc9355fe18487cd84e313e76f397ab47a4bf8 Mon Sep 17 00:00:00 2001 | 1 | From 2391bba64116135369147e930fb14b5824a9cef0 Mon Sep 17 00:00:00 2001 |
2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> | 2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> |
3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 | 3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 |
4 | Subject: [PATCH 03/18] wayland: Add Wayland example | 4 | Subject: [PATCH 03/18] wayland: Add Wayland example |
@@ -862,5 +862,5 @@ index 8225dd5..0be6ce7 100755 | |||
862 | - | 862 | - |
863 | +make -C hello_wayland | 863 | +make -C hello_wayland |
864 | -- | 864 | -- |
865 | 2.19.1 | 865 | 2.20.1 |
866 | 866 | ||
diff --git a/recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch b/recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch index a42aa14..9621afa 100644 --- a/recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch +++ b/recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From c379bd2dc575256084d9e36fc11a347e20660130 Mon Sep 17 00:00:00 2001 | 1 | From 3d1d046281b90d6777864b0d9a032657fad78d76 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 10 Aug 2015 02:38:27 -0700 | 3 | Date: Mon, 10 Aug 2015 02:38:27 -0700 |
4 | Subject: [PATCH 04/18] wayland-egl: Add bcm_host to dependencies | 4 | Subject: [PATCH 04/18] wayland-egl: Add bcm_host to dependencies |
@@ -24,5 +24,5 @@ index 8bafc15..fd259c9 100644 | |||
24 | Libs: -L${libdir} -lwayland-egl | 24 | Libs: -L${libdir} -lwayland-egl |
25 | Cflags: -I${includedir} | 25 | Cflags: -I${includedir} |
26 | -- | 26 | -- |
27 | 2.19.1 | 27 | 2.20.1 |
28 | 28 | ||
diff --git a/recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch b/recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch index bbaadda..004e2eb 100644 --- a/recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch +++ b/recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From bd940c32878d401f311215270579ff513c2f3999 Mon Sep 17 00:00:00 2001 | 1 | From d17e5b9285635dcbe1c6e5a7398f6e5b1560a0c0 Mon Sep 17 00:00:00 2001 |
2 | From: "Yann E. MORIN" <yann.morin.1998@free.fr> | 2 | From: "Yann E. MORIN" <yann.morin.1998@free.fr> |
3 | Date: Sat, 24 Jan 2015 22:07:19 +0100 | 3 | Date: Sat, 24 Jan 2015 22:07:19 +0100 |
4 | Subject: [PATCH 05/18] interface: remove faulty assert() to make weston happy | 4 | Subject: [PATCH 05/18] interface: remove faulty assert() to make weston happy |
@@ -25,5 +25,5 @@ index eab146e..29e0dee 100755 | |||
25 | } | 25 | } |
26 | } else { | 26 | } else { |
27 | -- | 27 | -- |
28 | 2.19.1 | 28 | 2.20.1 |
29 | 29 | ||
diff --git a/recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch b/recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch index 1a5e14f..955dfa1 100644 --- a/recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch +++ b/recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 466f28ce302f68ac39be750f4b55285791f43ab1 Mon Sep 17 00:00:00 2001 | 1 | From 7d4559c2418f4997dfdddefa9281250d0d8082db Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 6 Feb 2016 11:10:47 -0800 | 3 | Date: Sat, 6 Feb 2016 11:10:47 -0800 |
4 | Subject: [PATCH 06/18] zero-out wl buffers in egl_surface_free | 4 | Subject: [PATCH 06/18] zero-out wl buffers in egl_surface_free |
@@ -29,5 +29,5 @@ index 42350bf..1f923d9 100644 | |||
29 | #endif | 29 | #endif |
30 | } | 30 | } |
31 | -- | 31 | -- |
32 | 2.19.1 | 32 | 2.20.1 |
33 | 33 | ||
diff --git a/recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch b/recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch index 72264e4..514782f 100644 --- a/recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch +++ b/recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From b4a2967513f7d0f5f3caee8cf6cbc7a7a085ebac Mon Sep 17 00:00:00 2001 | 1 | From 19e63107670bb15833744402d68c8fcae9e53a12 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 6 Feb 2016 11:11:41 -0800 | 3 | Date: Sat, 6 Feb 2016 11:11:41 -0800 |
4 | Subject: [PATCH 07/18] initialize front back wayland buffers | 4 | Subject: [PATCH 07/18] initialize front back wayland buffers |
@@ -30,5 +30,5 @@ index 1f923d9..9a9582c 100644 | |||
30 | } | 30 | } |
31 | #endif | 31 | #endif |
32 | -- | 32 | -- |
33 | 2.19.1 | 33 | 2.20.1 |
34 | 34 | ||
diff --git a/recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch b/recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch index a100e39..bd6c2ff 100644 --- a/recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch +++ b/recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 14c22987dfa9fec02794856cd15b2d64b4b81c32 Mon Sep 17 00:00:00 2001 | 1 | From 4312ce4f9320b25f513c4d8fa163f9d8faebfd97 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 6 Feb 2016 11:09:18 -0800 | 3 | Date: Sat, 6 Feb 2016 11:09:18 -0800 |
4 | Subject: [PATCH 08/18] Remove RPC_FLUSH | 4 | Subject: [PATCH 08/18] Remove RPC_FLUSH |
@@ -23,5 +23,5 @@ index f9b7287..b04ffef 100644 | |||
23 | } | 23 | } |
24 | #endif | 24 | #endif |
25 | -- | 25 | -- |
26 | 2.19.1 | 26 | 2.20.1 |
27 | 27 | ||
diff --git a/recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch b/recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch index 4609455..e138ae2 100644 --- a/recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch +++ b/recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From e510be221276d06e630ab93452ecb712d3921790 Mon Sep 17 00:00:00 2001 | 1 | From cb454ad44fcb35fc28b823f05f3538c1f997e89e Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 6 Feb 2016 13:12:47 -0800 | 3 | Date: Sat, 6 Feb 2016 13:12:47 -0800 |
4 | Subject: [PATCH 09/18] fix cmake dependency race | 4 | Subject: [PATCH 09/18] fix cmake dependency race |
@@ -74,5 +74,5 @@ index f0bae30..8c44c58 100644 | |||
74 | struct wl_resource *resource; | 74 | struct wl_resource *resource; |
75 | struct wl_dispmanx *dispmanx; | 75 | struct wl_dispmanx *dispmanx; |
76 | -- | 76 | -- |
77 | 2.19.1 | 77 | 2.20.1 |
78 | 78 | ||
diff --git a/recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch b/recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch index dd0b95e..70d9045 100644 --- a/recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch +++ b/recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 8e6cde08077eadfe563dc17c19995ebc48e30b97 Mon Sep 17 00:00:00 2001 | 1 | From 2f0b25266d0b4b04ef78b8950f5bd9749857b4f0 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Tue, 29 Mar 2016 20:38:30 -0700 | 3 | Date: Tue, 29 Mar 2016 20:38:30 -0700 |
4 | Subject: [PATCH 10/18] Fix for framerate with nested composition | 4 | Subject: [PATCH 10/18] Fix for framerate with nested composition |
@@ -56,5 +56,5 @@ index 03fe67b..13a110c 100644 | |||
56 | #ifdef ANDROID | 56 | #ifdef ANDROID |
57 | CLIENT_UNLOCK(); | 57 | CLIENT_UNLOCK(); |
58 | -- | 58 | -- |
59 | 2.19.1 | 59 | 2.20.1 |
60 | 60 | ||
diff --git a/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch b/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch index 4bd5320..da37102 100644 --- a/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch +++ b/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 9a97d60262999093d6ce8cb688279506c210d802 Mon Sep 17 00:00:00 2001 | 1 | From 5bc4118e7861f35ead6565530cb4213987296fb9 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 2 Apr 2016 10:37:24 -0700 | 3 | Date: Sat, 2 Apr 2016 10:37:24 -0700 |
4 | Subject: [PATCH 11/18] build shared library for vchostif | 4 | Subject: [PATCH 11/18] build shared library for vchostif |
@@ -24,5 +24,5 @@ index c415176..d0cca1a 100755 | |||
24 | #add_library(bufman vc_vchi_bufman.c ) | 24 | #add_library(bufman vc_vchi_bufman.c ) |
25 | 25 | ||
26 | -- | 26 | -- |
27 | 2.19.1 | 27 | 2.20.1 |
28 | 28 | ||
diff --git a/recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch b/recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch index 9684b4c..40666fd 100644 --- a/recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch +++ b/recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From fedd7668152049c15ed58c7058e5f4a9c1fac7cb Mon Sep 17 00:00:00 2001 | 1 | From 27194bc05a7a488827590208285a8757164edcef Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 2 Apr 2016 10:54:59 -0700 | 3 | Date: Sat, 2 Apr 2016 10:54:59 -0700 |
4 | Subject: [PATCH 12/18] implement buffer wrapping interface for dispmanx | 4 | Subject: [PATCH 12/18] implement buffer wrapping interface for dispmanx |
@@ -88,5 +88,5 @@ index c18626d..11ed1ef 100644 | |||
88 | 88 | ||
89 | </protocol> | 89 | </protocol> |
90 | -- | 90 | -- |
91 | 2.19.1 | 91 | 2.20.1 |
92 | 92 | ||
diff --git a/recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch b/recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch index 3052168..5197856 100644 --- a/recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch +++ b/recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 65f8bca55aead676cd06fc3210aeffef1f2158c6 Mon Sep 17 00:00:00 2001 | 1 | From e99b2eafba5260b8087fc1a85830b08ea3228292 Mon Sep 17 00:00:00 2001 |
2 | From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com> | 2 | From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com> |
3 | Date: Thu, 19 Jan 2017 18:56:07 +0000 | 3 | Date: Thu, 19 Jan 2017 18:56:07 +0000 |
4 | Subject: [PATCH 13/18] Implement triple buffering for wayland | 4 | Subject: [PATCH 13/18] Implement triple buffering for wayland |
@@ -86,5 +86,5 @@ index e328b77..58a3184 100644 | |||
86 | back_wl_buffer | 86 | back_wl_buffer |
87 | 87 | ||
88 | -- | 88 | -- |
89 | 2.19.1 | 89 | 2.20.1 |
90 | 90 | ||
diff --git a/recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch b/recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch index 037d708..7f7e732 100644 --- a/recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch +++ b/recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From dc1d07d835e1fe70c957a655d6fbb8cde65775af Mon Sep 17 00:00:00 2001 | 1 | From a9726c7fdcd386bd104b13c494d261f693dde792 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 10 May 2017 06:39:34 +0000 | 3 | Date: Wed, 10 May 2017 06:39:34 +0000 |
4 | Subject: [PATCH 14/18] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT | 4 | Subject: [PATCH 14/18] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT |
@@ -31,5 +31,5 @@ index 4eacf7f..b1acc9f 100644 | |||
31 | #ifndef GL_EXT_texture_type_2_10_10_10_REV | 31 | #ifndef GL_EXT_texture_type_2_10_10_10_REV |
32 | #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368 | 32 | #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368 |
33 | -- | 33 | -- |
34 | 2.19.1 | 34 | 2.20.1 |
35 | 35 | ||
diff --git a/recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch b/recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch index 02cecb8..cfcc120 100644 --- a/recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch +++ b/recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From b5fa294c0d8fcb6dd5bfbfb96a0885dd9f3ae609 Mon Sep 17 00:00:00 2001 | 1 | From 3ba79e86cdec88440885fefc7aadf793b301b000 Mon Sep 17 00:00:00 2001 |
2 | From: Andrea Galbusera <gizero@gmail.com> | 2 | From: Andrea Galbusera <gizero@gmail.com> |
3 | Date: Fri, 14 Jul 2017 09:52:54 +0200 | 3 | Date: Fri, 14 Jul 2017 09:52:54 +0200 |
4 | Subject: [PATCH 15/18] EGL/glplatform.h: define EGL_CAST | 4 | Subject: [PATCH 15/18] EGL/glplatform.h: define EGL_CAST |
@@ -28,5 +28,5 @@ index 1f7c930..c39d425 100644 | |||
28 | + | 28 | + |
29 | #endif /* __eglplatform_h */ | 29 | #endif /* __eglplatform_h */ |
30 | -- | 30 | -- |
31 | 2.19.1 | 31 | 2.20.1 |
32 | 32 | ||
diff --git a/recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch b/recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch index 34ad90c..2d1b882 100644 --- a/recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch +++ b/recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From bff03f92c0d8bae113e0c7234c719f8385808b38 Mon Sep 17 00:00:00 2001 | 1 | From 5c53b2ff4d14b988ae9ab453fb2ef97b6a277ded Mon Sep 17 00:00:00 2001 |
2 | From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com> | 2 | From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com> |
3 | Date: Sat, 27 Jan 2018 12:28:31 -0500 | 3 | Date: Sat, 27 Jan 2018 12:28:31 -0500 |
4 | Subject: [PATCH 16/18] Allow multiple wayland compositor state data per | 4 | Subject: [PATCH 16/18] Allow multiple wayland compositor state data per |
@@ -141,5 +141,5 @@ index 9ef89cd..abd5ab3 100644 | |||
141 | CLIENT_UNLOCK(); | 141 | CLIENT_UNLOCK(); |
142 | 142 | ||
143 | -- | 143 | -- |
144 | 2.19.1 | 144 | 2.20.1 |
145 | 145 | ||
diff --git a/recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch b/recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch index 546cd58..9c223ab 100644 --- a/recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch +++ b/recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 8efd81e96bdd3be68063a6fd32be4755225e93b2 Mon Sep 17 00:00:00 2001 | 1 | From 0d3c6b7ca5d352cc00d9501b9d5576c4ece70a83 Mon Sep 17 00:00:00 2001 |
2 | From: Hugo Hromic <hhromic@gmail.com> | 2 | From: Hugo Hromic <hhromic@gmail.com> |
3 | Date: Sun, 13 May 2018 10:49:04 +0100 | 3 | Date: Sun, 13 May 2018 10:49:04 +0100 |
4 | Subject: [PATCH 17/18] khronos: backport typedef for | 4 | Subject: [PATCH 17/18] khronos: backport typedef for |
@@ -34,5 +34,5 @@ index d7e5ba7..dcc90ce 100755 | |||
34 | #ifndef EGL_WL_bind_wayland_display | 34 | #ifndef EGL_WL_bind_wayland_display |
35 | #define EGL_WL_bind_wayland_display 1 | 35 | #define EGL_WL_bind_wayland_display 1 |
36 | -- | 36 | -- |
37 | 2.19.1 | 37 | 2.20.1 |
38 | 38 | ||
diff --git a/recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch b/recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch index f4d865e..03499d4 100644 --- a/recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch +++ b/recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 9cfea4761ba68776fd9bfac671b74c7174f99029 Mon Sep 17 00:00:00 2001 | 1 | From 0f98ccac128265b85af3c5e310413fc9fce9f78c Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sun, 15 Jul 2018 00:48:38 -0700 | 3 | Date: Sun, 15 Jul 2018 00:48:38 -0700 |
4 | Subject: [PATCH 18/18] Add EGL_IMG_context_priority related defines | 4 | Subject: [PATCH 18/18] Add EGL_IMG_context_priority related defines |
@@ -31,5 +31,5 @@ index dcc90ce..6842bf9 100755 | |||
31 | #define EGL_KHR_vg_parent_image 1 | 31 | #define EGL_KHR_vg_parent_image 1 |
32 | #define EGL_VG_PARENT_IMAGE_KHR 0x30BA /* eglCreateImageKHR target */ | 32 | #define EGL_VG_PARENT_IMAGE_KHR 0x30BA /* eglCreateImageKHR target */ |
33 | -- | 33 | -- |
34 | 2.19.1 | 34 | 2.20.1 |
35 | 35 | ||
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb index f5c803e..4311588 100644 --- a/recipes-graphics/userland/userland_git.bb +++ b/recipes-graphics/userland/userland_git.bb | |||
@@ -12,11 +12,11 @@ COMPATIBLE_MACHINE = "^rpi$" | |||
12 | 12 | ||
13 | SRCBRANCH = "master" | 13 | SRCBRANCH = "master" |
14 | SRCFORK = "raspberrypi" | 14 | SRCFORK = "raspberrypi" |
15 | SRCREV = "d574b51a60a075baefe863670466ee24e6c4256e" | 15 | SRCREV = "e5803f2c986cbf8c919c60278b3231dcdf4271a6" |
16 | 16 | ||
17 | # Use the date of the above commit as the package version. Update this when | 17 | # Use the date of the above commit as the package version. Update this when |
18 | # SRCREV is changed. | 18 | # SRCREV is changed. |
19 | PV = "20181120" | 19 | PV = "20190114" |
20 | 20 | ||
21 | SRC_URI = "\ | 21 | SRC_URI = "\ |
22 | git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ | 22 | git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ |
@@ -64,6 +64,8 @@ do_install_append () { | |||
64 | sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f} | 64 | sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f} |
65 | sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f} | 65 | sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f} |
66 | done | 66 | done |
67 | install -D -m 0755 ${D}${prefix}${sysconfdir}/init.d/vcfiled ${D}${sysconfdir}/init.d/vcfiled | ||
68 | rm -rf ${D}${prefix}${sysconfdir} | ||
67 | if [ "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" = "1" ]; then | 69 | if [ "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" = "1" ]; then |
68 | rm -rf ${D}${libdir}/libEGL* | 70 | rm -rf ${D}${libdir}/libEGL* |
69 | rm -rf ${D}${libdir}/libGLES* | 71 | rm -rf ${D}${libdir}/libGLES* |