diff options
author | Andrea Galbusera <gizero@gmail.com> | 2017-04-03 22:07:27 +0200 |
---|---|---|
committer | Andrei Gherzan <andrei@gherzan.ro> | 2017-04-05 16:37:13 +0100 |
commit | 4b0bc450e08e6836744c97d21e72600f8320fc05 (patch) | |
tree | 0bcbf964713f1e3b14751dfb021fbf53c1be4523 /recipes-devtools | |
parent | d0c152d7f88d9d0d6c85904c6143a189f3caa380 (diff) | |
download | meta-raspberrypi-4b0bc450e08e6836744c97d21e72600f8320fc05.tar.gz |
wiringpi: uprev to 2.44
This upgrade is required to solve the following runtime hardware detection
issue when calling wiringPiSetup() on the Pi3:
Unable to determine hardware version. I see: Hardware : BCM2835
,
- expecting BCM2708 or BCM2709.
This was triggered by the recent kernel upgrade to 4.9 that introduced
"BCM2835" as the hardware signature in /proc/cpuinfo.
Patches reworked as follow:
* 0001-Add-initial-cross-compile-support.patch: rebase to current upstream
* 0001-include-asm-ioctl.h-directly-for-_IOC_SIZEBITS.patch: drop since is now
upstream
Signed-off-by: Andrea Galbusera <gizero@gmail.com>
Diffstat (limited to 'recipes-devtools')
3 files changed, 51 insertions, 108 deletions
diff --git a/recipes-devtools/wiringPi/files/0001-Add-initial-cross-compile-support.patch b/recipes-devtools/wiringPi/files/0001-Add-initial-cross-compile-support.patch index 603422c..a081b8d 100644 --- a/recipes-devtools/wiringPi/files/0001-Add-initial-cross-compile-support.patch +++ b/recipes-devtools/wiringPi/files/0001-Add-initial-cross-compile-support.patch | |||
@@ -1,21 +1,26 @@ | |||
1 | From 6d85e6cc3ab97c3f060e5e0a8e3f1945a14c86ba Mon Sep 17 00:00:00 2001 | 1 | From 4ed727aa9e528f130fdc8798df771037a1f22fc9 Mon Sep 17 00:00:00 2001 |
2 | From: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com> | 2 | From: Andrea Galbusera <gizero@gmail.com> |
3 | Date: Mon, 12 Oct 2015 12:15:51 +0200 | 3 | Date: Mon, 3 Apr 2017 14:48:14 +0200 |
4 | Subject: [PATCH] Add initial cross compile support (rebase from Petter Mabäcker <petter@technux.se> version) | 4 | Subject: [PATCH] =?UTF-8?q?Add=20initial=20cross=20compile=20support=20(re?= |
5 | =?UTF-8?q?base=20from=20Petter=20Mab=C3=A4cker=20<petter@technux.se>=20ve?= | ||
6 | =?UTF-8?q?rsion)?= | ||
7 | MIME-Version: 1.0 | ||
8 | Content-Type: text/plain; charset=UTF-8 | ||
9 | Content-Transfer-Encoding: 8bit | ||
5 | 10 | ||
6 | --- | 11 | --- |
7 | devLib/Makefile | 54 ++++++++++++++++++++++++------------------- | 12 | devLib/Makefile | 54 +++++++++++++++++++++++++-------------------- |
8 | examples/Gertboard/Makefile | 22 +++++++++++------- | 13 | examples/Gertboard/Makefile | 20 +++++++++++------ |
9 | examples/Makefile | 22 +++++++++++------- | 14 | examples/Makefile | 20 +++++++++++------ |
10 | examples/PiFace/Makefile | 22 +++++++++++------- | 15 | examples/PiFace/Makefile | 20 +++++++++++------ |
11 | examples/PiGlow/Makefile | 4 ++-- | 16 | examples/PiGlow/Makefile | 4 ++-- |
12 | examples/q2w/Makefile | 4 ++-- | 17 | examples/q2w/Makefile | 4 ++-- |
13 | gpio/Makefile | 29 ++++++++++++----------- | 18 | gpio/Makefile | 29 ++++++++++++------------ |
14 | wiringPi/Makefile | 50 +++++++++++++++++++++------------------ | 19 | wiringPi/Makefile | 50 +++++++++++++++++++++++------------------ |
15 | 8 files changed, 119 insertions(+), 88 deletions(-) | 20 | 8 files changed, 116 insertions(+), 85 deletions(-) |
16 | 21 | ||
17 | diff --git a/devLib/Makefile b/devLib/Makefile | 22 | diff --git a/devLib/Makefile b/devLib/Makefile |
18 | index 0fb0033..cbea759 100644 | 23 | index cf665d6..040c03a 100644 |
19 | --- a/devLib/Makefile | 24 | --- a/devLib/Makefile |
20 | +++ b/devLib/Makefile | 25 | +++ b/devLib/Makefile |
21 | @@ -31,15 +31,19 @@ ifneq ($V,1) | 26 | @@ -31,15 +31,19 @@ ifneq ($V,1) |
@@ -46,7 +51,7 @@ index 0fb0033..cbea759 100644 | |||
46 | 51 | ||
47 | LIBS = | 52 | LIBS = |
48 | 53 | ||
49 | @@ -66,16 +70,16 @@ $(STATIC): $(OBJ) | 54 | @@ -68,16 +72,16 @@ $(STATIC): $(OBJ) |
50 | 55 | ||
51 | $(DYNAMIC): $(OBJ) | 56 | $(DYNAMIC): $(OBJ) |
52 | $Q echo "[Link (Dynamic)]" | 57 | $Q echo "[Link (Dynamic)]" |
@@ -66,7 +71,7 @@ index 0fb0033..cbea759 100644 | |||
66 | 71 | ||
67 | .PHONY: tags | 72 | .PHONY: tags |
68 | tags: $(SRC) | 73 | tags: $(SRC) |
69 | @@ -86,22 +90,22 @@ tags: $(SRC) | 74 | @@ -88,22 +92,22 @@ tags: $(SRC) |
70 | .PHONY: install | 75 | .PHONY: install |
71 | install: $(DYNAMIC) | 76 | install: $(DYNAMIC) |
72 | $Q echo "[Install Headers]" | 77 | $Q echo "[Install Headers]" |
@@ -99,7 +104,7 @@ index 0fb0033..cbea759 100644 | |||
99 | 104 | ||
100 | .PHONY: install-deb | 105 | .PHONY: install-deb |
101 | install-deb: $(DYNAMIC) | 106 | install-deb: $(DYNAMIC) |
102 | @@ -116,9 +120,11 @@ install-deb: $(DYNAMIC) | 107 | @@ -118,9 +122,11 @@ install-deb: $(DYNAMIC) |
103 | .PHONY: uninstall | 108 | .PHONY: uninstall |
104 | uninstall: | 109 | uninstall: |
105 | $Q echo "[UnInstall]" | 110 | $Q echo "[UnInstall]" |
@@ -127,12 +132,11 @@ index 1939ad6..98d1415 100644 | |||
127 | -CC = gcc | 132 | -CC = gcc |
128 | -INCLUDE = -I/usr/local/include | 133 | -INCLUDE = -I/usr/local/include |
129 | -CFLAGS = $(DEBUG) -Wall $(INCLUDE) -Winline -pipe | 134 | -CFLAGS = $(DEBUG) -Wall $(INCLUDE) -Winline -pipe |
130 | - | ||
131 | -LDFLAGS = -L/usr/local/lib | ||
132 | -LDLIBS = -lwiringPi -lwiringPiDev -lpthread -lm | ||
133 | +DESTDIR?=/usr | 135 | +DESTDIR?=/usr |
134 | +PREFIX?=/local | 136 | +PREFIX?=/local |
135 | + | 137 | |
138 | -LDFLAGS = -L/usr/local/lib | ||
139 | -LDLIBS = -lwiringPi -lwiringPiDev -lpthread -lm | ||
136 | +INCLUDE_DIR?=$(DESTDIR)$(PREFIX)/include | 140 | +INCLUDE_DIR?=$(DESTDIR)$(PREFIX)/include |
137 | +LIB_DIR?=$(DESTDIR)$(PREFIX)/lib | 141 | +LIB_DIR?=$(DESTDIR)$(PREFIX)/lib |
138 | + | 142 | + |
@@ -148,7 +152,7 @@ index 1939ad6..98d1415 100644 | |||
148 | # Should not alter anything below this line | 152 | # Should not alter anything below this line |
149 | ############################################################################### | 153 | ############################################################################### |
150 | diff --git a/examples/Makefile b/examples/Makefile | 154 | diff --git a/examples/Makefile b/examples/Makefile |
151 | index e6b9b71..931b167 100644 | 155 | index 6d87885..8623816 100644 |
152 | --- a/examples/Makefile | 156 | --- a/examples/Makefile |
153 | +++ b/examples/Makefile | 157 | +++ b/examples/Makefile |
154 | @@ -26,14 +26,20 @@ ifneq ($V,1) | 158 | @@ -26,14 +26,20 @@ ifneq ($V,1) |
@@ -160,12 +164,11 @@ index e6b9b71..931b167 100644 | |||
160 | -CC = gcc | 164 | -CC = gcc |
161 | -INCLUDE = -I/usr/local/include | 165 | -INCLUDE = -I/usr/local/include |
162 | -CFLAGS = $(DEBUG) -Wall $(INCLUDE) -Winline -pipe | 166 | -CFLAGS = $(DEBUG) -Wall $(INCLUDE) -Winline -pipe |
163 | - | ||
164 | -LDFLAGS = -L/usr/local/lib | ||
165 | -LDLIBS = -lwiringPi -lwiringPiDev -lpthread -lm | ||
166 | +DESTDIR?=/usr | 167 | +DESTDIR?=/usr |
167 | +PREFIX?=/local | 168 | +PREFIX?=/local |
168 | + | 169 | |
170 | -LDFLAGS = -L/usr/local/lib | ||
171 | -LDLIBS = -lwiringPi -lwiringPiDev -lpthread -lm -lcrypt -lrt | ||
169 | +INCLUDE_DIR?=$(DESTDIR)$(PREFIX)/include | 172 | +INCLUDE_DIR?=$(DESTDIR)$(PREFIX)/include |
170 | +LIB_DIR?=$(DESTDIR)$(PREFIX)/lib | 173 | +LIB_DIR?=$(DESTDIR)$(PREFIX)/lib |
171 | + | 174 | + |
@@ -176,12 +179,12 @@ index e6b9b71..931b167 100644 | |||
176 | +CFLAGS ?= $(DEBUG) -Wall $(INCLUDE) -Winline -pipe | 179 | +CFLAGS ?= $(DEBUG) -Wall $(INCLUDE) -Winline -pipe |
177 | + | 180 | + |
178 | +LDFLAGS ?= -L$(LIB_DIR) | 181 | +LDFLAGS ?= -L$(LIB_DIR) |
179 | +LDLIBS ?= -lwiringPi -lwiringPiDev -lpthread -lm | 182 | +LDLIBS ?= -lwiringPi -lwiringPiDev -lpthread -lm -lcrypt -lrt |
180 | 183 | ||
181 | # Should not alter anything below this line | 184 | # Should not alter anything below this line |
182 | ############################################################################### | 185 | ############################################################################### |
183 | diff --git a/examples/PiFace/Makefile b/examples/PiFace/Makefile | 186 | diff --git a/examples/PiFace/Makefile b/examples/PiFace/Makefile |
184 | index 4685adc..cfaf902 100644 | 187 | index f937c14..ad030b3 100644 |
185 | --- a/examples/PiFace/Makefile | 188 | --- a/examples/PiFace/Makefile |
186 | +++ b/examples/PiFace/Makefile | 189 | +++ b/examples/PiFace/Makefile |
187 | @@ -26,14 +26,20 @@ ifneq ($V,1) | 190 | @@ -26,14 +26,20 @@ ifneq ($V,1) |
@@ -193,12 +196,11 @@ index 4685adc..cfaf902 100644 | |||
193 | -CC = gcc | 196 | -CC = gcc |
194 | -INCLUDE = -I/usr/local/include | 197 | -INCLUDE = -I/usr/local/include |
195 | -CFLAGS = $(DEBUG) -Wall $(INCLUDE) -Winline -pipe | 198 | -CFLAGS = $(DEBUG) -Wall $(INCLUDE) -Winline -pipe |
196 | - | ||
197 | -LDFLAGS = -L/usr/local/lib | ||
198 | -LDLIBS = -lwiringPi -lwiringPiDev -lpthread -lm | ||
199 | +DESTDIR?=/usr | 199 | +DESTDIR?=/usr |
200 | +PREFIX?=/local | 200 | +PREFIX?=/local |
201 | + | 201 | |
202 | -LDFLAGS = -L/usr/local/lib | ||
203 | -LDLIBS = -lwiringPi -lwiringPiDev -lpthread -lm | ||
202 | +INCLUDE_DIR?=$(DESTDIR)$(PREFIX)/include | 204 | +INCLUDE_DIR?=$(DESTDIR)$(PREFIX)/include |
203 | +LIB_DIR?=$(DESTDIR)$(PREFIX)/lib | 205 | +LIB_DIR?=$(DESTDIR)$(PREFIX)/lib |
204 | + | 206 | + |
@@ -214,7 +216,7 @@ index 4685adc..cfaf902 100644 | |||
214 | # Should not alter anything below this line | 216 | # Should not alter anything below this line |
215 | ############################################################################### | 217 | ############################################################################### |
216 | diff --git a/examples/PiGlow/Makefile b/examples/PiGlow/Makefile | 218 | diff --git a/examples/PiGlow/Makefile b/examples/PiGlow/Makefile |
217 | index acd4818..dabd64e 100644 | 219 | index f182db7..d1ea74f 100644 |
218 | --- a/examples/PiGlow/Makefile | 220 | --- a/examples/PiGlow/Makefile |
219 | +++ b/examples/PiGlow/Makefile | 221 | +++ b/examples/PiGlow/Makefile |
220 | @@ -29,10 +29,10 @@ endif | 222 | @@ -29,10 +29,10 @@ endif |
@@ -231,7 +233,7 @@ index acd4818..dabd64e 100644 | |||
231 | 233 | ||
232 | # Should not alter anything below this line | 234 | # Should not alter anything below this line |
233 | diff --git a/examples/q2w/Makefile b/examples/q2w/Makefile | 235 | diff --git a/examples/q2w/Makefile b/examples/q2w/Makefile |
234 | index 6f50fa0..c5e9f6e 100644 | 236 | index 8f773bf..14aa6e4 100644 |
235 | --- a/examples/q2w/Makefile | 237 | --- a/examples/q2w/Makefile |
236 | +++ b/examples/q2w/Makefile | 238 | +++ b/examples/q2w/Makefile |
237 | @@ -29,10 +29,10 @@ endif | 239 | @@ -29,10 +29,10 @@ endif |
@@ -248,7 +250,7 @@ index 6f50fa0..c5e9f6e 100644 | |||
248 | 250 | ||
249 | ############################################################################### | 251 | ############################################################################### |
250 | diff --git a/gpio/Makefile b/gpio/Makefile | 252 | diff --git a/gpio/Makefile b/gpio/Makefile |
251 | index 7dcd090..83ec454 100644 | 253 | index f41a005..22753ee 100644 |
252 | --- a/gpio/Makefile | 254 | --- a/gpio/Makefile |
253 | +++ b/gpio/Makefile | 255 | +++ b/gpio/Makefile |
254 | @@ -30,13 +30,17 @@ ifneq ($V,1) | 256 | @@ -30,13 +30,17 @@ ifneq ($V,1) |
@@ -259,7 +261,7 @@ index 7dcd090..83ec454 100644 | |||
259 | -DEBUG = -O2 | 261 | -DEBUG = -O2 |
260 | -CC = gcc | 262 | -CC = gcc |
261 | -INCLUDE = -I$(DESTDIR)$(PREFIX)/include | 263 | -INCLUDE = -I$(DESTDIR)$(PREFIX)/include |
262 | -CFLAGS = $(DEBUG) -Wall $(INCLUDE) -Winline -pipe | 264 | -CFLAGS = $(DEBUG) -Wall -Wextra $(INCLUDE) -Winline -pipe |
263 | +INCLUDE_DIR?=$(DESTDIR)$(PREFIX)/include | 265 | +INCLUDE_DIR?=$(DESTDIR)$(PREFIX)/include |
264 | +LIB_DIR?=$(DESTDIR)$(PREFIX)/lib | 266 | +LIB_DIR?=$(DESTDIR)$(PREFIX)/lib |
265 | +BIN_DIR?=$(DESTDIR)$(PREFIX)/bin | 267 | +BIN_DIR?=$(DESTDIR)$(PREFIX)/bin |
@@ -269,10 +271,10 @@ index 7dcd090..83ec454 100644 | |||
269 | +DEBUG ?= -O2 | 271 | +DEBUG ?= -O2 |
270 | +CC ?= gcc | 272 | +CC ?= gcc |
271 | +INCLUDE ?= -I$(INCLUDE_DIR) | 273 | +INCLUDE ?= -I$(INCLUDE_DIR) |
272 | +CFLAGS ?= $(DEBUG) -Wall $(INCLUDE) -Winline -pipe | 274 | +CFLAGS ?= $(DEBUG) -Wall -Wextra $(INCLUDE) -Winline -pipe |
273 | + | 275 | + |
274 | +LDFLAGS ?= -L$(LIB_DIR) | 276 | +LDFLAGS ?= -L$(LIB_DIR) |
275 | LIBS = -lwiringPi -lwiringPiDev -lpthread | 277 | LIBS = -lwiringPi -lwiringPiDev -lpthread -lrt -lm -lcrypt |
276 | 278 | ||
277 | # May not need to alter anything below this line | 279 | # May not need to alter anything below this line |
278 | @@ -72,13 +76,10 @@ tags: $(SRC) | 280 | @@ -72,13 +76,10 @@ tags: $(SRC) |
@@ -293,7 +295,7 @@ index 7dcd090..83ec454 100644 | |||
293 | 295 | ||
294 | .PHONY: install-deb | 296 | .PHONY: install-deb |
295 | install-deb: gpio | 297 | install-deb: gpio |
296 | @@ -89,7 +90,7 @@ install-deb: gpio | 298 | @@ -91,7 +92,7 @@ install-deb: gpio |
297 | .PHONY: uninstall | 299 | .PHONY: uninstall |
298 | uninstall: | 300 | uninstall: |
299 | $Q echo "[UnInstall]" | 301 | $Q echo "[UnInstall]" |
@@ -303,7 +305,7 @@ index 7dcd090..83ec454 100644 | |||
303 | 305 | ||
304 | .PHONY: depend | 306 | .PHONY: depend |
305 | diff --git a/wiringPi/Makefile b/wiringPi/Makefile | 307 | diff --git a/wiringPi/Makefile b/wiringPi/Makefile |
306 | index 6bbcc5d..5355b74 100644 | 308 | index e1868b9..e39f75a 100644 |
307 | --- a/wiringPi/Makefile | 309 | --- a/wiringPi/Makefile |
308 | +++ b/wiringPi/Makefile | 310 | +++ b/wiringPi/Makefile |
309 | @@ -25,19 +25,23 @@ VERSION=$(shell cat ../VERSION) | 311 | @@ -25,19 +25,23 @@ VERSION=$(shell cat ../VERSION) |
@@ -334,14 +336,14 @@ index 6bbcc5d..5355b74 100644 | |||
334 | +CC ?= gcc | 336 | +CC ?= gcc |
335 | +INCLUDE ?= -I. | 337 | +INCLUDE ?= -I. |
336 | DEFS = -D_GNU_SOURCE | 338 | DEFS = -D_GNU_SOURCE |
337 | CFLAGS = $(DEBUG) $(DEFS) -Wformat=2 -Wall -Winline $(INCLUDE) -pipe -fPIC | 339 | CFLAGS = $(DEBUG) $(DEFS) -Wformat=2 -Wall -Wextra -Winline $(INCLUDE) -pipe -fPIC |
338 | 340 | ||
339 | @@ -89,17 +93,17 @@ $(STATIC): $(OBJ) | 341 | @@ -78,17 +82,17 @@ $(STATIC): $(OBJ) |
340 | 342 | ||
341 | $(DYNAMIC): $(OBJ) | 343 | $(DYNAMIC): $(OBJ) |
342 | $Q echo "[Link (Dynamic)]" | 344 | $Q echo "[Link (Dynamic)]" |
343 | - $Q $(CC) -shared -Wl,-soname,libwiringPi.so$(WIRINGPI_SONAME_SUFFIX) -o libwiringPi.so.$(VERSION) -lpthread $(OBJ) | 345 | - $Q $(CC) -shared -Wl,-soname,libwiringPi.so$(WIRINGPI_SONAME_SUFFIX) -o libwiringPi.so.$(VERSION) $(LIBS) $(OBJ) |
344 | + $Q $(CC) $(LDFLAGS) -shared -Wl,-soname,$(BASE_NAME).so.$(DYN_VERS_MAJ) -o $(BASE_NAME).so -lpthread $(OBJ) | 346 | + $Q $(CC) $(LDFLAGS) -shared -Wl,-soname,$(BASE_NAME).so.$(DYN_VERS_MAJ) -o $(BASE_NAME).so $(LIBS) $(OBJ) |
345 | 347 | ||
346 | .c.o: | 348 | .c.o: |
347 | $Q echo [Compile] $< | 349 | $Q echo [Compile] $< |
@@ -357,7 +359,7 @@ index 6bbcc5d..5355b74 100644 | |||
357 | 359 | ||
358 | .PHONY: tags | 360 | .PHONY: tags |
359 | tags: $(SRC) | 361 | tags: $(SRC) |
360 | @@ -110,22 +114,22 @@ tags: $(SRC) | 362 | @@ -99,22 +103,22 @@ tags: $(SRC) |
361 | .PHONY: install | 363 | .PHONY: install |
362 | install: $(DYNAMIC) | 364 | install: $(DYNAMIC) |
363 | $Q echo "[Install Headers]" | 365 | $Q echo "[Install Headers]" |
@@ -390,7 +392,7 @@ index 6bbcc5d..5355b74 100644 | |||
390 | 392 | ||
391 | .PHONY: install-deb | 393 | .PHONY: install-deb |
392 | install-deb: $(DYNAMIC) | 394 | install-deb: $(DYNAMIC) |
393 | @@ -140,9 +144,11 @@ install-deb: $(DYNAMIC) | 395 | @@ -129,9 +133,11 @@ install-deb: $(DYNAMIC) |
394 | .PHONY: uninstall | 396 | .PHONY: uninstall |
395 | uninstall: | 397 | uninstall: |
396 | $Q echo "[UnInstall]" | 398 | $Q echo "[UnInstall]" |
@@ -406,5 +408,5 @@ index 6bbcc5d..5355b74 100644 | |||
406 | 408 | ||
407 | .PHONY: depend | 409 | .PHONY: depend |
408 | -- | 410 | -- |
409 | 2.1.4 | 411 | 2.7.4 |
410 | 412 | ||
diff --git a/recipes-devtools/wiringPi/wiringpi/0001-include-asm-ioctl.h-directly-for-_IOC_SIZEBITS.patch b/recipes-devtools/wiringPi/wiringpi/0001-include-asm-ioctl.h-directly-for-_IOC_SIZEBITS.patch deleted file mode 100644 index 5de5853..0000000 --- a/recipes-devtools/wiringPi/wiringpi/0001-include-asm-ioctl.h-directly-for-_IOC_SIZEBITS.patch +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | From 7f65eb37a82a6d9b095d9c8f262ad9dd205acd03 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 30 Jan 2016 16:57:38 -0800 | ||
4 | Subject: [PATCH] include <asm/ioctl.h> directly for _IOC_SIZEBITS | ||
5 | |||
6 | Fixes errors like | ||
7 | | wiringPiSPI.c: In function 'wiringPiSPIDataRW': | ||
8 | | wiringPiSPI.c:89:35: error: '_IOC_SIZEBITS' undeclared (first use in | ||
9 | this function) | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | Upstream-Status: Submitted | ||
14 | |||
15 | wiringPi/wiringPi.c | 1 + | ||
16 | wiringPi/wiringPiI2C.c | 1 + | ||
17 | wiringPi/wiringPiSPI.c | 1 + | ||
18 | 3 files changed, 3 insertions(+) | ||
19 | |||
20 | diff --git a/wiringPi/wiringPi.c b/wiringPi/wiringPi.c | ||
21 | index 32e5100..cb5db9d 100644 | ||
22 | --- a/wiringPi/wiringPi.c | ||
23 | +++ b/wiringPi/wiringPi.c | ||
24 | @@ -64,6 +64,7 @@ | ||
25 | #include <time.h> | ||
26 | #include <fcntl.h> | ||
27 | #include <pthread.h> | ||
28 | +#include <asm/ioctl.h> | ||
29 | #include <sys/time.h> | ||
30 | #include <sys/mman.h> | ||
31 | #include <sys/stat.h> | ||
32 | diff --git a/wiringPi/wiringPiI2C.c b/wiringPi/wiringPiI2C.c | ||
33 | index c787bce..efdf53c 100644 | ||
34 | --- a/wiringPi/wiringPiI2C.c | ||
35 | +++ b/wiringPi/wiringPiI2C.c | ||
36 | @@ -52,6 +52,7 @@ | ||
37 | #include <string.h> | ||
38 | #include <fcntl.h> | ||
39 | #include <sys/ioctl.h> | ||
40 | +#include <asm/ioctl.h> | ||
41 | |||
42 | #include "wiringPi.h" | ||
43 | #include "wiringPiI2C.h" | ||
44 | diff --git a/wiringPi/wiringPiSPI.c b/wiringPi/wiringPiSPI.c | ||
45 | index 453df31..ae3c7d9 100644 | ||
46 | --- a/wiringPi/wiringPiSPI.c | ||
47 | +++ b/wiringPi/wiringPiSPI.c | ||
48 | @@ -27,6 +27,7 @@ | ||
49 | #include <fcntl.h> | ||
50 | #include <errno.h> | ||
51 | #include <string.h> | ||
52 | +#include <asm/ioctl.h> | ||
53 | #include <sys/ioctl.h> | ||
54 | #include <linux/spi/spidev.h> | ||
55 | |||
56 | -- | ||
57 | 2.7.0 | ||
58 | |||
diff --git a/recipes-devtools/wiringPi/wiringpi_git.bb b/recipes-devtools/wiringPi/wiringpi_git.bb index c337b19..7953a55 100644 --- a/recipes-devtools/wiringPi/wiringpi_git.bb +++ b/recipes-devtools/wiringPi/wiringpi_git.bb | |||
@@ -4,14 +4,13 @@ SECTION = "devel/libs" | |||
4 | LICENSE = "LGPLv3+" | 4 | LICENSE = "LGPLv3+" |
5 | LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02" | 5 | LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02" |
6 | 6 | ||
7 | # tag 2.32 | 7 | # tag 2.44 |
8 | SRCREV = "b0a60c3302973ca1878d149d61f2f612c8f27fac" | 8 | SRCREV = "96344ff7125182989f98d3be8d111952a8f74e15" |
9 | 9 | ||
10 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
11 | 11 | ||
12 | SRC_URI = "git://git.drogon.net/wiringPi \ | 12 | SRC_URI = "git://git.drogon.net/wiringPi \ |
13 | file://0001-Add-initial-cross-compile-support.patch \ | 13 | file://0001-Add-initial-cross-compile-support.patch \ |
14 | file://0001-include-asm-ioctl.h-directly-for-_IOC_SIZEBITS.patch \ | ||
15 | " | 14 | " |
16 | 15 | ||
17 | COMPATIBLE_MACHINE = "raspberrypi" | 16 | COMPATIBLE_MACHINE = "raspberrypi" |