summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-06-08 00:17:59 +0200
committerAndrei Gherzan <andrei@gherzan.com>2021-06-08 14:05:13 +0100
commit7057d5dcbfa5802a370aa1730e14e940b9bf7b24 (patch)
treeb561d404934aab0c7c682d6c98bd5c4c792b3f18
parent66d20862de9c3969f889d94cb8d6cd65d39b8ada (diff)
downloadmeta-raspberrypi-7057d5dcbfa5802a370aa1730e14e940b9bf7b24.tar.gz
pi-bluetooth: upgrade 0.1.12 -> 0.1.17
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch33
-rw-r--r--recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb (renamed from recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb)2
2 files changed, 24 insertions, 11 deletions
diff --git a/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch b/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch
index 45b43c7..079377e 100644
--- a/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch
+++ b/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch
@@ -8,20 +8,33 @@ Signed-off-by: Peter A. Bigot <pab@pabigot.com>
8Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> 8Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
9 9
10--- 10---
11 usr/bin/bthelper | 4 ++-- 11 usr/bin/bthelper | 6 +++---
12 1 file changed, 2 insertions(+), 2 deletions(-) 12 1 file changed, 3 insertions(+), 3 deletions(-)
13 13
14diff --git a/usr/bin/bthelper b/usr/bin/bthelper 14diff --git a/usr/bin/bthelper b/usr/bin/bthelper
15index af597e5..5de84f6 100755 15index 2133fbc..1fc9245 100755
16--- a/usr/bin/bthelper 16--- a/usr/bin/bthelper
17+++ b/usr/bin/bthelper 17+++ b/usr/bin/bthelper
18@@ -10,7 +10,7 @@ fi 18@@ -12,8 +12,8 @@ fi
19 dev=$1
19 20
20 dev="$1"
21 # Need to bring hci up before looking at MAC as it can be all zeros during init 21 # Need to bring hci up before looking at MAC as it can be all zeros during init
22-/bin/hciconfig "$dev" up 22-/bin/hciconfig $dev up
23-/bin/hciconfig "$dev" | grep -qE "BD Address: (B8:27:EB|DC:A6:32):" || exit 0 23-if ! /bin/hciconfig $dev | grep -q "Bus: UART"; then
24+/usr/bin/hciconfig "$dev" up 24+/usr/bin/hciconfig $dev up
25+/usr/bin/hciconfig "$dev" | grep -qE "BD Address: (B8:27:EB|DC:A6:32):" || exit 0 25+if ! /usr/bin/hciconfig $dev | grep -q "Bus: UART"; then
26 /usr/bin/hcitool -i "$dev" cmd 0x3f 0x1c 0x01 0x02 0x00 0x01 0x01 > /dev/null 26 echo Not a UART-attached BT Modem
27 exit 0
28 fi
29@@ -26,7 +26,7 @@ if ( /usr/bin/hcitool -i $dev dev | grep -q -E '\s43:4[35]:' ); then
30 BDADDR=`printf '0x%02x 0x%02x 0x%02x 0xeb 0x27 0xb8' $((0x$B3 ^ 0xaa)) $((0x$B2 ^ 0xaa)) $((0x$B1 ^ 0xaa))`
27 31
32 /usr/bin/hcitool -i $dev cmd 0x3f 0x001 $BDADDR
33- /bin/hciconfig $dev reset
34+ /usr/bin/hciconfig $dev reset
35 else
36 echo Raspberry Pi BDADDR already set
37 fi
38--
392.31.1
40
diff --git a/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb b/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
index ccf714b..a1eb97f 100644
--- a/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb
+++ b/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
@@ -10,7 +10,7 @@ SRC_URI = "\
10 git://github.com/RPi-Distro/pi-bluetooth \ 10 git://github.com/RPi-Distro/pi-bluetooth \
11 file://0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch \ 11 file://0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch \
12" 12"
13SRCREV = "cbdbcb66bcc5b9af05f1a9fffe2254c872bb0ace" 13SRCREV = "fd4775bf90e037551532fc214a958074830bb80d"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16