diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-11-17 00:58:14 -0800 |
---|---|---|
committer | Andrei Gherzan <andrei@gherzan.ro> | 2018-11-19 18:21:43 +0200 |
commit | e1ba4484c0135e12fbbd4b7bab00d9a15d5137f2 (patch) | |
tree | 74a88dcdf6ee050d94a85b0a96ea3df7fd936ad8 | |
parent | c8b696248701ba4183c98d3e7b286d21d22eaa4c (diff) | |
download | meta-raspberrypi-e1ba4484c0135e12fbbd4b7bab00d9a15d5137f2.tar.gz |
qtbase: Tackle the case when eglfs is to be used
This provides out of box configuration for QT/eglfs use
when x11/wayland arent used but plain EGLFS is in play
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend new file mode 100644 index 0000000..e77e4cc --- /dev/null +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -0,0 +1,17 @@ | |||
1 | PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'gl', \ | ||
2 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'eglfs gles2 linuxfb', \ | ||
3 | '', d), d)}" | ||
4 | #PACKAGECONFIG_GL_rpi = "${@bb.utils.any_distro_features('x11 wayland', '', 'eglfs', d)}" | ||
5 | PACKAGECONFIG_FONTS_rpi = "fontconfig" | ||
6 | PACKAGECONFIG_append_rpi = " libinput examples tslib xkb xkbcommon-evdev" | ||
7 | PACKAGECONFIG_remove_rpi = "tests" | ||
8 | |||
9 | OE_QTBASE_EGLFS_DEVICE_INTEGRATION_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'eglfs_kms', 'eglfs_brcm', d)}" | ||
10 | |||
11 | do_configure_prepend_rpi() { | ||
12 | # Add the appropriate EGLFS_DEVICE_INTEGRATION | ||
13 | if [ "${@d.getVar('OE_QTBASE_EGLFS_DEVICE_INTEGRATION')}" != "" ]; then | ||
14 | echo "EGLFS_DEVICE_INTEGRATION = ${OE_QTBASE_EGLFS_DEVICE_INTEGRATION}" > ${S}/mkspecs/oe-device-extra.pri | ||
15 | echo "QT_QPA_DEFAULT_PLATFORM = eglfs" >> ${S}/mkspecs/oe-device-extra.pri | ||
16 | fi | ||
17 | } | ||