summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer
Commit message (Collapse)AuthorAgeFilesLines
* gstreamer-vaapi: fix tarball checksums1.6_M1.rc11.6_M1.final1.6_M1Ross Burton2013-11-201-2/+2
| | | | | Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi: add 0.5.6Ross Burton2013-11-145-0/+101
| | | | | | | | | | | gstreamer-vaapi 0.5.x supports GStreamer 0.10/1.0/1.2, so add seperate recipes for 0.10 and 1.0 builds. This adds a new recipe name so keep the old gstreamer-vaapi_0.4.3 for now until all users of that have migrated away. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi: upgrade to 0.4.3Ross Burton2013-11-043-86/+24
| | | | | | | | | | | | Use tarballs instead of git tags (upstream git means using submodules, which are tricky). Also use PACKAGECONFIG to respect x11/wayland DISTRO_FEATURES. Delete glib-includes.patch, as it wasn't being used. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gst-va-intel: avoid warning regarding ALLOW_EMPTYNitin A Kamble2013-03-071-1/+5
| | | | | | | | | | | | | | | Due to recent changes in the oecore layer, non package specific ALLOW_EMPTY declarations now cause warnings as seen below. WARNING: QA Issue: /media/build1/poky/meta-intel/common/ recipes-multimedia/gstreamer/gst-va-intel.bb: Variable ALLOW_EMPTY is set as not being package specific, please fix this. Avoid this warning by making ALLOW_EMPTY declarations package specific. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi_git: fix a build issueNitin A Kamble2013-01-151-3/+3
| | | | | | | | | | | | | | | | | | | | This commit fixes this issue: | In file included from gstvaapidisplay_glx.c:31:0: | gstvaapiutils_glx.h:148:5: error: unknown type name 'PFNGLMULTITEXCOORD2FPROC' | make[4]: *** [libgstvaapi_glx_0.10_la-gstvaapidisplay_glx.lo] Error 1 | ERROR: Function failed: do_compile (see /srv/home/nitin/build-test-bsps/build-sugarbay/tmp/work/x86_64-poky-linux/gstreamer-vaapi/0.3.8+gitAUTOINC+6ec4c2252a4aa706cd8631cb1083828485b9df9a-r0/temp/log.do_compile.73657 Found a solution to the issue here: https://bugs.freedesktop.org/show_bug.cgi?id=56516 Fixed the issue as per the comments on the above bug. Fixes this bug: [YOCTO #3722] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi: add missing build dependenciesRoss Burton2012-10-231-1/+1
| | | | | | | [YOCTO #3321] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi: upgrade to 0.3.8, and remove ffmpeg dependenciesRoss Burton2012-10-191-6/+15
| | | | | Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gst-va-intel: incude gst-ffmpeg only if 'commercial' is whitelisted1.3_M5.rc3Tom Zanussi2012-10-031-2/+3
| | | | | | | | | | | | | World and universe builds break if the newly commercial gst-ffmpeg is included without a 'commercial' entry in LICENSE_FLAGS_WHITELIST, so only add gst-ffmpeg if that's the case. Normally BSPs conditionally include gst-va-intel and thus gst-ffmpeg is included in the build only if 'commercial' is added to LICENSE_FLAGS_WHITELIST and therefore this isn't an issue, but world and universe builds are different. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: add va-impl-intel MACHINE_FEATURETom Zanussi2012-08-301-3/+13
| | | | | | | | | | | | Add a new va-impl-intel MACHINE_FEATURE to explicitly choose intel video acceleration, rather than have it as the fallthrough default, so that anything that wants to specify something different locally doesn't get unwanted components. Also rename the gst-va-mixvideo feature to va-impl-mixvideo match and since it isn't only concerned with gst. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi: fix glib includesTom Zanussi2012-05-302-1/+52
| | | | | | | | | | | Fix "Only <glib.h> can be included directly" compilation errors seen when building with 1.3/master. Patch pulled from a post-0.2.9 gstreamer-vaapi version (which however doesn't work with the current stack so a straight upgrade won't work as a fix at this point). Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gst-va-intel: clarify DESCRIPTIONTom Zanussi2012-05-301-1/+1
| | | | | | Modify the description to clarify that these are gstreamer addons. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gst-va-intel: add conditional vaapi implementationTom Zanussi2012-05-301-0/+13
| | | | | | | | | | | | Use different versions of vaapi interface implementaion depending on what a machine specifies. The default if no MACHINE_FEATURE is specified is gstreamer-vaapi. Other machines may need a different implementation e.g. a machine using emgd would specify 'gst-va-mixvideo' in its MACHINE_FEATURES in order to have the implementation satisfied by emgd instead of gstreamer-vaapi, which this also implements. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: add gstreamer-vaapi_git recipeTom Zanussi2012-05-301-0/+26
| | | | | | | | | | | | | | | | | | | | | | | | | | | Based on the gstreamer-vaapi_0.2.5.bb recipe from the Yocto Project meta-demo layer (git://git.yoctoproject.org/meta-demo): commit a33dd433b629f08bc6517ef2ad3bdd36814ebe85 Author: Joshua Lock <josh@linux.intel.com> Date: Tue Mar 22 12:11:42 2011 +0000 gstreamer-vaapi: new recipe currently untested but will likely be useful in future so commiting it so that it doesn't get lost Signed-off-by: Joshua Lock <josh@linux.intel.com> Additional changes made by Tom Zanussi <tom.zanussi@intel.com> in order to work with the other multimedia recipes in meta-intel/common: - summary and description - correct license - changed into a _git recipe in order to pick up post-0.2.5 versions - additional inherits - tested Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: new package - gst-va-intelTom Zanussi2011-12-051-0/+28
| | | | | | | We need some extra plugins for EMGD video acceleration use and testing, so create a new 'gst-va-intel' package group for them. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* Revert "meta-intel: add gst-meta-base .bbappend"Tom Zanussi2011-12-021-9/+0
| | | | | | | | | This reverts commit acf138682a45725caa48574b170fbc29817bf941. This breaks non-compatible builds, and should probably be done per-BSP anyway. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: add gst-meta-base .bbappendTom Zanussi2011-12-021-0/+9
We need some extra plugins for EMGD video acceleration use and testing, so append them to gst-meta-base. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>