summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* meta-romley: change preferred kernel to 3.41.4_M4.rc11.4_M4.final1.4_M4Kishore Bodke2013-02-181-1/+1
| | | | | | | Set the romley preferred kernel version to 3.4. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* meta-romley: add support for the linux-yocto_3.4 kernelKishore Bodke2013-02-181-0/+13
| | | | | | | Add linux-yocto_3.4 kernel support for the romley machine. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* meta-intel: remove cedartrail maintainer from the MAINTAINERS listKishore Bodke2013-02-161-4/+0
| | | | | | | | Update the MAINTAINERS list after removing the cedartrail BSP from meta-intel. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* cedartrail: remove BSPKishore Bodke2013-02-1620-656/+0
| | | | | | | | | Cedartrail will not be supported in the Yocto 1.4 Release. Remove it from meta-intel. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* emgd-driver-bin: Fix RDEPENDSRichard Purdie2013-02-122-2/+2
| | | | | | | | | RDEPENDS should be set on specific packages, not applied to everything in general (e.g. -dev, -dbg or -doc packages). This fixes up warnings in the build. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* mesa-dri: Update bbappend to version 9.0.2Darren Hart2013-02-121-0/+0
| | | | | | Adjust bbappend to match changes in OE-Core. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* meta-intel: remove kernel AUTOREVsTom Zanussi2013-02-0422-69/+111
| | | | | | | | Using AUTOREV turns out to cause problems with unreproducible autobuilder builds and unwanted network access. This patch removes kernel AUTOREVs and locks down SRCREVs and LINUX_VERSIONs. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* fri2: use EMGD version 1.16 instead of 1.14Nitin A Kamble2013-02-012-2/+2
| | | | | | | | | | | | | | The recently added 1.16 version of the EMGD graphics stack also works for the FRI2 BSP. Update the BSP to use the newer EMGD version for graphics. This partly addresses: [YOCTO #3809] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emenlow README: add information about the gma500 driverNitin A Kamble2013-02-011-1/+3
| | | | | | | | | Mention the use of the graphics stack based on the kernel 'gma500' driver as well as the 'modesetting' X driver for the emenlow-noemgd machine configuration. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* fri2.conf: fix boot time kernel errorsNitin A Kamble2013-02-011-0/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The following was seen when booting the fri2: BUG: Bad page state in process loop0 pfn:3803 page:f6991700 count:0 mapcount:0 mapping: (null) index:0x0 page flags: 0x80400000(uncached) Modules linked in: emgd drm_kms_helper ip_tables x_tables arc4 minix cdc_acm iwlwifi led_class mac80211 cfg80211 firmware_class Pid: 448, comm: loop0 Not tainted 3.4.26-yocto-standard #1 Call Trace: [<c10cdb0f>] bad_page+0x8f/0xe0 [<c10ce0e5>] get_page_from_freelist+0x435/0x4e0 [<c10ce2c5>] __alloc_pages_nodemask+0x135/0x690 [<c10d1964>] __do_page_cache_readahead+0xe4/0x210 [<c1055a6b>] ? get_parent_ip+0xb/0x40 [<c1055a6b>] ? get_parent_ip+0xb/0x40 [<c10d1cf7>] ra_submit+0x27/0x30 [<c10d1e37>] ondemand_readahead+0x137/0x230 [<c166b061>] ? __wait_on_bit_lock+0x61/0xa0 [<c10d1fae>] page_cache_async_readahead+0x7e/0xa0 [<c112b590>] __generic_file_splice_read+0x360/0x5a0 [<c1129e90>] ? page_cache_pipe_buf_release+0x20/0x20 [<c105c56c>] ? enqueue_task_fair+0x1ac/0x620 [<c105b584>] ? check_preempt_wakeup+0x144/0x220 [<c1054b32>] ? check_preempt_curr+0x72/0x90 [<c1051f5d>] ? ttwu_stat+0x2d/0x100 [<c1055a6b>] ? get_parent_ip+0xb/0x40 [<c1055a6b>] ? get_parent_ip+0xb/0x40 [<c1670763>] ? sub_preempt_count+0x43/0xb0 [<c102573e>] ? __kunmap_atomic+0x3e/0x90 [<c13b22c0>] ? loop_make_request+0xf0/0xf0 [<c13b19b9>] ? lo_splice_actor+0x89/0xc0 [<c12c01e4>] ? security_file_permission+0x94/0xb0 [<c112b83c>] generic_file_splice_read+0x6c/0xe0 [<c112b7d0>] ? __generic_file_splice_read+0x5a0/0x5a0 [<c112a201>] vfs_splice_to+0x61/0x80 [<c112a2ca>] splice_direct_to_actor+0xaa/0x1d0 [<c13b21b0>] ? loop_thread+0x510/0x510 [<c13b1f43>] loop_thread+0x2a3/0x510 [<c13b1ca0>] ? do_lo_send_write+0xe0/0xe0 [<c1047103>] kthread+0x73/0x80 [<c1047090>] ? kthread_freezable_should_stop+0x50/0x50 [<c1673df6>] kernel_thread_helper+0x6/0x10 The fri2 has 1Gb of ram, hence the kernel sets 128Mb for the allocation of vmalloc memory. The EMGD driver needs at least 256Mb of vmalloc memory to work correctly, according to the EMGD documentation This change passes the vmalloc allocation size to the kernel via the vmalloc=256MB boot parameter. Adjusting the kernel's vmalloc allocation size fixes the kernel errors. This fixes bug: [Yocto #3810] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* nuc.conf: use the new method for specifying VA codecsNitin A Kamble2013-02-011-4/+3
| | | | | | | | | | | | | This replaces the old VA_FEATURES method for specifying codecs. These VA codecs are included in the image when the image has 'hwcodec' in the IMAGE_FEATURES variable. One can disable the VA features by redefining the IMAGE_FEATURES variable in local.conf. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* chiefriver.conf: use the new method for specifying VA codecsNitin A Kamble2013-02-011-3/+3
| | | | | | | | | | | | | This replaces the old VA_FEATURES method for specifying codecs. These VA codecs are included in the image when the image has 'hwcodec' in the IMAGE_FEATURES variable. One can disable the VA features by redefining the IMAGE_FEATURES variable in local.conf. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* sugarbay.conf: use the new method for specifying VA codecsNitin A Kamble2013-02-011-4/+2
| | | | | | | | | | | | | This replaces the old VA_FEATURES method for specifying codecs. These VA codecs are included in the image when the image has 'hwcodec' in the IMAGE_FEATURES variable. One can disable the VA features by redefining the IMAGE_FEATURES variable in local.conf. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* sys940x.conf: use the new method for specifying VA codecs1.4_M3.rc21.4_M3.final1.4_M3Nitin A Kamble2013-01-251-8/+4
| | | | | | | | | | | | | | | | | This replaces the old VA_FEATURES method to specify the codecs. These VA codecs are included in the image when image has 'hwcodec' in the IMAGE_FEATURES. And one can disable the VA features by redefining the IMAGE_FEATURES var in the local.conf . The gst-va-intel package pulls in emgd driver and x11 pieces, hence it is moved to the XSERVERCODECS var. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* fri2.conf: use the new method for specifying VA codecsNitin A Kamble2013-01-251-6/+4
| | | | | | | | | | | | | | | | | This replaces the old VA_FEATURES method to specify the codecs. These VA codecs are included in the image when image has 'hwcodec' in the IMAGE_FEATURES. And one can disable the VA features by redefining the IMAGE_FEATURES var in the local.conf . The gst-va-intel package pulls in emgd driver and x11 pieces, hence it is moved to the XSERVERCODECS var. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay.conf: use the new method for specifying VA codecsNitin A Kamble2013-01-251-8/+4
| | | | | | | | | | | | | | | | | This replaces the old VA_FEATURES method to specify the codecs. These VA codecs are included in the image when image has 'hwcodec' in the IMAGE_FEATURES. And one can disable the VA features by redefining the IMAGE_FEATURES var in the local.conf . The gst-va-intel package pulls in emgd driver and x11 pieces, hence it is moved to the XSERVERCODECS var. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emenlow.conf: use the new method for specifying VA codecsNitin A Kamble2013-01-251-8/+4
| | | | | | | | | | | | | | | | | This replaces the old VA_FEATURES method to specify the codecs. These VA codecs are included in the image when image has 'hwcodec' in the IMAGE_FEATURES. And one can disable the VA features by redefining the IMAGE_FEATURES var in the local.conf . The gst-va-intel package pulls in emgd driver and x11 pieces, hence it is moved to the XSERVERCODECS var. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emenlow: add LICENSE_FLAG_WHITELIST information to READMETom Zanussi2013-01-251-4/+27
| | | | | | | | The switchover to emgd neglected to add the user documentation needed for whitelisting the video components. This adds it and now matches the other emgd-based BSPs. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* meta-intel: update MAINTAINERS with new mailing listTom Zanussi2013-01-251-13/+10
| | | | | | | Submissions and questions about meta-intel BSPs should now go to the new meta-intel mailing list. Update MAINTAINERS with the new list. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* fri2.conf: mesa-dri was updated to 9.0.1Andrei Gherzan2013-01-241-1/+1
| | | | | Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* ffmpeg: Remove package as nobody depends on it anymoreAndrei Gherzan2013-01-242-154/+0
| | | | | Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: use emgd 1.16 driver for graphicsNitin A Kamble2013-01-233-8/+8
| | | | | | | | | Move from 1.14 version to 1.16 version of the emgd driver for graphics support. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emenlow: use emgd 1.16 driver for graphicsNitin A Kamble2013-01-233-6/+6
| | | | | | | | | Move from 1.14 version to 1.16 version of the emgd driver for graphics support. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-1.16: create a new recipeNitin A Kamble2013-01-233-0/+767
| | | | | | | | | | | | | | | Create a new recipe for the latest emgd 1.16 version of the graphics driver. Also add the custom license files of the recipe to avoid build time QA warnings. There are strange characters in the license files, because they are copied verbatim from the sources. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-1.14: prepare for coexisting with emgd-1.16 recipeNitin A Kamble2013-01-235-19/+21
| | | | | | | | | | | | | | | | | | | | We want to use emgd-1.14 & emgd-1.16 recipe interchangeably. As the some of the generated package names include versions which will be different in the emgd-1.16 recipe, this version part is stripped from the package names so that it will match with the emgd-1.16 recipe package names. All the BSP configuration which were using these package names also change accordingly to avoid any build issues. Also with the 2 versions of emgd recipes make sure that BSPs don't start using the emgd-1.16 version until they have been validated to work by specifying the preferred emgd recipe version for the relevant BSPs. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* fri2: fix a typo in specifying the kernel featureNitin A Kamble2013-01-221-1/+1
| | | | | | | | | There was a typo in specifying cfg/vesafb kernel feature. This commit fixes it. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* sys940x: linux-yocto_3.4: cleanup the SRC_URINitin A Kamble2013-01-221-1/+1
| | | | | | | | | | | | | | | As the commit to change kernel recipe SRC_URI to base on the KSRC_linux_yocto_3_4_repo var did not go in the poky layer, it leaves the SRC-URI definition incomplete here. Fix the SRC_URI by specifying the git repository location explicitly. This fixes bug: [YOCTO #3775] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: clean up the linux-yocto-3.4 recipeNitin A Kamble2013-01-221-1/+0
| | | | | | | clean up unused variable. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* BSP layer READMEs: fix the YP Compliance linkNitin A Kamble2013-01-1912-12/+12
| | | | | | | | | | | The link has changed on the yoctoproject website, updating the URL in the BSP layer READMEs. This fixes the bug: [Yocto #3730] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emenlow-noemgd: create a new BSPNitin A Kamble2013-01-194-0/+57
| | | | | | | | | | This is based on the gma500/gma600 kernel driver and the modesetting X driver for poulsbo graphics. The gma500 driver needs soft cursor in X. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* sys940x: create a v3.4 kernel recipeNitin A Kamble2013-01-191-0/+22
| | | | | | | | | | | The sys940x & sys940x-noemgd BSPs are still using v3.2 linux-yocto kernel. This commit provides a v3.4 kernel recipe for these BSPs. This addresses the bug/feature request: [YOCTO #2268] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* fri2: specify graphics driver as a kernel featureNitin A Kamble2013-01-191-0/+2
| | | | | | | | | | | | | | | | This change avoids addition of emgd source code in the noemgd bsp kernels. This configures the fri2 BSP kernel with EMGD graphics driver and fri2-noemgd BSP kernel with VESA graphics driver. The VESA FB support is kept for both BSPs for boot time splash screen support. This addresses the bug/feature request: [YOCTO #2268] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emenlow: specify graphics driver as a kernel featureNitin A Kamble2013-01-191-0/+1
| | | | | | | | | | | | | | This change avoids addition of emgd source code in the noemgd bsp kernels. This configures the emenlow BSP kernel with EMGD graphics driver. The VESA FB support is kept for boot time splash screen support. This addresses the bug/feature request: [YOCTO #2268] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: specify graphics driver as a kernel featureNitin A Kamble2013-01-191-0/+2
| | | | | | | | | | | | | | | | This change avoids addition of emgd source code in the noemgd bsp kernels. This configures the crownbay BSP kernel with EMGD graphics driver and crownbay-noemgd BSP kernel with just the VESA graphics driver. The VESA FB support is kept for both BSPs for boot time splash screen support. This addresses the bug/feature request: [YOCTO #2268] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi_git: fix a build issueNitin A Kamble2013-01-151-3/+3
| | | | | | | | | | | | | | | | | | | | This commit fixes this issue: | In file included from gstvaapidisplay_glx.c:31:0: | gstvaapiutils_glx.h:148:5: error: unknown type name 'PFNGLMULTITEXCOORD2FPROC' | make[4]: *** [libgstvaapi_glx_0.10_la-gstvaapidisplay_glx.lo] Error 1 | ERROR: Function failed: do_compile (see /srv/home/nitin/build-test-bsps/build-sugarbay/tmp/work/x86_64-poky-linux/gstreamer-vaapi/0.3.8+gitAUTOINC+6ec4c2252a4aa706cd8631cb1083828485b9df9a-r0/temp/log.do_compile.73657 Found a solution to the issue here: https://bugs.freedesktop.org/show_bug.cgi?id=56516 Fixed the issue as per the comments on the above bug. Fixes this bug: [YOCTO #3722] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* mesa-dri: Fix file extension for bbappendRichard Purdie2013-01-111-0/+0
| | | | | | The file extension should be bbappend, sorry about that. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* mesa-dri: Update bbappend to version 9.0.1Richard Purdie2013-01-111-0/+0
| | | | | | Adjust bbappend to match changes in OE-Core. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* layer.conf: Use .= for adding to BBPATH and += to BBFILESKhem Raj2013-01-0714-28/+28
| | | | | | | | | | | | | | | | | | | | Fixes parsing errors which is appearing after this commit to meta-openembedded http://cgit.openembedded.org/meta-openembedded/commit/?id=3c21a46020bd0816579648f684c41dbd6333583e This triggers exception NameError: name 'base_contains' is not defined without this change Avoid the immediate expansion operator (:=) which caused base_contains added in the previous commit to fail to expand at the time the meta-intel layer configs are parsed and replace it with one of the append operators (.= or +=) that allows for delayed variable expansion. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* libva-intel-driver: workaround for concurrent VC1 and H264 playback issueTom Zanussi2012-12-212-0/+442
| | | | | | | | | | | Explanation from Terence Chiang: "encountered a GFX issue while enabling HW video playback VC-1 and H.264 simultaneously, the graphic driver report error with gfx hang on Sandy Bridge platform. We worked with Intel Linux graphic team and provided a patch" Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* sys940x.conf: add EMGD VA components to VA_FEATURES variableNitin A Kamble2012-12-211-1/+5
| | | | | | | | | | | | | | | | | | | The following EMGD subpackages provide video acceleration and have dependencies on libva and libx11: emgd-driver-video emgd-gst-plugins-va-0.10.10 emgd-gst-plugins-mixvideo-0.10.34 Include these in the VA_FEATURES variable only when the EMGD XSERVER is included in the image. For images such as core-image-lsb which do not include X components, including any of these emgd subpackages will pull in unwanted X components. This fixes that problem. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* fri2.conf: add EMGD VA components to VA_FEATURES variableNitin A Kamble2012-12-211-1/+5
| | | | | | | | | | | | | | | | | | | The following EMGD subpackages provide video acceleration and have dependencies on libva and libx11: emgd-driver-video emgd-gst-plugins-va-0.10.10 emgd-gst-plugins-mixvideo-0.10.34 Include these in the VA_FEATURES variable only when the EMGD XSERVER is included in the image. For images such as core-image-lsb which do not include X components, including any of these emgd subpackages will pull in unwanted X components. This fixes that problem. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emenlow.conf: add EMGD VA components to VA_FEATURES variableNitin A Kamble2012-12-211-2/+5
| | | | | | | | | | | | | | | | | | | The following EMGD subpackages provide video acceleration and have dependencies on libva and libx11: emgd-driver-video emgd-gst-plugins-va-0.10.10 emgd-gst-plugins-mixvideo-0.10.34 Include these in the VA_FEATURES variable only when the EMGD XSERVER is included in the image. For images such as core-image-lsb which do not include X components, including any of these emgd subpackages will pull in unwanted X components. This fixes that problem. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay.conf: add EMGD VA components to VA_FEATURES variableNitin A Kamble2012-12-211-1/+5
| | | | | | | | | | | | | | | | | | | | | | The following EMGD subpackages provide video acceleration and have dependencies on libva and libx11: emgd-driver-video emgd-gst-plugins-va-0.10.10 emgd-gst-plugins-mixvideo-0.10.34 Include these in the VA_FEATURES variable only when the EMGD XSERVER is included in the image. For images such as core-image-lsb which do not include X components, including any of these emgd subpackages will pull in unwanted X components. This fixes that problem. This fixes the following bug: [YOCTO #3507] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-driver-bin: split target files into subpackagesNitin A Kamble2012-12-211-3/+23
| | | | | | | | | | | | | | | | | Currently all the EMGD binary files are packaged mainly into the emgd-driver-bin package. This brings in undesired dependencies on various external packages such as libva and libx11. Splitting them further into subpackages passes these dependencies on to only those subpackages, and these subpackages can be selected individually as needed. This fixes the following bugs: [YOCTO #2551] [YOCTO #3373] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-nuc: include wifi chip microcode package in nuc.confNitin A Kamble2012-12-141-1/+2
| | | | | | | | Add the microcode package needed to enable the Centrino Advanced-N 6235 card to nuc.conf. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* common/linux-firmware: add support for Centrino Advanced-N 6235 wirelessNitin A Kamble2012-12-141-5/+10
| | | | | | | | | Add and package microcode needed for Centrino Advanced-N 6235 wireless card, and split the packaging of the licence file so that it can be bundled with any of the Intel iwlfifi microcode packages. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-nuc: init script for configuring HDMI audioNitin A Kamble2012-12-142-0/+38
| | | | | | | | Provide an init script to check at boot time which HDMI port is connected and configure the default ALSA audio out to that port. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-nuc: disable serial port configNitin A Kamble2012-12-141-0/+3
| | | | | | | | | | There is no serial port on the NUC, so remove the serial port configuration to avoid these kind of errors in the /var/log/messages: Dec 12 19:06:06 nuc auth.err getty: ttyS0: ioctl: Input/output error Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-nuc: provide a working alsa config for the nuc BSPNitin A Kamble2012-12-142-0/+25
| | | | | | | | | The nuc supports audio only via the HDMI ports. This provides an alsa sound configuration where HDMI0 port is set as a default sound out device. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-nuc: provide a working xorg.conf for the nuc BSPNitin A Kamble2012-12-142-0/+27
| | | | | | | Provide a working xorg.conf for the nuc BSP. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>