diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2018-11-15 05:53:11 (GMT) |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2018-11-28 03:29:39 (GMT) |
commit | 901a714e52e47d60c78044423243d33abd692ad1 (patch) | |
tree | 14a351d38a087e315bf6701842ac9630a9775787 /recipes-multimedia | |
parent | b90dc177252a8d63ae47567f49452486b49bdca5 (diff) | |
download | meta-intel-901a714e52e47d60c78044423243d33abd692ad1.tar.gz |
intel-mediasdk: add recipe
Intel(R) Media SDK provides an API to access hardware-accelerated
video decode, encode and filtering on IntelĀ® platforms with integrated
graphics.
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/mediasdk/intel-mediasdk_18.3.1.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-multimedia/mediasdk/intel-mediasdk_18.3.1.bb b/recipes-multimedia/mediasdk/intel-mediasdk_18.3.1.bb new file mode 100644 index 0000000..fe57b64 --- /dev/null +++ b/recipes-multimedia/mediasdk/intel-mediasdk_18.3.1.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "Intel(R) Media SDK for hardware accelerated media processing" | ||
2 | DESCRIPTION = "Intel(R) Media SDK provides an API to access hardware-accelerated \ | ||
3 | video decode, encode and filtering on IntelĀ® platforms with integrated graphics." | ||
4 | |||
5 | HOMEPAGE = "https://github.com/Intel-Media-SDK/MediaSDK" | ||
6 | BUGTRACKER = "https://github.com/Intel-Media-SDK/MediaSDK/issues" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3cb331af679cd8f968bf799a9c55b46e" | ||
10 | |||
11 | # Only for 64 bit until media-driver issues aren't fixed | ||
12 | COMPATIBLE_HOST = '(x86_64).*-linux' | ||
13 | |||
14 | DEPENDS += "libdrm libva intel-media-driver" | ||
15 | |||
16 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "dri3", "", d)} \ | ||
17 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "wayland", "", d)}" | ||
18 | |||
19 | PACKAGECONFIG[dri3] = "-DENABLE_X11_DRI3=ON, -DENABLE_X11_DRI3=OFF" | ||
20 | PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND=ON, -DENABLE_WAYLAND=OFF, wayland wayland-native" | ||
21 | |||
22 | SRC_URI = " \ | ||
23 | git://github.com/Intel-Media-SDK/MediaSDK.git;protocol=https;branch=${BPN}-18.3 \ | ||
24 | " | ||
25 | |||
26 | SRCREV = "2e946771649c47525fcbbea057e2a2c1072e173e" | ||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | inherit cmake pkgconfig | ||
30 | |||
31 | EXTRA_OECMAKE += "-DMFX_INCLUDE=${S}/api/include -DBUILD_SAMPLES=OFF" | ||
32 | |||
33 | FILES_${PN} += " \ | ||
34 | ${libdir}/mfx \ | ||
35 | ${datadir}/mfx/plugins.cfg \ | ||
36 | " | ||