diff options
author | Darren Hart <dvhart@linux.intel.com> | 2011-03-15 23:30:07 (GMT) |
---|---|---|
committer | Darren Hart <dvhart@linux.intel.com> | 2011-03-16 04:29:47 (GMT) |
commit | 14f57b958ba34ad3c5e82188ff3f457f7737b9b5 (patch) | |
tree | d26a932e7622dfb883cee1dd0a7718b27d39b418 /meta-n450 | |
parent | 2bd6b798cbb21562ace0b53808c544dc38deb4b0 (diff) | |
download | meta-intel-14f57b958ba34ad3c5e82188ff3f457f7737b9b5.tar.gz |
n450: add xorg.conf to disable AutoAddDevices
Fixes [YOCTO #869] (2 of 2)
The n450 needs:
Option "AutoAddDevices" "False"
In the ServerFlags, or it will fail to detect the keyboard.
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Acked-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-n450')
-rw-r--r-- | meta-n450/recipes-graphics/xorg-xserver/xserver-xf86-config/n450/xorg.conf | 26 | ||||
-rw-r--r-- | meta-n450/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend | 3 |
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-n450/recipes-graphics/xorg-xserver/xserver-xf86-config/n450/xorg.conf b/meta-n450/recipes-graphics/xorg-xserver/xserver-xf86-config/n450/xorg.conf new file mode 100644 index 0000000..e18b911 --- /dev/null +++ b/meta-n450/recipes-graphics/xorg-xserver/xserver-xf86-config/n450/xorg.conf | |||
@@ -0,0 +1,26 @@ | |||
1 | Section "Device" | ||
2 | Identifier "Intel Graphics Driver" | ||
3 | Driver "intel" | ||
4 | EndSection | ||
5 | |||
6 | Section "Monitor" | ||
7 | Identifier "Generic Monitor" | ||
8 | Option "DPMS" | ||
9 | EndSection | ||
10 | |||
11 | Section "Screen" | ||
12 | Identifier "Default Screen" | ||
13 | Device "Intel Graphics Driver" | ||
14 | Monitor "Generic Monitor" | ||
15 | DefaultDepth 24 | ||
16 | EndSection | ||
17 | |||
18 | Section "ServerLayout" | ||
19 | Identifier "Default Layout" | ||
20 | Screen "Default Screen" | ||
21 | EndSection | ||
22 | |||
23 | Section "ServerFlags" | ||
24 | Option "DontZap" "0" | ||
25 | Option "AutoAddDevices" "False" | ||
26 | EndSection | ||
diff --git a/meta-n450/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-n450/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend new file mode 100644 index 0000000..4b8d0e6 --- /dev/null +++ b/meta-n450/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}" | ||
2 | FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:" | ||
3 | |||