diff options
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-qoriq/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch | 63 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_5.4.bb | 1 |
2 files changed, 64 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch b/recipes-kernel/linux/linux-qoriq/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch new file mode 100644 index 00000000..e3df8084 --- /dev/null +++ b/recipes-kernel/linux/linux-qoriq/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | From 0ada120c883d4f1f6aafd01cf0fbb10d8bbba015 Mon Sep 17 00:00:00 2001 | ||
2 | From: Changbin Du <changbin.du@gmail.com> | ||
3 | Date: Tue, 28 Jan 2020 23:29:38 +0800 | ||
4 | Subject: [PATCH] perf: Make perf able to build with latest libbfd | ||
5 | |||
6 | libbfd has changed the bfd_section_* macros to inline functions | ||
7 | bfd_section_<field> since 2019-09-18. See below two commits: | ||
8 | o http://www.sourceware.org/ml/gdb-cvs/2019-09/msg00064.html | ||
9 | o https://www.sourceware.org/ml/gdb-cvs/2019-09/msg00072.html | ||
10 | |||
11 | This fix make perf able to build with both old and new libbfd. | ||
12 | |||
13 | Upstream-Status: Submitted [commit 0ada120c883d4f1f6aafd01cf0fbb10d8bbba015 upstream] | ||
14 | |||
15 | Signed-off-by: Changbin Du <changbin.du@gmail.com> | ||
16 | Acked-by: Jiri Olsa <jolsa@redhat.com> | ||
17 | Cc: Peter Zijlstra <peterz@infradead.org> | ||
18 | Link: http://lore.kernel.org/lkml/20200128152938.31413-1-changbin.du@gmail.com | ||
19 | Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com> | ||
20 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
21 | --- | ||
22 | tools/perf/util/srcline.c | 16 +++++++++++++++- | ||
23 | 1 file changed, 15 insertions(+), 1 deletion(-) | ||
24 | |||
25 | diff --git a/tools/perf/util/srcline.c b/tools/perf/util/srcline.c | ||
26 | index 6ccf6f6d09df..5b7d6c16d33f 100644 | ||
27 | --- a/tools/perf/util/srcline.c | ||
28 | +++ b/tools/perf/util/srcline.c | ||
29 | @@ -193,16 +193,30 @@ static void find_address_in_section(bfd *abfd, asection *section, void *data) | ||
30 | bfd_vma pc, vma; | ||
31 | bfd_size_type size; | ||
32 | struct a2l_data *a2l = data; | ||
33 | + flagword flags; | ||
34 | |||
35 | if (a2l->found) | ||
36 | return; | ||
37 | |||
38 | - if ((bfd_get_section_flags(abfd, section) & SEC_ALLOC) == 0) | ||
39 | +#ifdef bfd_get_section_flags | ||
40 | + flags = bfd_get_section_flags(abfd, section); | ||
41 | +#else | ||
42 | + flags = bfd_section_flags(section); | ||
43 | +#endif | ||
44 | + if ((flags & SEC_ALLOC) == 0) | ||
45 | return; | ||
46 | |||
47 | pc = a2l->addr; | ||
48 | +#ifdef bfd_get_section_vma | ||
49 | vma = bfd_get_section_vma(abfd, section); | ||
50 | +#else | ||
51 | + vma = bfd_section_vma(section); | ||
52 | +#endif | ||
53 | +#ifdef bfd_get_section_size | ||
54 | size = bfd_get_section_size(section); | ||
55 | +#else | ||
56 | + size = bfd_section_size(section); | ||
57 | +#endif | ||
58 | |||
59 | if (pc < vma || pc >= vma + size) | ||
60 | return; | ||
61 | -- | ||
62 | 2.17.1 | ||
63 | |||
diff --git a/recipes-kernel/linux/linux-qoriq_5.4.bb b/recipes-kernel/linux/linux-qoriq_5.4.bb index e632f273..2d6c7cc5 100644 --- a/recipes-kernel/linux/linux-qoriq_5.4.bb +++ b/recipes-kernel/linux/linux-qoriq_5.4.bb | |||
@@ -2,6 +2,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | |||
2 | 2 | ||
3 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ | 3 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ |
4 | file://0001-Makfefile-linux-5.4-add-warning-cflags-on-LSDK-20.04.patch \ | 4 | file://0001-Makfefile-linux-5.4-add-warning-cflags-on-LSDK-20.04.patch \ |
5 | file://0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch \ | ||
5 | " | 6 | " |
6 | SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466" | 7 | SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466" |
7 | 8 | ||