diff options
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb | 33 |
1 files changed, 0 insertions, 33 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb b/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb deleted file mode 100644 index 7cf8f57a..00000000 --- a/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | DESCRIPTION = "Non-DPAA software Application Specific Fast-path" | ||
2 | SECTION = "asf" | ||
3 | LICENSE = "GPLv2 & GPLv2+ & BSD" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" | ||
5 | |||
6 | SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=master" | ||
7 | SRCREV = "62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b" | ||
8 | |||
9 | inherit module | ||
10 | |||
11 | S = "${WORKDIR}/git/asfmodule" | ||
12 | |||
13 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" | ||
14 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" | ||
15 | |||
16 | INHIBIT_PACKAGE_STRIP = "1" | ||
17 | |||
18 | do_configure[depends] += "virtual/kernel:do_shared_workdir" | ||
19 | do_configure_prepend () { | ||
20 | find ${S} -name Makefile -exec \ | ||
21 | sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \; | ||
22 | } | ||
23 | |||
24 | do_install(){ | ||
25 | mkdir -p ${D}/${libexecdir} | ||
26 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf | ||
27 | cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf | ||
28 | cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf | ||
29 | cp -rf ${S}/../scripts ${D}/${libexecdir}/ | ||
30 | } | ||
31 | |||
32 | FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf" | ||
33 | RDEPENDS_${PN} += "ipsec-tools" | ||