summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc/0001-FMCCFGReader-improve-parameter-definition-of-functio.patch38
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2024.07.inc (renamed from recipes-bsp/u-boot/u-boot-fslc-common_2024.04.inc)6
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.04.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2024.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc_2024.04.bb)0
-rw-r--r--recipes-core/udev/udev-rules-imx.bb6
-rw-r--r--recipes-kernel/linux/linux-fslc_6.6.bb6
6 files changed, 29 insertions, 27 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc/0001-FMCCFGReader-improve-parameter-definition-of-functio.patch b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc/0001-FMCCFGReader-improve-parameter-definition-of-functio.patch
index 06cafa72..5769d555 100644
--- a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc/0001-FMCCFGReader-improve-parameter-definition-of-functio.patch
+++ b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc/0001-FMCCFGReader-improve-parameter-definition-of-functio.patch
@@ -1,7 +1,7 @@
1From 329c8ab2770ab34d887296a35585fac53c8bedb7 Mon Sep 17 00:00:00 2001 1From 018249d180705657efbecdce3736c9a415412762 Mon Sep 17 00:00:00 2001
2From: Meng Li <Meng.Li@windriver.com> 2From: Meng Li <Meng.Li@windriver.com>
3Date: Wed, 5 Jun 2024 18:54:22 +0800 3Date: Tue, 9 Jul 2024 14:35:06 +0800
4Subject: [PATCH] FMCCFGReader: improve parameter definition of function 4Subject: [PATCH] FMCCFGReader: improve parameter definition of function
5 errorFuncHandler 5 errorFuncHandler
6 6
7When building fmc package, there is below error: 7When building fmc package, there is below error:
@@ -30,27 +30,27 @@ index a1a87a4..c11742c 100644
30--- a/source/FMCGenericError.cpp 30--- a/source/FMCGenericError.cpp
31+++ b/source/FMCGenericError.cpp 31+++ b/source/FMCGenericError.cpp
32@@ -33,7 +33,7 @@ 32@@ -33,7 +33,7 @@
33 #include "FMCUtils.h" 33 #include "FMCUtils.h"
34 #include "logger.hpp" 34 #include "logger.hpp"
35 35
36-void errorFuncHandler( void * ctx, xmlErrorPtr error ) 36-void errorFuncHandler( void * ctx, xmlErrorPtr error )
37+void errorFuncHandler( void * ctx, const xmlError *error ) 37+void errorFuncHandler( void * ctx, const xmlError *error )
38 { 38 {
39 char *filestr = (char*)""; 39 char *filestr = (char*)"";
40 char *msgstr = (char*)""; 40 char *msgstr = (char*)"";
41diff --git a/source/FMCGenericError.h b/source/FMCGenericError.h 41diff --git a/source/FMCGenericError.h b/source/FMCGenericError.h
42index 504a81b..61ab6c1 100644 42index 504a81b..61ab6c1 100644
43--- a/source/FMCGenericError.h 43--- a/source/FMCGenericError.h
44+++ b/source/FMCGenericError.h 44+++ b/source/FMCGenericError.h
45@@ -35,7 +35,7 @@ 45@@ -35,7 +35,7 @@
46 46
47 const int NO_LINE = -1; 47 const int NO_LINE = -1;
48 48
49-void errorFuncHandler( void * ctx, xmlErrorPtr error ); 49-void errorFuncHandler( void * ctx, xmlErrorPtr error );
50+void errorFuncHandler( void * ctx, const xmlError *error ); 50+void errorFuncHandler( void * ctx, const xmlError *error );
51 51
52 52
53 class CGenericError { 53 class CGenericError {
54-- 54--
552.34.1 552.34.1
56 56
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2024.04.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2024.07.inc
index b270dfd7..214d4532 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2024.04.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2024.07.inc
@@ -10,10 +10,10 @@ DEPENDS += "flex-native bison-native"
10 10
11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https" 11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https"
12 12
13SRCREV = "1a2bdc16b79a6f9c31829ede1bbf4063ccea6e54" 13SRCREV = "1406c04f60f5c375e0fc77b9f661aecd08dff45e"
14SRCBRANCH = "2024.04+fslc" 14SRCBRANCH = "2024.07+fslc"
15 15
16PV = "2024.04+git${SRCPV}" 16PV = "2024.07+fslc+git${SRCPV}"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19B = "${WORKDIR}/build" 19B = "${WORKDIR}/build"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.07.bb
index b7e4ca76..b7e4ca76 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.07.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2024.04.bb b/recipes-bsp/u-boot/u-boot-fslc_2024.07.bb
index eba8876a..eba8876a 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2024.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2024.07.bb
diff --git a/recipes-core/udev/udev-rules-imx.bb b/recipes-core/udev/udev-rules-imx.bb
index 8ade3ebf..57aff9bc 100644
--- a/recipes-core/udev/udev-rules-imx.bb
+++ b/recipes-core/udev/udev-rules-imx.bb
@@ -4,7 +4,9 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
4 4
5SRC_URI = " file://10-imx.rules" 5SRC_URI = " file://10-imx.rules"
6 6
7S = "${UNPACKDIR}"
8
7do_install () { 9do_install () {
8 install -d ${D}${sysconfdir}/udev/rules.d 10 install -D -m 0644 ${UNPACKDIR}/10-imx.rules \
9 install -m 0644 ${UNPACKDIR}/10-imx.rules ${D}${sysconfdir}/udev/rules.d/ 11 ${D}${sysconfdir}/udev/rules.d/10-imx.rules
10} 12}
diff --git a/recipes-kernel/linux/linux-fslc_6.6.bb b/recipes-kernel/linux/linux-fslc_6.6.bb
index f9a54080..35489fef 100644
--- a/recipes-kernel/linux/linux-fslc_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc_6.6.bb
@@ -1,4 +1,4 @@
1# Copyright (C) 2012-2019 O.S. Systems Software LTDA. 1# Copyright (C) 2012-2024 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3# 3#
4# SPDX-License-Identifier: MIT 4# SPDX-License-Identifier: MIT
@@ -19,10 +19,10 @@ SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=
19# 19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged. 21# should be updated once patchlevel is merged.
22LINUX_VERSION = "6.6.32" 22LINUX_VERSION = "6.6.36"
23 23
24KBRANCH = "6.6.x+fslc" 24KBRANCH = "6.6.x+fslc"
25SRCREV = "8c0a83d1bb158cd9d90ab7378fd963e72b4a5a7f" 25SRCREV = "32a79dc5c8f69f1eb7b10b7707b0078fb2fdfa98"
26 26
27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig" 27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
28KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig" 28KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig"