diff options
-rw-r--r-- | classes/fsl-u-boot-localversion.bbclass | 30 | ||||
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit/ppc-fixplt.patch | 104 | ||||
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend | 4 | ||||
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb | 7 | ||||
-rw-r--r-- | recipes-bsp/imx-seco/imx-seco_5.9.4.bb (renamed from recipes-bsp/imx-seco/imx-seco_5.9.0.bb) | 6 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb | 8 |
6 files changed, 26 insertions, 133 deletions
diff --git a/classes/fsl-u-boot-localversion.bbclass b/classes/fsl-u-boot-localversion.bbclass index 94b30c04..df4ac5fb 100644 --- a/classes/fsl-u-boot-localversion.bbclass +++ b/classes/fsl-u-boot-localversion.bbclass | |||
@@ -17,21 +17,21 @@ UBOOT_LOCALVERSION = "${LOCALVERSION}" | |||
17 | do_compile:prepend() { | 17 | do_compile:prepend() { |
18 | if [ "${SCMVERSION}" = "y" ]; then | 18 | if [ "${SCMVERSION}" = "y" ]; then |
19 | # Add GIT revision to the local version | 19 | # Add GIT revision to the local version |
20 | if [ "${SRCREV}" = "INVALID" ]; then | 20 | if [ "${SRCREV}" = "INVALID" ]; then |
21 | hash=${SRCREV_machine} | 21 | hash=${SRCREV_machine} |
22 | else | 22 | else |
23 | hash=${SRCREV} | 23 | hash=${SRCREV} |
24 | fi | 24 | fi |
25 | if [ "$hash" = "AUTOINC" ]; then | 25 | if [ "$hash" = "AUTOINC" ]; then |
26 | branch=`git --git-dir=${S}/.git symbolic-ref --short -q HEAD` | 26 | branch=`git --git-dir=${S}/.git symbolic-ref --short -q HEAD` |
27 | head=`git --git-dir=${S}/.git rev-parse --verify --short origin/${branch} 2> /dev/null` | 27 | head=`git --git-dir=${S}/.git rev-parse --verify --short origin/${branch} 2> /dev/null` |
28 | else | 28 | else |
29 | head=`git --git-dir=${S}/.git rev-parse --verify --short $hash 2> /dev/null` | 29 | head=`git --git-dir=${S}/.git rev-parse --verify --short $hash 2> /dev/null` |
30 | fi | 30 | fi |
31 | patches=`git --git-dir=${S}/.git rev-list --count $head..HEAD 2> /dev/null` | 31 | patches=`git --git-dir=${S}/.git rev-list --count $head..HEAD 2> /dev/null` |
32 | printf "%s%s%s%s" +g $head +p $patches > ${S}/.scmversion | 32 | printf "%s%s%s%s%s" "${UBOOT_LOCALVERSION}" +g $head +p $patches > ${S}/.scmversion |
33 | printf "%s%s%s%s" +g $head +p $patches > ${B}/.scmversion | 33 | printf "%s%s%s%s%s" "${UBOOT_LOCALVERSION}" +g $head +p $patches > ${B}/.scmversion |
34 | else | 34 | else |
35 | printf "%s" "${UBOOT_LOCALVERSION}" > ${S}/.scmversion | 35 | printf "%s" "${UBOOT_LOCALVERSION}" > ${S}/.scmversion |
36 | printf "%s" "${UBOOT_LOCALVERSION}" > ${B}/.scmversion | 36 | printf "%s" "${UBOOT_LOCALVERSION}" > ${B}/.scmversion |
37 | fi | 37 | fi |
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit/ppc-fixplt.patch b/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit/ppc-fixplt.patch deleted file mode 100644 index a576f917..00000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit/ppc-fixplt.patch +++ /dev/null | |||
@@ -1,104 +0,0 @@ | |||
1 | Upstream-Status: Pending | ||
2 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
3 | |||
4 | libluajit is having symbols that can't be | ||
5 | resolved the reloc cannot accommodate an offset greater than 24 bits. | ||
6 | |||
7 | Looking at libluajit with readelf -r, you see a bunch of entries that look like: | ||
8 | 000082f0 00003c0a R_PPC_REL24 00000000 sqrt + 0 | ||
9 | |||
10 | These should not occur when the code is compiled and linked with -fPIC. | ||
11 | |||
12 | It turns out that libluajit *is* compiled and linked with -fPIC, however... | ||
13 | There is one assembler file called lj_vm.s which is generated during the build. | ||
14 | This file is missing the `@plt' qualifier from external references. | ||
15 | |||
16 | This file is generated by a program called buildvm. This in turn uses tables | ||
17 | in a file called buildvm_arch.h which is generated by dynasm.lua. | ||
18 | |||
19 | Index: LuaJIT-2.0.1/src/host/buildvm.c | ||
20 | =================================================================== | ||
21 | --- LuaJIT-2.0.1.orig/src/host/buildvm.c 2013-02-19 12:15:00.000000000 -0800 | ||
22 | +++ LuaJIT-2.0.1/src/host/buildvm.c 2013-05-14 20:26:05.933444512 -0700 | ||
23 | @@ -107,12 +107,14 @@ | ||
24 | #endif | ||
25 | sprintf(name, "%s%s%s", symprefix, prefix, suffix); | ||
26 | p = strchr(name, '@'); | ||
27 | +#if 0 | ||
28 | if (p) { | ||
29 | if (!LJ_64 && (ctx->mode == BUILD_coffasm || ctx->mode == BUILD_peobj)) | ||
30 | name[0] = '@'; | ||
31 | else | ||
32 | *p = '\0'; | ||
33 | } | ||
34 | +#endif | ||
35 | p = (char *)malloc(strlen(name)+1); /* MSVC doesn't like strdup. */ | ||
36 | strcpy(p, name); | ||
37 | return p; | ||
38 | Index: LuaJIT-2.0.1/src/vm_ppcspe.dasc | ||
39 | =================================================================== | ||
40 | --- LuaJIT-2.0.1.orig/src/vm_ppcspe.dasc 2013-02-19 12:15:00.000000000 -0800 | ||
41 | +++ LuaJIT-2.0.1/src/vm_ppcspe.dasc 2013-05-14 20:26:05.937444512 -0700 | ||
42 | @@ -1390,7 +1390,7 @@ | ||
43 | | checknum CARG2 | ||
44 | | evmergehi CARG1, CARG2, CARG2 | ||
45 | | checkfail ->fff_fallback | ||
46 | - | bl extern func | ||
47 | + | bl extern func@plt | ||
48 | | evmergelo CRET1, CRET1, CRET2 | ||
49 | | b ->fff_restv | ||
50 | |.endmacro | ||
51 | @@ -1405,7 +1405,7 @@ | ||
52 | | checknum CARG1 | ||
53 | | evmergehi CARG3, CARG4, CARG4 | ||
54 | | checkanyfail ->fff_fallback | ||
55 | - | bl extern func | ||
56 | + | bl extern func@plt | ||
57 | | evmergelo CRET1, CRET1, CRET2 | ||
58 | | b ->fff_restv | ||
59 | |.endmacro | ||
60 | @@ -1437,7 +1437,7 @@ | ||
61 | | checknum CARG2 | ||
62 | | evmergehi CARG1, CARG2, CARG2 | ||
63 | | checkfail ->fff_fallback | ||
64 | - | bl extern log | ||
65 | + | bl extern log@plt | ||
66 | | evmergelo CRET1, CRET1, CRET2 | ||
67 | | b ->fff_restv | ||
68 | | | ||
69 | @@ -1471,7 +1471,7 @@ | ||
70 | | checknum CARG1 | ||
71 | | checkanyfail ->fff_fallback | ||
72 | | efdctsi CARG3, CARG4 | ||
73 | - | bl extern ldexp | ||
74 | + | bl extern ldexp@plt | ||
75 | | evmergelo CRET1, CRET1, CRET2 | ||
76 | | b ->fff_restv | ||
77 | | | ||
78 | @@ -1484,7 +1484,7 @@ | ||
79 | | checkfail ->fff_fallback | ||
80 | | la CARG3, DISPATCH_GL(tmptv)(DISPATCH) | ||
81 | | lwz PC, FRAME_PC(BASE) | ||
82 | - | bl extern frexp | ||
83 | + | bl extern frexp@plt | ||
84 | | lwz TMP1, DISPATCH_GL(tmptv)(DISPATCH) | ||
85 | | evmergelo CRET1, CRET1, CRET2 | ||
86 | | efdcfsi CRET2, TMP1 | ||
87 | @@ -1503,7 +1503,7 @@ | ||
88 | | checkfail ->fff_fallback | ||
89 | | la CARG3, -8(BASE) | ||
90 | | lwz PC, FRAME_PC(BASE) | ||
91 | - | bl extern modf | ||
92 | + | bl extern modf@plt | ||
93 | | evmergelo CRET1, CRET1, CRET2 | ||
94 | | la RA, -8(BASE) | ||
95 | | evstdd CRET1, 0(BASE) | ||
96 | @@ -2399,7 +2399,7 @@ | ||
97 | | checknum CARG1 | ||
98 | | evmergehi CARG3, CARG4, CARG4 | ||
99 | | checkanyfail ->vmeta_arith_vv | ||
100 | - | bl extern pow | ||
101 | + | bl extern pow@plt | ||
102 | | evmergelo CRET2, CRET1, CRET2 | ||
103 | | evstddx CRET2, BASE, RA | ||
104 | | ins_next | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend b/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend deleted file mode 100644 index d07f8ae1..00000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:" | ||
2 | |||
3 | SRC_URI:append:qoriq-ppc = " file://ppc-fixplt.patch " | ||
4 | |||
diff --git a/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb b/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb index d28b2382..c425173c 100644 --- a/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb +++ b/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb | |||
@@ -7,11 +7,11 @@ should be preferred." | |||
7 | 7 | ||
8 | SECTION = "kernel" | 8 | SECTION = "kernel" |
9 | LICENSE = "Proprietary" | 9 | LICENSE = "Proprietary" |
10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44a8052c384584ba09077e85a3d1654f" | 10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=10c0fda810c63b052409b15a5445671a" |
11 | 11 | ||
12 | SRC_URI = "git://github.com/nxp-imx/imx-firmware.git;protocol=https;branch=${SRCBRANCH}" | 12 | SRC_URI = "git://github.com/nxp-imx/imx-firmware.git;protocol=https;branch=${SRCBRANCH}" |
13 | SRCBRANCH = "lf-6.6.3_1.0.0" | 13 | SRCBRANCH = "lf-6.6.23_2.0.0" |
14 | SRCREV = "2afa15e77f0b58eade42b4f59c9215339efcca66" | 14 | SRCREV = "7e038c6afba3118bcee91608764ac3c633bce0c4" |
15 | 15 | ||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | 17 | ||
@@ -150,6 +150,7 @@ FILES:${PN}-nxpiw612-sdio = " \ | |||
150 | ${nonarch_base_libdir}/firmware/nxp/sd_w61x_v1.bin.se \ | 150 | ${nonarch_base_libdir}/firmware/nxp/sd_w61x_v1.bin.se \ |
151 | ${nonarch_base_libdir}/firmware/nxp/uartspi_n61x_v1.bin.se \ | 151 | ${nonarch_base_libdir}/firmware/nxp/uartspi_n61x_v1.bin.se \ |
152 | ${nonarch_base_libdir}/firmware/nxp/IW612_SD_RFTest/ \ | 152 | ${nonarch_base_libdir}/firmware/nxp/IW612_SD_RFTest/ \ |
153 | ${nonarch_base_libdir}/firmware/nxp/uartuart_n61x_v1.bin.se \ | ||
153 | " | 154 | " |
154 | RDEPENDS:${PN}-nxpiw612-sdio += "${PN}-nxp-common" | 155 | RDEPENDS:${PN}-nxpiw612-sdio += "${PN}-nxp-common" |
155 | RPROVIDES:${PN}-nxpiw612-sdio = "linux-firmware-nxpiw612-sdio" | 156 | RPROVIDES:${PN}-nxpiw612-sdio = "linux-firmware-nxpiw612-sdio" |
diff --git a/recipes-bsp/imx-seco/imx-seco_5.9.0.bb b/recipes-bsp/imx-seco/imx-seco_5.9.4.bb index f7dadea5..14b15da2 100644 --- a/recipes-bsp/imx-seco/imx-seco_5.9.0.bb +++ b/recipes-bsp/imx-seco/imx-seco_5.9.4.bb | |||
@@ -4,14 +4,14 @@ SUMMARY = "NXP i.MX SECO firmware" | |||
4 | DESCRIPTION = "Firmware for i.MX Security Controller Subsystem" | 4 | DESCRIPTION = "Firmware for i.MX Security Controller Subsystem" |
5 | SECTION = "base" | 5 | SECTION = "base" |
6 | LICENSE = "Proprietary" | 6 | LICENSE = "Proprietary" |
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=10c0fda810c63b052409b15a5445671a" |
8 | 8 | ||
9 | inherit fsl-eula-unpack use-imx-security-controller-firmware deploy | 9 | inherit fsl-eula-unpack use-imx-security-controller-firmware deploy |
10 | 10 | ||
11 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" | 11 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" |
12 | 12 | ||
13 | SRC_URI[md5sum] = "b722a534c4d3cc90270e05eaa812514d" | 13 | SRC_URI[md5sum] = "d05d6b15ad9ad0df141e1fc736f4a622" |
14 | SRC_URI[sha256sum] = "c3bd761f457e939035b01a0ab36e79064a2a1bc6c3cdb3cd847f7f38df0964df" | 14 | SRC_URI[sha256sum] = "9b04be33814a9cbda9bbfcb6711585cf7e4ed2527793813c95230f350323cba7" |
15 | 15 | ||
16 | 16 | ||
17 | do_compile[noexec] = "1" | 17 | do_compile[noexec] = "1" |
diff --git a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb index 48e9cc3b..453fdd48 100644 --- a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb +++ b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | SUMMARY = "NXP Wi-Fi driver for module 88w8801/8987/8997/9098 IW416/612" | 1 | SUMMARY = "NXP Wi-Fi driver for module 88w8801/8987/8997/9098 IW416/612" |
2 | LICENSE = "GPL-2.0-only" | 2 | LICENSE = "GPL-2.0-only" |
3 | LIC_FILES_CHKSUM = "file://../../LICENSE;md5=ab04ac0f249af12befccb94447c08b77" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ab04ac0f249af12befccb94447c08b77" |
4 | 4 | ||
5 | # For backwards compatibility | 5 | # For backwards compatibility |
6 | PROVIDES += "kernel-module-nxp89xx" | 6 | PROVIDES += "kernel-module-nxp89xx" |
@@ -8,12 +8,12 @@ RREPLACES:${PN} = "kernel-module-nxp89xx" | |||
8 | RPROVIDES:${PN} = "kernel-module-nxp89xx" | 8 | RPROVIDES:${PN} = "kernel-module-nxp89xx" |
9 | RCONFLICTS:${PN} = "kernel-module-nxp89xx" | 9 | RCONFLICTS:${PN} = "kernel-module-nxp89xx" |
10 | 10 | ||
11 | SRCBRANCH = "lf-6.6.3_1.0.0" | 11 | SRCBRANCH = "lf-6.6.23_2.0.0" |
12 | MRVL_SRC ?= "git://github.com/nxp-imx/mwifiex.git;protocol=https" | 12 | MRVL_SRC ?= "git://github.com/nxp-imx/mwifiex.git;protocol=https" |
13 | SRC_URI = "${MRVL_SRC};branch=${SRCBRANCH}" | 13 | SRC_URI = "${MRVL_SRC};branch=${SRCBRANCH}" |
14 | SRCREV = "a84df583155bad2a396a937056805550bdf655ab" | 14 | SRCREV = "88372772badbf30152b3ad12ae251dc567095cab" |
15 | 15 | ||
16 | S = "${WORKDIR}/git/mxm_wifiex/wlan_src" | 16 | S = "${WORKDIR}/git" |
17 | 17 | ||
18 | inherit module | 18 | inherit module |
19 | 19 | ||