diff options
-rw-r--r-- | recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb | 20 |
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb index b106b985..5f33e78b 100644 --- a/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb +++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb | |||
@@ -3,21 +3,21 @@ | |||
3 | DESCRIPTION = "i.MX Verisilicon Software ISP" | 3 | DESCRIPTION = "i.MX Verisilicon Software ISP" |
4 | LICENSE = "Proprietary" | 4 | LICENSE = "Proprietary" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=3c3fe2b904fd694f28d2f646ee16dddb" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=3c3fe2b904fd694f28d2f646ee16dddb" |
6 | DEPENDS = "python3 libdrm" | ||
6 | 7 | ||
7 | inherit fsl-eula-unpack cmake systemd | 8 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true \ |
8 | |||
9 | SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \ | ||
10 | file://0001-start_isp.sh-fix-test-to-be-generic.patch \ | 9 | file://0001-start_isp.sh-fix-test-to-be-generic.patch \ |
11 | " | 10 | " |
12 | 11 | ||
13 | SRC_URI[md5sum] = "75f79ba556c47172b9a0cbc3a877e604" | 12 | SRC_URI[md5sum] = "75f79ba556c47172b9a0cbc3a877e604" |
14 | SRC_URI[sha256sum] = "28e2ee909f29a256c4eac87ef8336932d90a88a2a183389ac0868212954af42c" | 13 | SRC_URI[sha256sum] = "28e2ee909f29a256c4eac87ef8336932d90a88a2a183389ac0868212954af42c" |
15 | 14 | ||
16 | DEPENDS = "python3 libdrm" | 15 | inherit fsl-eula-unpack cmake systemd |
17 | 16 | ||
18 | # Build the sub-folder appshell | 17 | # Build the sub-folder appshell |
19 | OECMAKE_SOURCEPATH = "${S}/appshell" | 18 | OECMAKE_SOURCEPATH = "${S}/appshell" |
20 | 19 | ||
20 | # Use make instead of ninja | ||
21 | OECMAKE_GENERATOR = "Unix Makefiles" | 21 | OECMAKE_GENERATOR = "Unix Makefiles" |
22 | 22 | ||
23 | SYSTEMD_SERVICE_${PN} = "imx8-isp.service" | 23 | SYSTEMD_SERVICE_${PN} = "imx8-isp.service" |
@@ -52,24 +52,22 @@ do_install() { | |||
52 | cp -r ${WORKDIR}/build/generated/release/bin/*2775* ${D}/opt/imx8-isp/bin | 52 | cp -r ${WORKDIR}/build/generated/release/bin/*2775* ${D}/opt/imx8-isp/bin |
53 | cp -r ${WORKDIR}/build/generated/release/bin/isp_media_server ${D}/opt/imx8-isp/bin | 53 | cp -r ${WORKDIR}/build/generated/release/bin/isp_media_server ${D}/opt/imx8-isp/bin |
54 | cp -r ${WORKDIR}/build/generated/release/bin/vvext ${D}/opt/imx8-isp/bin | 54 | cp -r ${WORKDIR}/build/generated/release/bin/vvext ${D}/opt/imx8-isp/bin |
55 | cp -r ${WORKDIR}/${PN}-${PV}/mediacontrol/case/ ${D}/opt/imx8-isp/bin | 55 | cp -r ${WORKDIR}/${BP}/mediacontrol/case/ ${D}/opt/imx8-isp/bin |
56 | cp -r ${WORKDIR}/build/generated/release/lib/*.so* ${D}/${libdir} | 56 | cp -r ${WORKDIR}/build/generated/release/lib/*.so* ${D}/${libdir} |
57 | cp -r ${WORKDIR}/build/generated/release/include/* ${D}/${includedir} | 57 | cp -r ${WORKDIR}/build/generated/release/include/* ${D}/${includedir} |
58 | 58 | ||
59 | cp ${WORKDIR}/${PN}-${PV}/imx/run.sh ${D}/opt/imx8-isp/bin | 59 | cp ${WORKDIR}/${BP}/imx/run.sh ${D}/opt/imx8-isp/bin |
60 | cp ${WORKDIR}/${PN}-${PV}/imx/start_isp.sh ${D}/opt/imx8-isp/bin | 60 | cp ${WORKDIR}/${BP}/imx/start_isp.sh ${D}/opt/imx8-isp/bin |
61 | 61 | ||
62 | chmod +x ${D}/opt/imx8-isp/bin/run.sh | 62 | chmod +x ${D}/opt/imx8-isp/bin/run.sh |
63 | chmod +x ${D}/opt/imx8-isp/bin/start_isp.sh | 63 | chmod +x ${D}/opt/imx8-isp/bin/start_isp.sh |
64 | 64 | ||
65 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 65 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
66 | install -d ${D}${systemd_system_unitdir} | 66 | install -d ${D}${systemd_system_unitdir} |
67 | install -m 0644 ${WORKDIR}/${PN}-${PV}/imx/imx8-isp.service ${D}${systemd_system_unitdir} | 67 | install -m 0644 ${WORKDIR}/${BP}/imx/imx8-isp.service ${D}${systemd_system_unitdir} |
68 | fi | 68 | fi |
69 | } | 69 | } |
70 | 70 | ||
71 | RDEPENDS_${PN} = "libdrm libpython3" | ||
72 | |||
73 | # The build contains a mix of versioned and unversioned libraries, so | 71 | # The build contains a mix of versioned and unversioned libraries, so |
74 | # the default packaging configuration needs some modifications | 72 | # the default packaging configuration needs some modifications |
75 | FILES_SOLIBSDEV = "" | 73 | FILES_SOLIBSDEV = "" |
@@ -82,4 +80,6 @@ FILES_${PN}-dev += " \ | |||
82 | 80 | ||
83 | INSANE_SKIP_${PN} = "rpaths" | 81 | INSANE_SKIP_${PN} = "rpaths" |
84 | 82 | ||
83 | RDEPENDS_${PN} = "libdrm libpython3" | ||
84 | |||
85 | COMPATIBLE_MACHINE = "(imx|use-nxp-bsp)" | 85 | COMPATIBLE_MACHINE = "(imx|use-nxp-bsp)" |