diff options
-rw-r--r-- | recipes-fsl/mcore-demos/README | 2 | ||||
-rw-r--r-- | recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb | 26 | ||||
-rw-r--r-- | recipes-fsl/mcore-demos/imx-m7-demos_24.12.00.bb (renamed from recipes-fsl/mcore-demos/imx-m7-demos_2.16.001.bb) | 2 | ||||
-rw-r--r-- | recipes-fsl/mcore-demos/imx-mcore-demos.inc | 12 |
4 files changed, 14 insertions, 28 deletions
diff --git a/recipes-fsl/mcore-demos/README b/recipes-fsl/mcore-demos/README index 0023bb26..addd1c37 100644 --- a/recipes-fsl/mcore-demos/README +++ b/recipes-fsl/mcore-demos/README | |||
@@ -5,7 +5,7 @@ The M4 demo app version of each SoCs are followed: | |||
5 | 5 | ||
6 | The M7 demo app version of each SoCs are followed: | 6 | The M7 demo app version of each SoCs are followed: |
7 | * 2.16.000 -- i.MX 8MP , 8MNULite, 8MN | 7 | * 2.16.000 -- i.MX 8MP , 8MNULite, 8MN |
8 | * 2.16.001 -- i.MX95 | 8 | * 24.12.00 -- i.MX95 |
9 | 9 | ||
10 | The M33 demo app version of each SoCs are followed: | 10 | The M33 demo app version of each SoCs are followed: |
11 | * 2.16.000 -- i.MX 8ULP, i.MX 93 | 11 | * 2.16.000 -- i.MX 8ULP, i.MX 93 |
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb b/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb index 78a837af..6791553b 100644 --- a/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb +++ b/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb | |||
@@ -1,27 +1,13 @@ | |||
1 | SUMMARY = "i.MX M4 core Demo images" | 1 | # Copyright 2017-2021 NXP |
2 | SECTION = "app" | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | LICENSE = "Proprietary" | ||
4 | LIC_FILES_CHKSUM:mx7d-nxp-bsp = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a" | ||
5 | 3 | ||
6 | inherit deploy fsl-eula-unpack | 4 | require imx-mcore-demos.inc |
7 | 5 | ||
8 | M4_SOC ?= "INVALID" | 6 | LIC_FILES_CHKSUM:mx7d-nxp-bsp = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a" |
9 | M4_SOC:mx7d-nxp-bsp = "imx7d-sabresd" | ||
10 | 7 | ||
11 | SRC_URI = "${FSL_MIRROR}/${M4_SOC}-m4-freertos-${PV}.bin;fsl-eula=true" | 8 | SRC_URI = "${FSL_MIRROR}/${SOC}-m4-freertos-${PV}.bin;fsl-eula=true" |
12 | S = "${WORKDIR}/${M4_SOC}-m4-freertos-${PV}" | 9 | S = "${WORKDIR}/${SOC}-m4-freertos-${PV}" |
13 | 10 | ||
14 | SRC_URI[sha256sum] = "cc00d3b936d49b2794a2a99e10129437e70caba3fd26b8379b8c50dd22f73254" | 11 | SRC_URI[sha256sum] = "cc00d3b936d49b2794a2a99e10129437e70caba3fd26b8379b8c50dd22f73254" |
15 | 12 | ||
16 | do_deploy () { | ||
17 | # Install the demo binaries | ||
18 | install -d ${DEPLOYDIR} | ||
19 | cp ${S}/*.bin ${DEPLOYDIR}/ | ||
20 | ls ${DEPLOYDIR}/ | ||
21 | } | ||
22 | |||
23 | addtask deploy before do_build after do_compile | ||
24 | |||
25 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||
26 | COMPATIBLE_MACHINE = "(mx7d-nxp-bsp)" | 13 | COMPATIBLE_MACHINE = "(mx7d-nxp-bsp)" |
27 | |||
diff --git a/recipes-fsl/mcore-demos/imx-m7-demos_2.16.001.bb b/recipes-fsl/mcore-demos/imx-m7-demos_24.12.00.bb index 56ddbf80..17d90903 100644 --- a/recipes-fsl/mcore-demos/imx-m7-demos_2.16.001.bb +++ b/recipes-fsl/mcore-demos/imx-m7-demos_24.12.00.bb | |||
@@ -5,6 +5,6 @@ require imx-mcore-demos.inc | |||
5 | 5 | ||
6 | LIC_FILES_CHKSUM:mx95-nxp-bsp = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837" | 6 | LIC_FILES_CHKSUM:mx95-nxp-bsp = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837" |
7 | 7 | ||
8 | SRC_URI[imx95.sha256sum] = "0569f128e2068c509dcd4afe6689a62cdb5a4ac9f8eb1b522b2bfaac0e7d09fd" | 8 | SRC_URI[imx95.sha256sum] = "01603b53fd01181631b71f5139a4a3e215f7e03cc531638ef4fa805a678ede3d" |
9 | 9 | ||
10 | COMPATIBLE_MACHINE = "(mx95-nxp-bsp)" | 10 | COMPATIBLE_MACHINE = "(mx95-nxp-bsp)" |
diff --git a/recipes-fsl/mcore-demos/imx-mcore-demos.inc b/recipes-fsl/mcore-demos/imx-mcore-demos.inc index 11621752..8bf66617 100644 --- a/recipes-fsl/mcore-demos/imx-mcore-demos.inc +++ b/recipes-fsl/mcore-demos/imx-mcore-demos.inc | |||
@@ -9,6 +9,7 @@ inherit deploy fsl-eula-unpack | |||
9 | 9 | ||
10 | SOC ?= "INVALID" | 10 | SOC ?= "INVALID" |
11 | SOC:mx7ulp-nxp-bsp = "imx7ulp" | 11 | SOC:mx7ulp-nxp-bsp = "imx7ulp" |
12 | SOC:mx7d-nxp-bsp = "imx7d-sabresd" | ||
12 | SOC:mx8dxl-nxp-bsp = "imx8dxl" | 13 | SOC:mx8dxl-nxp-bsp = "imx8dxl" |
13 | SOC:mx8mm-nxp-bsp = "imx8mm" | 14 | SOC:mx8mm-nxp-bsp = "imx8mm" |
14 | SOC:mx8mn-nxp-bsp = "imx8mn" | 15 | SOC:mx8mn-nxp-bsp = "imx8mn" |
@@ -32,26 +33,25 @@ MCORE_TYPE:mx8ulp-nxp-bsp = "m33" | |||
32 | MCORE_TYPE:mx93-nxp-bsp = "m33" | 33 | MCORE_TYPE:mx93-nxp-bsp = "m33" |
33 | MCORE_TYPE:mx95-nxp-bsp = "m7" | 34 | MCORE_TYPE:mx95-nxp-bsp = "m7" |
34 | 35 | ||
35 | SRC_URI = "${FSL_MIRROR}${SOC}-${MCORE_TYPE}-demo-${PV}.bin;name=${SOC};fsl-eula=true" | 36 | SRC_URI = "${FSL_MIRROR}/${SOC}-${MCORE_TYPE}-demo-${PV}.bin;name=${SOC};fsl-eula=true" |
36 | 37 | ||
37 | S = "${WORKDIR}/${SOC}-${MCORE_TYPE}-demo-${PV}" | 38 | S = "${WORKDIR}/${SOC}-${MCORE_TYPE}-demo-${PV}" |
38 | 39 | ||
39 | #SRC_URI="https://www.nxp.com/lgfiles/NMG/MAD/YOCTO//imx93-m33-demo-2.14.0.bin;fsl-eula=true;name=imx93" | ||
40 | |||
41 | |||
42 | SCR = "SCR-${SOC}-${MCORE_TYPE}-demo.txt" | 40 | SCR = "SCR-${SOC}-${MCORE_TYPE}-demo.txt" |
43 | 41 | ||
44 | do_install () { | 42 | do_install () { |
45 | install -d ${D}${nonarch_base_libdir}/firmware | 43 | install -d ${D}${nonarch_base_libdir}/firmware |
46 | install -m 0644 ${S}/*.elf ${D}${nonarch_base_libdir}/firmware | 44 | install -m 0644 ${S}/*.elf ${D}${nonarch_base_libdir}/firmware |
45 | install -m 0644 ${S}/*.bin ${D}${nonarch_base_libdir}/firmware | ||
47 | } | 46 | } |
48 | 47 | ||
49 | DEPLOY_FILE_EXT ?= "bin" | 48 | DEPLOY_FILE_EXT ?= "bin" |
50 | DEPLOY_FILE_EXT:mx7ulp-nxp-bsp = "img" | 49 | DEPLOY_FILE_EXT:mx7ulp-nxp-bsp = "img" |
51 | 50 | ||
52 | do_deploy () { | 51 | do_deploy () { |
53 | # Install the demo binaries | 52 | # Install the demo binaries |
54 | install -m 0644 ${S}/*.${DEPLOY_FILE_EXT} ${DEPLOYDIR}/ | 53 | install -d ${DEPLOYDIR}/mcore-demos |
54 | install -m 0644 ${S}/*.${DEPLOY_FILE_EXT} ${DEPLOYDIR}/mcore-demos/ | ||
55 | } | 55 | } |
56 | 56 | ||
57 | addtask deploy after do_install | 57 | addtask deploy after do_install |