diff options
author | Oleksandr Suvorov <cryosay@gmail.com> | 2024-04-30 18:39:13 +0300 |
---|---|---|
committer | Oleksandr Suvorov <cryosay@gmail.com> | 2024-04-30 22:52:01 +0300 |
commit | df779d254727962dd025aef675e6c144e03f4fe7 (patch) | |
tree | 33b0aaadedd50cf0a4f84bc814a0aebbb5d3a30e /recipes-kernel | |
parent | 975179cf83b8451c919700bc26665c09e4759ba4 (diff) | |
download | meta-freescale-df779d254727962dd025aef675e6c144e03f4fe7.tar.gz |
linux-fslc-imx: Update up to 6.6.28
Update linux-fslc-imx to 6.6.28.
Also fix the recipe to be 6.6-specific.
Signed-off-by: Oleksandr Suvorov <cryosay@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-fslc-imx_6.6.bb | 23 |
1 files changed, 10 insertions, 13 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.6.bb b/recipes-kernel/linux/linux-fslc-imx_6.6.bb index 6e31c1e2..9511d654 100644 --- a/recipes-kernel/linux/linux-fslc-imx_6.6.bb +++ b/recipes-kernel/linux/linux-fslc-imx_6.6.bb | |||
@@ -12,8 +12,8 @@ Latest stable Kernel patchlevel is applied and maintained by Community." | |||
12 | ############################################################################### | 12 | ############################################################################### |
13 | # This recipe (and corresponding kernel repository and branch) receives updates | 13 | # This recipe (and corresponding kernel repository and branch) receives updates |
14 | # from 3 different sources: | 14 | # from 3 different sources: |
15 | # 1. Stable [linux-6.1.y] branch updates of korg; | 15 | # 1. Stable [linux-6.6.y] branch updates of korg; |
16 | # 2. NXP-specific updates via branch [lf-6.1.y] shared via GitHub NXP repo; | 16 | # 2. NXP-specific updates via branch [lf-6.6.y] shared via GitHub NXP repo; |
17 | # 3. Critical patches, which are not (yet) integrated into either of 2 above | 17 | # 3. Critical patches, which are not (yet) integrated into either of 2 above |
18 | # sources, but are required to be applied to the kernel tree. | 18 | # sources, but are required to be applied to the kernel tree. |
19 | # | 19 | # |
@@ -28,23 +28,20 @@ Latest stable Kernel patchlevel is applied and maintained by Community." | |||
28 | # ------------------------------------------------------------------------------ | 28 | # ------------------------------------------------------------------------------ |
29 | # 1. Stable (tag or SHA(s)) | 29 | # 1. Stable (tag or SHA(s)) |
30 | # ------------------------------------------------------------------------------ | 30 | # ------------------------------------------------------------------------------ |
31 | # tag: v6.1.70 | 31 | # tag: v6.6.28 |
32 | # | 32 | # |
33 | # ------------------------------------------------------------------------------ | 33 | # ------------------------------------------------------------------------------ |
34 | # 2. NXP-specific (tag or SHA(s)) | 34 | # 2. NXP-specific (tag or SHA(s)) |
35 | # ------------------------------------------------------------------------------ | 35 | # ------------------------------------------------------------------------------ |
36 | # tag: lf-6.1.55-2.2.0 | 36 | # tag: lf-6.6.3-1.0.00 |
37 | # | 37 | # |
38 | # ------------------------------------------------------------------------------ | 38 | # ------------------------------------------------------------------------------ |
39 | # 3. Critical patches (SHA(s)) | 39 | # 3. Critical patches (SHA(s)) |
40 | # ------------------------------------------------------------------------------ | 40 | # ------------------------------------------------------------------------------ |
41 | # - 77a660738af5 Revert "net: stmmac: fix FPE events losing" | 41 | # - f67cb9a5b4fb7 Revert "net: stmmac: fix FPE events losing" |
42 | # - d9e9cb8ce9bc hx280enc_vc8000e: fix misplaced #endif | 42 | # - 1918c2eb8b07f Revert "dmaengine: fsl-edma: fix DMA channel leak in eDMAv4" |
43 | # - 3f1f2ea72955 mxc: gpu-viv: change _QuerySignal() return type to gceSTATUS | 43 | # - 42289407ee38f Revert "dmaengine: fsl-edma: Add judgment on enabling round robin arbitration" |
44 | # - b73c6797ee42 ARM: imx_v7_defconfig: Remove KERNEL_LZO config | 44 | # - 952f79923f055 Revert "dmaengine: fsl-edma: Do not suspend and resume the masked dma channel when the system is sleeping" |
45 | # - ec33c7fc43be touchscreen: Kconfig: add I2C dependency for CT36X | ||
46 | # - 6c41233a2cfb pwm: pwm-adp5585: fix get_state callback prototype | ||
47 | # - 9c7540ecb891 pwm: pwm-rpmsg-imx: fix get_state callback prototype | ||
48 | # | 45 | # |
49 | # NOTE to upgraders: | 46 | # NOTE to upgraders: |
50 | # This recipe should NOT collect individual patches, they should be applied to | 47 | # This recipe should NOT collect individual patches, they should be applied to |
@@ -56,14 +53,14 @@ require linux-imx.inc | |||
56 | 53 | ||
57 | KBRANCH = "6.6-1.0.x-imx" | 54 | KBRANCH = "6.6-1.0.x-imx" |
58 | SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" | 55 | SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" |
59 | SRCREV = "ccf0a99701a701fb48a04e31ffe3f9d585a8374a" | 56 | SRCREV = "776652a165f5bbf30c68a5f6213d75b02e8df11c" |
60 | 57 | ||
61 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition | 58 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition |
62 | # required by kernel-yocto.bbclass. | 59 | # required by kernel-yocto.bbclass. |
63 | # | 60 | # |
64 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 61 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
65 | # should be updated once patchlevel is merged. | 62 | # should be updated once patchlevel is merged. |
66 | LINUX_VERSION = "6.6.3" | 63 | LINUX_VERSION = "6.6.28" |
67 | 64 | ||
68 | KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" | 65 | KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" |
69 | KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" | 66 | KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" |