diff options
author | Vincent Davis Jr <vince@underview.tech> | 2023-06-09 16:31:30 -0500 |
---|---|---|
committer | Vincent Davis Jr <vince@underview.tech> | 2023-06-13 09:04:56 -0500 |
commit | 160c16738f1cc4bf3f4a74d5da321f006ac4795b (patch) | |
tree | 486b70e7de4fd88b07f1d0bd4cee8402c85102a0 /recipes-downgrade | |
parent | 30a655d98ef9fc079c45e4b40948de7acb4b2ca4 (diff) | |
download | meta-freescale-160c16738f1cc4bf3f4a74d5da321f006ac4795b.tar.gz |
vulkan-validation-layers: add new recipe v1.2.182.0
Add a recipe to build the Khronos official Vulkan validation
layers that can assist developers in verifying that their
applications correctly use the Vulkan APIs.
Using vulkan version v1.2.182.0 to be compatible with
other vulkan recipes in meta-freescale layer.
Signed-off-by: Vincent Davis Jr <vince@underview.tech>
Diffstat (limited to 'recipes-downgrade')
-rw-r--r-- | recipes-downgrade/vulkan/vulkan-validation-layers_1.2.182.0.imx.bb | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-downgrade/vulkan/vulkan-validation-layers_1.2.182.0.imx.bb b/recipes-downgrade/vulkan/vulkan-validation-layers_1.2.182.0.imx.bb new file mode 100644 index 00000000..da834e62 --- /dev/null +++ b/recipes-downgrade/vulkan/vulkan-validation-layers_1.2.182.0.imx.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | SUMMARY = "Vulkan Validation layers" | ||
2 | DESCRIPTION = "Khronos official Vulkan validation layers to assist developers \ | ||
3 | in verifying that their applications correctly use the Vulkan API" | ||
4 | HOMEPAGE = "https://www.khronos.org/vulkan/" | ||
5 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-ValidationLayers" | ||
6 | SECTION = "libs" | ||
7 | |||
8 | LICENSE = "Apache-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8df9e8826734226d08cb412babfa599c" | ||
10 | |||
11 | SRC_URI = "git://git@github.com/KhronosGroup/Vulkan-ValidationLayers.git;branch=sdk-1.2.182;protocol=https" | ||
12 | SRCREV = "91fcffa8eca1a9573c8d736a54a028035ed4e06c" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | REQUIRED_DISTRO_FEATURES = "vulkan" | ||
17 | |||
18 | DEPENDS = "vulkan-headers vulkan-loader spirv-headers spirv-tools glslang" | ||
19 | |||
20 | # BUILD_TESTS - Not required for OE builds | ||
21 | # BUILD_WERROR - There are too many compiler warnings/errors due to upgrades in version | ||
22 | # of clang. Requiring a number of patches from upstream. Disable compiler | ||
23 | # -Werror to bypass build issues. | ||
24 | # USE_ROBIN_HOOD_HASHING - Provides substantial performance improvements on all platforms. | ||
25 | # Yocto project doesn't contain a recipe for package so disabled it. | ||
26 | EXTRA_OECMAKE = "\ | ||
27 | -DBUILD_TESTS=OFF \ | ||
28 | -DBUILD_WERROR=OFF \ | ||
29 | -DUSE_ROBIN_HOOD_HASHING=OFF \ | ||
30 | -DGLSLANG_INSTALL_DIR=${STAGING_LIBDIR} \ | ||
31 | -DVULKAN_HEADERS_INSTALL_DIR=${STAGING_DATADIR} \ | ||
32 | -DSPIRV_HEADERS_INSTALL_DIR=${STAGING_DATADIR} \ | ||
33 | " | ||
34 | |||
35 | PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr" | ||
36 | PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland" | ||
37 | |||
38 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)}" | ||
39 | |||
40 | inherit cmake features_check pkgconfig | ||
41 | |||
42 | FILES:${PN} += "${datadir}/vulkan" | ||
43 | |||
44 | SOLIBS = ".so" | ||
45 | FILES_SOLIBSDEV = "" | ||
46 | |||
47 | # These recipes need to be updated in lockstep with each other: | ||
48 | # glslang, vulkan-headers, vulkan-loader, vulkan-tools, | ||
49 | # vulkan-validation-layers, spirv-headers, spirv-tools | ||
50 | # The tags versions should always be sdk-x.y.z, as this is what | ||
51 | # upstream considers a release. | ||
52 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" | ||