diff options
author | Lauren Post <lauren.post@nxp.com> | 2016-03-31 10:25:33 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:06:34 -0300 |
commit | 5106a192deacf2c0c08f3f4aa9a9f79ca69e6abe (patch) | |
tree | 6e201f2f08b05ac2970711759924eededf90215e /recipes-bsp | |
parent | cb003490c7e5d8950694da8e0c8cf4478c779445 (diff) | |
download | meta-freescale-5106a192deacf2c0c08f3f4aa9a9f79ca69e6abe.tar.gz |
imx-test: Upgrade to 5.4 version
- Restructure to support building all test cases on all machines
regardless of harware support
- mx6s_v4l2_capture: Fix resource leak reported by coverity
- memtool: Fix string not null - Fix resource leak problem reported by coverity
- mxc_i2c_slave_test: Fix argument cannot be negative problem reported by coverity
- mxc_spi_test1: Fix resource leak problems reported by coverity.
- mxc_vpu_test: Encode and decode MPEG file in one app failed with return value
- mxc_v4l2_capture: Handle usb camera restriction which does not support CROP feature
- mxc_mlb_test: Fix out of bounds access reported by coverity
- soc_check: Remove unnecessary operation in soc_check.h
- mxc_epdc_v2_fb: Initialize upd_data.dither_mode to 0 to avoid the spurious
"unsupported quantization bit number" error message.
- mxc_sim_test: When sim card doesn't exist, no atr can be received. The application
should directly return with corresponding error value.
- Remove legacy platform restriction to shell scripts - only support mx6 and mx7 SoC now.
Signed-off-by: Lauren Post <lauren.post@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-test/imx-test_5.3.bb | 8 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_5.4.bb | 21 |
2 files changed, 21 insertions, 8 deletions
diff --git a/recipes-bsp/imx-test/imx-test_5.3.bb b/recipes-bsp/imx-test/imx-test_5.3.bb deleted file mode 100644 index ce57ae1b..00000000 --- a/recipes-bsp/imx-test/imx-test_5.3.bb +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | # Copyright (C) 2013-2015 Freescale Semiconductor | ||
2 | |||
3 | include imx-test.inc | ||
4 | |||
5 | SRC_URI[md5sum] = "b5d156c4766f06135bfdbf83dc708373" | ||
6 | SRC_URI[sha256sum] = "a7c8aefb57c59883349cef755dc64b09b14af20e20a6a7554828cf6d7347b40e" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" | ||
diff --git a/recipes-bsp/imx-test/imx-test_5.4.bb b/recipes-bsp/imx-test/imx-test_5.4.bb new file mode 100644 index 00000000..de4e5bad --- /dev/null +++ b/recipes-bsp/imx-test/imx-test_5.4.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | # Copyright (C) 2013-2016 Freescale Semiconductor | ||
2 | |||
3 | include imx-test.inc | ||
4 | |||
5 | DEPENDS_mx6q += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
6 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
7 | DEPENDS_mx6dl += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
8 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
9 | DEPENDS_mx6sl += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
10 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
11 | DEPENDS_mx6sx += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
12 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
13 | DEPENDS_mx6ul += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
14 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
15 | DEPENDS_mx7d += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
16 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
17 | |||
18 | SRC_URI[md5sum] = "46ddd6d1631cc0f7328383e13632d5bb" | ||
19 | SRC_URI[sha256sum] = "cae6ec9b4d5cc1c402a7683cc8c2c35cccdd9598283caefcea2804baa47a15b6" | ||
20 | |||
21 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" | ||