diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:14:27 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | f8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch) | |
tree | 79349f091306d1760fd4687e62336ffa8fb8c721 /browser-layer/recipes-browser | |
parent | c92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff) | |
download | meta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz |
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It
contains a clean history and allowing a more granullar set of changes.
This commit is just a rename of all contents of meta-fsl-arm
subdirectory to this layer's root, subsequent changes are based on top
of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'browser-layer/recipes-browser')
-rw-r--r-- | browser-layer/recipes-browser/chromium/chromium-imx.inc | 49 | ||||
-rw-r--r-- | browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend | 12 |
2 files changed, 61 insertions, 0 deletions
diff --git a/browser-layer/recipes-browser/chromium/chromium-imx.inc b/browser-layer/recipes-browser/chromium/chromium-imx.inc new file mode 100644 index 00000000..f63807d5 --- /dev/null +++ b/browser-layer/recipes-browser/chromium/chromium-imx.inc | |||
@@ -0,0 +1,49 @@ | |||
1 | DEPENDS_append_mx6q = " libfslvpuwrap" | ||
2 | DEPENDS_append_mx6dl = " libfslvpuwrap" | ||
3 | |||
4 | # Additional imx code and patches are included in the chromium-imx git repository. | ||
5 | # The code below fetches this repository, copies the extra source over to the main | ||
6 | # chromium source directory, and applies the patches. | ||
7 | |||
8 | CHROMIUM_IMX_BRANCH ?= "master" | ||
9 | CHROMIUM_IMX_SRCREV ?= "HEAD" | ||
10 | CHROMIUM_IMX_DESTSUFFIX ?= "chromium-imx-git" | ||
11 | |||
12 | PATCH_BASE_DIR = "${WORKDIR}/${CHROMIUM_IMX_DESTSUFFIX}/patches" | ||
13 | |||
14 | CHROMIUM_IMX_COMMON_PATCHES ?= " " | ||
15 | CHROMIUM_IMX_VPU_PATCHES ?= " " | ||
16 | CHROMIUM_IMX_WAYLAND_PATCHES ?= " " | ||
17 | |||
18 | SRC_URI += "git://github.com/Freescale/chromium-imx.git;destsuffix=${CHROMIUM_IMX_DESTSUFFIX};branch=${CHROMIUM_IMX_BRANCH};rev=${CHROMIUM_IMX_SRCREV}" | ||
19 | |||
20 | do_unpack[postfuncs] += "copy_chromium_imx_files" | ||
21 | # using =+ instead of += to make sure add_chromium_imx_patches is | ||
22 | # executed before add_ozone_wayland_patches in the main recipe; | ||
23 | # this is necessary because add_chromium_imx_patches appends | ||
24 | # patches to the OZONE_WAYLAND_EXTRA_PATCHES variable | ||
25 | do_patch[prefuncs] =+ "add_chromium_imx_patches" | ||
26 | |||
27 | # * Lost context problems are not known to happen with Vivante GPUs, | ||
28 | # so it is safe to use ignore-lost-context | ||
29 | # * EGL is on by default due to the GPU on the i.MX6 | ||
30 | PACKAGECONFIG_append = " use-egl ignore-lost-context" | ||
31 | |||
32 | copy_chromium_imx_files() { | ||
33 | # sources in src/ are already organized in a manner | ||
34 | # that matches the subdirectories in the chromium | ||
35 | # source directory; just copy over the files in src/ | ||
36 | cp -r ${WORKDIR}/chromium-imx-git/src/* ${S}/ | ||
37 | } | ||
38 | |||
39 | python add_chromium_imx_patches() { | ||
40 | d.appendVar('SRC_URI', ' ' + d.getVar('CHROMIUM_IMX_COMMON_PATCHES', 1)) | ||
41 | d.appendVar('SRC_URI', ' ' + d.getVar('CHROMIUM_IMX_VPU_PATCHES', 1)) | ||
42 | d.appendVar('OZONE_WAYLAND_EXTRA_PATCHES', ' ' + d.getVar('CHROMIUM_IMX_WAYLAND_PATCHES', 1)) | ||
43 | } | ||
44 | |||
45 | # Necessary flags to enable support for h.264 and MP4 in Chromium | ||
46 | # (Parsing is done by ffmpeg) | ||
47 | EXTRA_OEGYP += "-Dproprietary_codecs=1 -Dffmpeg_branding=Chrome" | ||
48 | |||
49 | COMPATIBLE_MACHINE = "(mx6)" | ||
diff --git a/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend b/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend new file mode 100644 index 00000000..d9c5d154 --- /dev/null +++ b/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend | |||
@@ -0,0 +1,12 @@ | |||
1 | include chromium-imx.inc | ||
2 | |||
3 | CHROMIUM_IMX_BRANCH = "chromium-40" | ||
4 | CHROMIUM_IMX_SRCREV = "af13a3dbdfdb4b162a9f9692761216e5d6204e57" | ||
5 | CHROMIUM_IMX_COMMON_PATCHES += "file://${PATCH_BASE_DIR}/common/0001-Enable-share-group-workaround-for-Vivante-GPUs.patch" | ||
6 | |||
7 | VPU_PATCHES = "file://${PATCH_BASE_DIR}/common/0002-Add-VPU-video-decode-accelerator-to-Chromium-GPU-.patch" | ||
8 | |||
9 | CHROMIUM_IMX_VPU_PATCHES_mx6q += "${VPU_PATCHES}" | ||
10 | CHROMIUM_IMX_VPU_PATCHES_mx6dl += "${VPU_PATCHES}" | ||
11 | |||
12 | CHROMIUM_IMX_WAYLAND_PATCHES += "file://${PATCH_BASE_DIR}/wayland/0001-Modify-eglwayland-versions-for-Vivante-GPUs.patch" | ||