summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrej Valek <andrej.v@skyrain.eu>2025-04-17 08:56:52 +0200
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2025-04-17 10:46:45 +0000
commit177dc38c198e5a3049ad01d0b0a0dae1030105ed (patch)
tree431c5a18d2641fdc0ecca650967a1bc1b1bb4a6d
parentaa1a3c026bab756bb8a5643a810db4ea4139eb8f (diff)
downloadmeta-freescale-177dc38c198e5a3049ad01d0b0a0dae1030105ed.tar.gz
fix(opencv): do not try to install sample files
- don't install sample files if PACKAGECONFIG:samples is disabled Signed-off-by: Andrej Valek <andrej.v@skyrain.eu> (cherry picked from commit d025faa488801bdcf4ea0366f6ed19b07f408d5b)
-rw-r--r--recipes-support/opencv/opencv_4.6.0.imx.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-support/opencv/opencv_4.6.0.imx.bb b/recipes-support/opencv/opencv_4.6.0.imx.bb
index 6d13d107..3b455534 100644
--- a/recipes-support/opencv/opencv_4.6.0.imx.bb
+++ b/recipes-support/opencv/opencv_4.6.0.imx.bb
@@ -302,10 +302,12 @@ EXTRA_OECMAKE:append = " -DBUILD_opencv_cvv=OFF"
302 302
303do_install:append() { 303do_install:append() {
304 ln -sf opencv4/opencv2 ${D}${includedir}/opencv2 304 ln -sf opencv4/opencv2 ${D}${includedir}/opencv2
305 install -d ${D}${datadir}/OpenCV/samples/data 305 if ${@bb.utils.contains('PACKAGECONFIG', 'samples', 'true', 'false', d)}; then
306 cp -r ${S}/samples/data/* ${D}${datadir}/OpenCV/samples/data 306 install -d ${D}${datadir}/OpenCV/samples/data
307 install -d ${D}${datadir}/OpenCV/samples/bin/ 307 cp -r ${S}/samples/data/* ${D}${datadir}/OpenCV/samples/data
308 cp -f bin/example_* ${D}${datadir}/OpenCV/samples/bin/ 308 install -d ${D}${datadir}/OpenCV/samples/bin/
309 cp -f bin/example_* ${D}${datadir}/OpenCV/samples/bin/
310 fi
309 if ${@bb.utils.contains('PACKAGECONFIG', 'tests-imx', 'true', 'false', d)}; then 311 if ${@bb.utils.contains('PACKAGECONFIG', 'tests-imx', 'true', 'false', d)}; then
310 cp -r share/opencv4/testdata/cv/face/* ${D}${datadir}/opencv4/testdata/cv/face/ 312 cp -r share/opencv4/testdata/cv/face/* ${D}${datadir}/opencv4/testdata/cv/face/
311 fi 313 fi