summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Schuster <timo.schuster@leica-microsystems.com>2025-01-16 13:09:16 +0100
committerTimo Schuster <timo.schuster@leica-microsystems.com>2025-01-16 13:09:16 +0100
commit181c2e2cfcebd3464c90c4678896bdbd1a25e3cf (patch)
tree42397c1ff1cedd8ea2e7a2eb2924d42059e2c3a0
parentbecacf6d48e326ac91a22f40ae37ac89f93a1be1 (diff)
downloadmeta-freescale-181c2e2cfcebd3464c90c4678896bdbd1a25e3cf.tar.gz
linux-imx: Remove obsolete backport patches
Signed-off-by: Timo Schuster <timo.schuster@leica-microsystems.com>
-rw-r--r--recipes-kernel/linux/linux-imx/0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch62
-rw-r--r--recipes-kernel/linux/linux-imx/0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch38
-rw-r--r--recipes-kernel/linux/linux-imx_6.6.bb2
3 files changed, 0 insertions, 102 deletions
diff --git a/recipes-kernel/linux/linux-imx/0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch b/recipes-kernel/linux/linux-imx/0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch
deleted file mode 100644
index 2933c40e..00000000
--- a/recipes-kernel/linux/linux-imx/0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From 5ef6dc08cfde240b8c748733759185646e654570 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Uwe=20Kleine-K=C3=B6nig?= <u.kleine-koenig@pengutronix.de>
3Date: Wed, 13 Mar 2024 22:19:56 +0100
4Subject: [PATCH] lib/build_OID_registry: don't mention the full path of the
5 script in output
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10This change strips the full path of the script generating
11lib/oid_registry_data.c to just lib/build_OID_registry. The motivation
12for this change is Yocto emitting a build warning
13
14 File /usr/src/debug/linux-lxatac/6.7-r0/lib/oid_registry_data.c in package linux-lxatac-src contains reference to TMPDIR [buildpaths]
15
16So this change brings us one step closer to make the build result
17reproducible independent of the build path.
18
19Upstream-Status: Backport [https://github.com/torvalds/linux/commit/5ef6dc08cfde240b8c748733759185646e654570]
20
21Link: https://lkml.kernel.org/r/20240313211957.884561-2-u.kleine-koenig@pengutronix.de
22Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
23Cc: Masahiro Yamada <masahiroy@kernel.org>
24Reviewed-by: Nicolas Schier <nicolas@fjasle.eu>
25Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
26---
27 lib/build_OID_registry | 5 ++++-
28 1 file changed, 4 insertions(+), 1 deletion(-)
29
30diff --git a/lib/build_OID_registry b/lib/build_OID_registry
31index d7fc32ea8ac2..56d8bafeb848 100755
32--- a/lib/build_OID_registry
33+++ b/lib/build_OID_registry
34@@ -8,6 +8,7 @@
35 #
36
37 use strict;
38+use Cwd qw(abs_path);
39
40 my @names = ();
41 my @oids = ();
42@@ -17,6 +18,8 @@ if ($#ARGV != 1) {
43 exit(2);
44 }
45
46+my $abs_srctree = abs_path($ENV{'srctree'});
47+
48 #
49 # Open the file to read from
50 #
51@@ -35,7 +38,7 @@ close IN_FILE || die;
52 #
53 open C_FILE, ">$ARGV[1]" or die;
54 print C_FILE "/*\n";
55-print C_FILE " * Automatically generated by ", $0, ". Do not edit\n";
56+print C_FILE " * Automatically generated by ", $0 =~ s#^\Q$abs_srctree/\E##r, ". Do not edit\n";
57 print C_FILE " */\n";
58
59 #
60--
612.34.1
62
diff --git a/recipes-kernel/linux/linux-imx/0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch b/recipes-kernel/linux/linux-imx/0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch
deleted file mode 100644
index b9ec1be3..00000000
--- a/recipes-kernel/linux/linux-imx/0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From fb3b9c2d217f1f51fffe19fc0f4eaf55e2d4ea4f Mon Sep 17 00:00:00 2001
2From: Lucas Stach <l.stach@pengutronix.de>
3Date: Wed, 10 Apr 2024 15:41:21 +0200
4Subject: [PATCH 6/6] video: logo: Drop full path of the input filename in
5 generated file
6
7Avoid this Yocto build warning to make build reproducible:
8
9 WARNING: linux-foo-6.8-r0 do_package_qa: QA Issue:
10 File /usr/src/debug/linux-foo/6.8-r0/drivers/video/logo/logo_linux_clut224.c
11 in package linux-foo-src contains reference to TMPDIR
12
13Helge modified the patch to drop the whole line.
14
15Upstream-Status: Backport [https://github.com/torvalds/linux/commit/fb3b9c2d217f1f51fffe19fc0f4eaf55e2d4ea4f]
16
17Signed-off-by: Lucas Stach <l.stach@pengutronix.de>
18Signed-off-by: Helge Deller <deller@gmx.de>
19---
20 drivers/video/logo/pnmtologo.c | 2 --
21 1 file changed, 2 deletions(-)
22
23diff --git a/drivers/video/logo/pnmtologo.c b/drivers/video/logo/pnmtologo.c
24index 2434a25afb64..8080c4d9c4a2 100644
25--- a/drivers/video/logo/pnmtologo.c
26+++ b/drivers/video/logo/pnmtologo.c
27@@ -235,8 +235,6 @@ static void write_header(void)
28 fputs("/*\n", out);
29 fputs(" * DO NOT EDIT THIS FILE!\n", out);
30 fputs(" *\n", out);
31- fprintf(out, " * It was automatically generated from %s\n", filename);
32- fputs(" *\n", out);
33 fprintf(out, " * Linux logo %s\n", logoname);
34 fputs(" */\n\n", out);
35 fputs("#include <linux/linux_logo.h>\n\n", out);
36--
372.34.1
38
diff --git a/recipes-kernel/linux/linux-imx_6.6.bb b/recipes-kernel/linux/linux-imx_6.6.bb
index 320e8a0f..e039dd9c 100644
--- a/recipes-kernel/linux/linux-imx_6.6.bb
+++ b/recipes-kernel/linux/linux-imx_6.6.bb
@@ -18,8 +18,6 @@ SRCREV = "e0f9e2afd4cff3f02d71891244b4aa5899dfc786"
18 18
19SRC_URI += " \ 19SRC_URI += " \
20 file://0001-tty-vt-conmakehash-Don-t-mention-the-full-path-of-th.patch \ 20 file://0001-tty-vt-conmakehash-Don-t-mention-the-full-path-of-th.patch \
21 file://0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch \
22 file://0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch \
23" 21"
24 22
25# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 23# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition