summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2025-01-14 09:57:55 -0800
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2025-01-21 15:17:16 +0000
commitf6ab99568ac277e1d5af545bfce29ea82573a6b6 (patch)
treeea1db702e42c19c777ca9c555285610b92c6fd2c
parentbdab4120eed6b14c513ec7250fa5abf70c753382 (diff)
downloadmeta-freescale-f6ab99568ac277e1d5af545bfce29ea82573a6b6.tar.gz
imx-gpu-apitrace: Simplify package config logic
There's no need for the SOC-specific overrides. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit fcf874bb22eb4a815b3c75fbff46ae30b6de45b3)
-rw-r--r--recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb16
1 files changed, 6 insertions, 10 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb
index 7d97f475..053fbf3e 100644
--- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb
+++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb
@@ -13,24 +13,20 @@ S = "${WORKDIR}/git"
13 13
14inherit cmake pkgconfig perlnative python3native 14inherit cmake pkgconfig perlnative python3native
15 15
16PACKAGECONFIG_BACKEND:mx6-nxp-bsp = " \ 16PACKAGECONFIG ??= " \
17 egl \
18 ${PACKAGECONFIG_BACKEND} \
19 ${PACKAGECONFIG_GPU2D} \
20"
21PACKAGECONFIG_BACKEND = " \
17 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'waffle', \ 22 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'waffle', \
18 bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \ 23 bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
19 '', d), d)} \ 24 '', d), d)} \
20" 25"
21PACKAGECONFIG_BACKEND:mx7-nxp-bsp = "${PACKAGECONFIG_BACKEND:mx6-nxp-bsp}"
22PACKAGECONFIG_BACKEND:mx8-nxp-bsp = "waffle"
23PACKAGECONFIG_BACKEND:mx95-nxp-bsp = "waffle"
24
25PACKAGECONFIG_GPU2D = "" 26PACKAGECONFIG_GPU2D = ""
26PACKAGECONFIG_GPU2D:imxgpu2d = "vivante" 27PACKAGECONFIG_GPU2D:imxgpu2d = "vivante"
27PACKAGECONFIG_GPU2D:mx95-nxp-bsp = "" 28PACKAGECONFIG_GPU2D:mx95-nxp-bsp = ""
28 29
29PACKAGECONFIG ??= " \
30 egl \
31 ${PACKAGECONFIG_BACKEND} \
32 ${PACKAGECONFIG_GPU2D} \
33"
34 30
35PACKAGECONFIG[egl] = "-DENABLE_EGL=ON,-DENABLE_EGL=OFF,virtual/egl" 31PACKAGECONFIG[egl] = "-DENABLE_EGL=ON,-DENABLE_EGL=OFF,virtual/egl"
36PACKAGECONFIG[gui] = "-DENABLE_GUI=ON,-DENABLE_GUI=OFF" 32PACKAGECONFIG[gui] = "-DENABLE_GUI=ON,-DENABLE_GUI=OFF"