diff options
author | Alexandru Avadanii <Alexandru.Avadanii@enea.com> | 2020-11-03 10:44:46 +0100 |
---|---|---|
committer | Adrian Dudau <Adrian.Dudau@enea.com> | 2020-12-14 14:14:38 +0100 |
commit | 409e90e04504715028019eb09cb75425a47ab3ee (patch) | |
tree | e1b6d16d14ed5255edcf8638991dd2239f841fa0 | |
parent | 18157262997a5e6999f36934fa107c09fced7991 (diff) | |
download | meta-el-nfv-access-409e90e04504715028019eb09cb75425a47ab3ee.tar.gz |
cleanup: remove run-postinsts, dpkg status-old
- initramfs: remove run-postinsts package, it has no purpose as there is
no package manager inside the initramfs;
- rootfs: remove run-postinsts if the package manager is DPKG/APT, since
it duplicates the existing dpkg-configure.service installed by the
dpkg recipe;
- rootfs: cleanup DPKG backup file 'status-old', it contains information
about packages before the final installation stages of the rootfs
build process (completely irrelevant for the end user), saves >500kB;
Change-Id: I6bd257d56805a3dfee4478c88977942e9f210afc
Signed-off-by: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
-rw-r--r-- | images/core-image-minimal-initramfs.bbappend | 4 | ||||
-rw-r--r-- | images/enea-nfv-access-common.inc | 11 |
2 files changed, 14 insertions, 1 deletions
diff --git a/images/core-image-minimal-initramfs.bbappend b/images/core-image-minimal-initramfs.bbappend index e743bb3..5512158 100644 --- a/images/core-image-minimal-initramfs.bbappend +++ b/images/core-image-minimal-initramfs.bbappend | |||
@@ -4,6 +4,9 @@ PACKAGE_INSTALL += " nfv-installer kernel-modules" | |||
4 | # ostree version specified in the kernel command line | 4 | # ostree version specified in the kernel command line |
5 | PACKAGE_INSTALL_append_sota = " ostree-switchroot" | 5 | PACKAGE_INSTALL_append_sota = " ostree-switchroot" |
6 | 6 | ||
7 | # run-postinsts does not belong in the minimal initramfs | ||
8 | PACKAGE_INSTALL_remove = "run-postinsts" | ||
9 | |||
7 | create_enea_symlink() { | 10 | create_enea_symlink() { |
8 | # enea image used in bare metal installation | 11 | # enea image used in bare metal installation |
9 | cd ${DEPLOY_DIR_IMAGE} | 12 | cd ${DEPLOY_DIR_IMAGE} |
@@ -12,4 +15,3 @@ create_enea_symlink() { | |||
12 | } | 15 | } |
13 | 16 | ||
14 | IMAGE_POSTPROCESS_COMMAND_append += " create_enea_symlink;" | 17 | IMAGE_POSTPROCESS_COMMAND_append += " create_enea_symlink;" |
15 | |||
diff --git a/images/enea-nfv-access-common.inc b/images/enea-nfv-access-common.inc index 3f9fc84..5472056 100644 --- a/images/enea-nfv-access-common.inc +++ b/images/enea-nfv-access-common.inc | |||
@@ -7,6 +7,17 @@ IMAGE_INSTALL += " \ | |||
7 | kernel-modules \ | 7 | kernel-modules \ |
8 | " | 8 | " |
9 | 9 | ||
10 | # run-postinsts duplicates dpkg-configure if package_deb is used | ||
11 | PACKAGE_INSTALL_remove = "${@bb.utils.contains('PACKAGE_CLASSES', 'package_deb', 'run-postinsts', '', d)}" | ||
12 | |||
13 | # After installing packages inside the rootfs, remove backup DPKG status file | ||
14 | rootfs_postinstall_dpkg_cleanup () { | ||
15 | if ${@bb.utils.contains('PACKAGE_CLASSES', 'package_deb', 'true', 'false', d)}; then | ||
16 | rm -f ${IMAGE_ROOTFS}/var/lib/dpkg/status-old | ||
17 | fi | ||
18 | } | ||
19 | ROOTFS_POSTINSTALL_COMMAND_append += " rootfs_postinstall_dpkg_cleanup;" | ||
20 | |||
10 | IMAGE_FSTYPES = "ext4 ext4.gz tar.gz" | 21 | IMAGE_FSTYPES = "ext4 ext4.gz tar.gz" |
11 | 22 | ||
12 | # Add ostree specific image types if sota support is set | 23 | # Add ostree specific image types if sota support is set |