diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-10-06 16:32:46 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-10-12 13:16:26 +0000 |
commit | c23e67cc73e4fe0d7c07dd79bd2380367d2047d6 (patch) | |
tree | dafbdaa5eb0ad95ed1bddf3744e27463caf52458 /meta-fsl-extras | |
parent | 7c988467d12fe6507e6ca2275c65d90b247a3e12 (diff) | |
download | meta-boot2qt-c23e67cc73e4fe0d7c07dd79bd2380367d2047d6.tar.gz |
apalis-imx6: add support for the new capasitive touch display
The atmel_mxt_ts controller needs to be enabled in the dtb,
done here for the ixora v1.1 dtb. Said dtb is also changed
to be the default dtb in the u-boot config.
Existing u-boot patch is updated to include console=tty1 removal
for all toradex boards.
Task-number: QTBUG-63344
Change-Id: Idaba988c2a0a5916c8fe6b6f11cc75981a9a28e2
Reviewed-by: Sami Nurmenniemi <sami.nurmenniemi@qt.io>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch | 63 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch (renamed from meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-apalis-imx6-enable-Fusion10-display-if-found-during-.patch) | 32 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend | 2 |
3 files changed, 72 insertions, 25 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch index bf7861e..f6dc0cc 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch | |||
@@ -1,20 +1,21 @@ | |||
1 | From 003b18993fe1c5b1e64a44a3b831c63afb0e9a94 Mon Sep 17 00:00:00 2001 | 1 | From f86bb70bd270967082cb8132eb68c3c3dea4a7a7 Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@qt.io> | 2 | From: Samuli Piippo <samuli.piippo@qt.io> |
3 | Date: Mon, 15 May 2017 15:31:36 +0300 | 3 | Date: Mon, 15 May 2017 15:31:36 +0300 |
4 | Subject: [PATCH] Make sdboot default on all boards | 4 | Subject: [PATCH 1/2] Make sdboot default on all boards |
5 | 5 | ||
6 | ... and remove console=tty1 from kernel args | ||
6 | --- | 7 | --- |
7 | include/configs/apalis_imx6.h | 3 ++- | 8 | include/configs/apalis_imx6.h | 5 +++-- |
8 | include/configs/colibri_imx6.h | 3 ++- | 9 | include/configs/colibri_imx6.h | 5 +++-- |
9 | include/configs/colibri_imx7.h | 2 +- | 10 | include/configs/colibri_imx7.h | 4 ++-- |
10 | include/configs/colibri_vf.h | 2 +- | 11 | include/configs/colibri_vf.h | 4 ++-- |
11 | 4 files changed, 6 insertions(+), 4 deletions(-) | 12 | 4 files changed, 10 insertions(+), 8 deletions(-) |
12 | 13 | ||
13 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h | 14 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h |
14 | index 8dce5af..4f2f689 100644 | 15 | index 76cbdf2..9b42af9 100644 |
15 | --- a/include/configs/apalis_imx6.h | 16 | --- a/include/configs/apalis_imx6.h |
16 | +++ b/include/configs/apalis_imx6.h | 17 | +++ b/include/configs/apalis_imx6.h |
17 | @@ -256,7 +256,8 @@ | 18 | @@ -257,7 +257,8 @@ |
18 | #endif | 19 | #endif |
19 | #define CONFIG_EXTRA_ENV_SETTINGS \ | 20 | #define CONFIG_EXTRA_ENV_SETTINGS \ |
20 | BOOTENV \ | 21 | BOOTENV \ |
@@ -24,11 +25,20 @@ index 8dce5af..4f2f689 100644 | |||
24 | "run distro_bootcmd ; " \ | 25 | "run distro_bootcmd ; " \ |
25 | "usb start ;" \ | 26 | "usb start ;" \ |
26 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ | 27 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ |
28 | @@ -280,7 +281,7 @@ | ||
29 | " ${loadaddr} flash_blk.img && " \ | ||
30 | "source ${loadaddr}\0" \ | ||
31 | "setup=setenv setupargs fec_mac=${ethaddr} " \ | ||
32 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | ||
33 | + "consoleblank=0 no_console_suspend=1 " \ | ||
34 | "console=${console},${baudrate}n8\0 " \ | ||
35 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
36 | "setusbupdate=usb start && setenv interface usb; setenv drive 0; " \ | ||
27 | diff --git a/include/configs/colibri_imx6.h b/include/configs/colibri_imx6.h | 37 | diff --git a/include/configs/colibri_imx6.h b/include/configs/colibri_imx6.h |
28 | index af49bcc..f6c6e9a 100644 | 38 | index ab561f3..cbaeece 100644 |
29 | --- a/include/configs/colibri_imx6.h | 39 | --- a/include/configs/colibri_imx6.h |
30 | +++ b/include/configs/colibri_imx6.h | 40 | +++ b/include/configs/colibri_imx6.h |
31 | @@ -231,7 +231,8 @@ | 41 | @@ -232,7 +232,8 @@ |
32 | #define FDT_FILE "imx6dl-colibri-eval-v3.dtb" | 42 | #define FDT_FILE "imx6dl-colibri-eval-v3.dtb" |
33 | #define CONFIG_EXTRA_ENV_SETTINGS \ | 43 | #define CONFIG_EXTRA_ENV_SETTINGS \ |
34 | BOOTENV \ | 44 | BOOTENV \ |
@@ -38,8 +48,17 @@ index af49bcc..f6c6e9a 100644 | |||
38 | "run distro_bootcmd ; " \ | 48 | "run distro_bootcmd ; " \ |
39 | "usb start ;" \ | 49 | "usb start ;" \ |
40 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ | 50 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ |
51 | @@ -253,7 +254,7 @@ | ||
52 | "${interface} ${drive}:1 ${loadaddr} flash_blk.img && " \ | ||
53 | "source ${loadaddr}\0" \ | ||
54 | "setup=setenv setupargs fec_mac=${ethaddr} " \ | ||
55 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | ||
56 | + "consoleblank=0 no_console_suspend=1 " \ | ||
57 | "console=${console},${baudrate}n8\0 " \ | ||
58 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
59 | "setusbupdate=usb start && setenv interface usb; setenv drive 0; " \ | ||
41 | diff --git a/include/configs/colibri_imx7.h b/include/configs/colibri_imx7.h | 60 | diff --git a/include/configs/colibri_imx7.h b/include/configs/colibri_imx7.h |
42 | index 1709032..01a8f43 100644 | 61 | index 2d6cee3..6773296 100644 |
43 | --- a/include/configs/colibri_imx7.h | 62 | --- a/include/configs/colibri_imx7.h |
44 | +++ b/include/configs/colibri_imx7.h | 63 | +++ b/include/configs/colibri_imx7.h |
45 | @@ -104,7 +104,7 @@ | 64 | @@ -104,7 +104,7 @@ |
@@ -51,8 +70,17 @@ index 1709032..01a8f43 100644 | |||
51 | "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;" | 70 | "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;" |
52 | 71 | ||
53 | #define BOOTENV_RUN_NET_USB_START "" | 72 | #define BOOTENV_RUN_NET_USB_START "" |
73 | @@ -138,7 +138,7 @@ | ||
74 | "fatload ${interface} 0:1 ${loadaddr} " \ | ||
75 | "${board}/flash_blk.img && source ${loadaddr}\0" \ | ||
76 | "setup=setenv setupargs " \ | ||
77 | - "console=tty1 console=${console}" \ | ||
78 | + "console=${console}" \ | ||
79 | ",${baudrate}n8 ${memargs} consoleblank=0\0" \ | ||
80 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
81 | "setusbupdate=usb start && setenv interface usb && " \ | ||
54 | diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h | 82 | diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h |
55 | index 6770f62..73a316a 100644 | 83 | index 7fea78b..5bc3e3d 100644 |
56 | --- a/include/configs/colibri_vf.h | 84 | --- a/include/configs/colibri_vf.h |
57 | +++ b/include/configs/colibri_vf.h | 85 | +++ b/include/configs/colibri_vf.h |
58 | @@ -155,7 +155,7 @@ | 86 | @@ -155,7 +155,7 @@ |
@@ -64,3 +92,12 @@ index 6770f62..73a316a 100644 | |||
64 | "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;" | 92 | "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;" |
65 | 93 | ||
66 | #define BOOTENV_RUN_NET_USB_START "" | 94 | #define BOOTENV_RUN_NET_USB_START "" |
95 | @@ -190,7 +190,7 @@ | ||
96 | "fatload ${interface} 0:1 ${loadaddr} " \ | ||
97 | "${board}/flash_blk.img && source ${loadaddr}\0" \ | ||
98 | "setup=setenv setupargs " \ | ||
99 | - "console=tty1 console=${console}" \ | ||
100 | + "console=${console}" \ | ||
101 | ",${baudrate}n8 ${memargs} consoleblank=0 ${mtdparts}\0" \ | ||
102 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
103 | "setusbupdate=usb start && setenv interface usb && " \ | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-apalis-imx6-enable-Fusion10-display-if-found-during-.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch index 2fcadc0..469009b 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-apalis-imx6-enable-Fusion10-display-if-found-during-.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch | |||
@@ -1,32 +1,42 @@ | |||
1 | From 5dc634b67f3b1890c5f166694ba9b81dd0a5a871 Mon Sep 17 00:00:00 2001 | 1 | From 138f477c5a1990429d35ffadc8f5cea5b1e9f945 Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@qt.io> | 2 | From: Samuli Piippo <samuli.piippo@qt.io> |
3 | Date: Fri, 19 May 2017 12:41:38 +0300 | 3 | Date: Fri, 19 May 2017 12:41:38 +0300 |
4 | Subject: [PATCH] apalis-imx6: enable Fusion10 display if found during boot | 4 | Subject: [PATCH 2/2] apalis-imx6: test for Capacitive Touch Display 7" |
5 | Parallel | ||
5 | 6 | ||
6 | Test i2c bus if Fusion10 display is present during boot. | 7 | Test i2c bus if Capacitive Touch Display 7" Parallel display is present |
7 | If found, enable it as the primary display in kernel args. | 8 | during boot. If found, enable it as the primary display in kernel args. |
8 | 9 | ||
9 | Also remove console from tty1, as it overlays with Qt. | 10 | Set imx6q-apalis-ixora-v1.1.dtb as the default dtb, as it provides |
11 | support for the atmel_mxt_ts touch controller. | ||
10 | --- | 12 | --- |
11 | include/configs/apalis_imx6.h | 9 +++++++-- | 13 | include/configs/apalis_imx6.h | 9 +++++++-- |
12 | 1 file changed, 7 insertions(+), 2 deletions(-) | 14 | 1 file changed, 7 insertions(+), 2 deletions(-) |
13 | 15 | ||
14 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h | 16 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h |
15 | index 4f2f689..de18b43 100644 | 17 | index 9b42af9..121eaa7 100644 |
16 | --- a/include/configs/apalis_imx6.h | 18 | --- a/include/configs/apalis_imx6.h |
17 | +++ b/include/configs/apalis_imx6.h | 19 | +++ b/include/configs/apalis_imx6.h |
18 | @@ -279,9 +279,14 @@ | 20 | @@ -250,7 +250,7 @@ |
21 | "${fdt_file} && setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | ||
22 | |||
23 | #ifndef CONFIG_TDX_APALIS_IMX6_V1_0 | ||
24 | -#define FDT_FILE "imx6q-apalis-eval.dtb" | ||
25 | +#define FDT_FILE "imx6q-apalis-ixora-v1.1.dtb" | ||
26 | #define FDT_FILE_V1_0 "imx6q-apalis_v1_0-eval.dtb" | ||
27 | #else | ||
28 | #define FDT_FILE "imx6q-apalis_v1_0-eval.dtb" | ||
29 | @@ -280,9 +280,14 @@ | ||
19 | "|| setenv drive 2; mmc rescan; load ${interface} ${drive}:1" \ | 30 | "|| setenv drive 2; mmc rescan; load ${interface} ${drive}:1" \ |
20 | " ${loadaddr} flash_blk.img && " \ | 31 | " ${loadaddr} flash_blk.img && " \ |
21 | "source ${loadaddr}\0" \ | 32 | "source ${loadaddr}\0" \ |
22 | - "setup=setenv setupargs fec_mac=${ethaddr} " \ | 33 | - "setup=setenv setupargs fec_mac=${ethaddr} " \ |
23 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | ||
24 | + "setup=run setupvideo; setenv setupargs fec_mac=${ethaddr} " \ | 34 | + "setup=run setupvideo; setenv setupargs fec_mac=${ethaddr} " \ |
25 | + "consoleblank=0 no_console_suspend=1 " \ | 35 | "consoleblank=0 no_console_suspend=1 " \ |
26 | "console=${console},${baudrate}n8\0 " \ | 36 | "console=${console},${baudrate}n8\0 " \ |
27 | + "setupvideo=i2c dev 0; if i2c probe 50; " \ | 37 | + "setupvideo=i2c dev 0; if i2c probe 4A; " \ |
28 | + "then setenv vidargs mxc_hdmi.only_cea=1 " \ | 38 | + "then setenv vidargs mxc_hdmi.only_cea=1 " \ |
29 | + "video=mxcfb0:dev=lcd,FusionF10A,if=RGB24 " \ | 39 | + "video=mxcfb0:dev=lcd,FusionF07A,if=RGB24 " \ |
30 | + "video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off " \ | 40 | + "video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off " \ |
31 | + "fbmem=32M; fi\0" \ | 41 | + "fbmem=32M; fi\0" \ |
32 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | 42 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ |
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend index 7d7f373..e501f5e 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend | |||
@@ -30,5 +30,5 @@ | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
31 | SRC_URI += " \ | 31 | SRC_URI += " \ |
32 | file://0001-Make-sdboot-default-on-all-boards.patch \ | 32 | file://0001-Make-sdboot-default-on-all-boards.patch \ |
33 | file://0001-apalis-imx6-enable-Fusion10-display-if-found-during-.patch \ | 33 | file://0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch \ |
34 | " | 34 | " |